aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2013-12-08 16:06:03 +0800
committerkoobs <koobs@FreeBSD.org>2013-12-08 16:06:03 +0800
commitbc023f99acdaf2bf3197a03353c9510105d45060 (patch)
tree84cf90d5ce867b84a1f1e1a0c0f0abbee5cba4e3 /lang
parentec87b01d4dc3d786471eb78015e919a516283143 (diff)
downloadfreebsd-ports-gnome-bc023f99acdaf2bf3197a03353c9510105d45060.tar.gz
freebsd-ports-gnome-bc023f99acdaf2bf3197a03353c9510105d45060.tar.zst
freebsd-ports-gnome-bc023f99acdaf2bf3197a03353c9510105d45060.zip
lang/python26: Add FreeBSD 11 support, enable POSIX Semaphores on FreeBSD 7+
Finish off adding FreeBSD 11 support to our Python ports by backporting wg@'s changesets [1] and [2], and mine from python32 [3] to lang/python26. These changes also bring more consistency and reduced diffs between ports [1] https://svnweb.freebsd.org/ports?view=revision&revision=333665 [2] https://svnweb.freebsd.org/ports?view=revision&revision=333487 [3] https://svnweb.freebsd.org/ports?view=revision&revision=335376 Reviewed by: milki
Diffstat (limited to 'lang')
-rw-r--r--lang/python26/Makefile4
-rw-r--r--lang/python26/files/extra-patch-setup.py4
-rw-r--r--lang/python26/files/patch-setup.py20
-rw-r--r--lang/python26/pkg-plist3
4 files changed, 21 insertions, 10 deletions
diff --git a/lang/python26/Makefile b/lang/python26/Makefile
index e5a4fec93acb..af7896702ed2 100644
--- a/lang/python26/Makefile
+++ b/lang/python26/Makefile
@@ -46,7 +46,7 @@ EXAMPLESDIR= ${PREFIX}/share/examples/${PYTHON_VERSION}
DATADIR= ${PREFIX}/share/${PYTHON_VERSION}
PLATFORMS= plat-freebsd6 plat-freebsd7 plat-freebsd8 plat-freebsd9 \
- plat-freebsd10
+ plat-freebsd10 plat-freebsd11
BIN_SCRIPTS= 2to3 idle pydoc smtpd.py
BIN_FILES= python python-shared python-config python-shared-config \
@@ -160,6 +160,8 @@ pre-patch:
${PATCH_WRKSRC}/Lib/plat-freebsd9
${CP} -r ${PATCH_WRKSRC}/Lib/plat-freebsd8 \
${PATCH_WRKSRC}/Lib/plat-freebsd10
+ ${CP} -r ${PATCH_WRKSRC}/Lib/plat-freebsd8 \
+ ${PATCH_WRKSRC}/Lib/plat-freebsd11
${MKDIR} ${WRKSRC} ${SHARED_WRKSRC}/Modules
${LN} ${PATCH_WRKSRC}/Lib/smtpd.py ${PATCH_WRKSRC}/Tools/scripts/
.for script in ${BIN_SCRIPTS}
diff --git a/lang/python26/files/extra-patch-setup.py b/lang/python26/files/extra-patch-setup.py
index 1122acac8054..28fe87aaced3 100644
--- a/lang/python26/files/extra-patch-setup.py
+++ b/lang/python26/files/extra-patch-setup.py
@@ -4,7 +4,7 @@
)
libraries = []
-- elif platform in ('freebsd4', 'freebsd5', 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10'):
+- elif platform in ('freebsd4', 'freebsd5', 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10', 'freebsd11'):
+ elif platform in ('freebsd4', 'freebsd5', 'freebsd6'):
# FreeBSD's P1003.1b semaphore support is very experimental
# and has many known problems. (as of June 2008)
@@ -16,7 +16,7 @@
+ )
+ libraries = []
+
-+ elif platform in ('freebsd7', 'freebsd8', 'freebsd9', 'freebsd10'):
++ elif platform in ('freebsd7', 'freebsd8', 'freebsd9', 'freebsd10', 'freebsd11'):
+ macros = dict( # FreeBSD 7+
+ HAVE_SEM_OPEN=1,
+ HAVE_SEM_TIMEDWAIT=1,
diff --git a/lang/python26/files/patch-setup.py b/lang/python26/files/patch-setup.py
index 271cda1f30be..174c816cd0ee 100644
--- a/lang/python26/files/patch-setup.py
+++ b/lang/python26/files/patch-setup.py
@@ -1,5 +1,5 @@
---- setup.py.orig 2010-07-17 20:31:09.000000000 +0800
-+++ setup.py 2010-09-03 08:59:33.000000000 +0800
+--- ./setup.py.orig 2013-10-30 02:04:39.000000000 +1100
++++ ./setup.py 2013-12-08 18:42:28.054900011 +1100
@@ -18,7 +18,7 @@
from distutils.spawn import find_executable
@@ -73,20 +73,26 @@
libraries = []
- elif platform in ('freebsd4', 'freebsd5', 'freebsd6', 'freebsd7', 'freebsd8'):
-+ elif platform in ('freebsd4', 'freebsd5', 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10'):
++ elif platform in ('freebsd4', 'freebsd5', 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10', 'freebsd11'):
# FreeBSD's P1003.1b semaphore support is very experimental
# and has many known problems. (as of June 2008)
macros = dict( # FreeBSD
-@@ -1450,7 +1454,7 @@
+@@ -1449,8 +1453,12 @@
+ else:
missing.append('linuxaudiodev')
- if platform in ('linux2', 'freebsd4', 'freebsd5', 'freebsd6',
+- if platform in ('linux2', 'freebsd4', 'freebsd5', 'freebsd6',
- 'freebsd7', 'freebsd8'):
-+ 'freebsd7', 'freebsd8', 'freebsd9', 'freebsd10'):
++ #############################
++ # Backport Commit: http://hg.python.org/cpython/rev/50f1922bc1d5
++ # Backport Issue: http://bugs.python.org/issue12326
++ #############################
++ if any(platform.startswith(prefix)
++ for prefix in ("linux", "freebsd", "gnukfreebsd")):
exts.append( Extension('ossaudiodev', ['ossaudiodev.c']) )
else:
missing.append('ossaudiodev')
-@@ -2026,9 +2030,7 @@
+@@ -2026,9 +2034,7 @@
ext_modules=[Extension('_struct', ['_struct.c'])],
# Scripts to install
diff --git a/lang/python26/pkg-plist b/lang/python26/pkg-plist
index ff3bee18d807..1375d2133dd0 100644
--- a/lang/python26/pkg-plist
+++ b/lang/python26/pkg-plist
@@ -913,6 +913,8 @@ lib/lib%%PYTHON_VERSION%%.so.1
%%PYTHON_LIBDIR%%/plat-freebsd9/regen
%%PYTHON_LIBDIR%%/plat-freebsd10/IN.py
%%PYTHON_LIBDIR%%/plat-freebsd10/regen
+%%PYTHON_LIBDIR%%/plat-freebsd11/IN.py
+%%PYTHON_LIBDIR%%/plat-freebsd11/regen
%%PYTHON_LIBDIR%%/platform.py
%%PYTHON_LIBDIR%%/plistlib.py
%%PYTHON_LIBDIR%%/popen2.py
@@ -2216,6 +2218,7 @@ lib/libpython2.6.a
@dirrm %%PYTHON_LIBDIR%%/sqlite3/test
@dirrm %%PYTHON_LIBDIR%%/sqlite3
@dirrm %%PYTHON_LIBDIR%%/site-packages
+@dirrm %%PYTHON_LIBDIR%%/plat-freebsd11
@dirrm %%PYTHON_LIBDIR%%/plat-freebsd10
@dirrm %%PYTHON_LIBDIR%%/plat-freebsd9
@dirrm %%PYTHON_LIBDIR%%/plat-freebsd8