aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2017-12-17 18:19:10 +0800
committerlwhsu <lwhsu@FreeBSD.org>2017-12-17 18:19:10 +0800
commitcf034033ae8ccb6ab338fb235790dd4c6a604518 (patch)
tree02204a2ada702960d135f28f397ab35fc8675f2c /lang
parentcc72cfeb6a53dc9d0836bb844fd197e46a063774 (diff)
downloadfreebsd-ports-gnome-cf034033ae8ccb6ab338fb235790dd4c6a604518.tar.gz
freebsd-ports-gnome-cf034033ae8ccb6ab338fb235790dd4c6a604518.tar.zst
freebsd-ports-gnome-cf034033ae8ccb6ab338fb235790dd4c6a604518.zip
Add an upstream patch:
http://git.php.net/?p=php-src.git;a=commit;h=72ec23d8233ac9a2071f991752cff55febb167d5 This eliminate a warning while building with clang on 32-bit system and enable other programs' configure scripts test PHP feature with `-Werror` Approved by: tz (maintainer)
Diffstat (limited to 'lang')
-rw-r--r--lang/php70/Makefile2
-rw-r--r--lang/php70/files/patch-Zend_zend__hash.c11
-rw-r--r--lang/php70/files/patch-Zend_zend__hash.h11
-rw-r--r--lang/php71/Makefile2
-rw-r--r--lang/php71/files/patch-Zend_zend__hash.c11
-rw-r--r--lang/php71/files/patch-Zend_zend__hash.h11
-rw-r--r--lang/php72/Makefile2
-rw-r--r--lang/php72/files/patch-Zend_zend__hash.c11
-rw-r--r--lang/php72/files/patch-Zend_zend__hash.h11
9 files changed, 69 insertions, 3 deletions
diff --git a/lang/php70/Makefile b/lang/php70/Makefile
index 521b1281ce57..ad11b682c1c2 100644
--- a/lang/php70/Makefile
+++ b/lang/php70/Makefile
@@ -3,7 +3,7 @@
PORTNAME= php70
PORTVERSION= 7.0.26
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES?= lang devel www
MASTER_SITES= PHP/distributions
DISTNAME= php-${PORTVERSION}
diff --git a/lang/php70/files/patch-Zend_zend__hash.c b/lang/php70/files/patch-Zend_zend__hash.c
new file mode 100644
index 000000000000..76605dee39c5
--- /dev/null
+++ b/lang/php70/files/patch-Zend_zend__hash.c
@@ -0,0 +1,11 @@
+--- Zend/zend_hash.c.orig 2017-12-13 20:20:30 UTC
++++ Zend/zend_hash.c
+@@ -1573,7 +1573,7 @@ ZEND_API void ZEND_FASTCALL zend_hash_ap
+ }
+
+
+-ZEND_API void ZEND_FASTCALL zend_hash_apply_with_arguments(HashTable *ht, apply_func_args_t apply_func, int num_args, ...)
++ZEND_API void zend_hash_apply_with_arguments(HashTable *ht, apply_func_args_t apply_func, int num_args, ...)
+ {
+ uint32_t idx;
+ Bucket *p;
diff --git a/lang/php70/files/patch-Zend_zend__hash.h b/lang/php70/files/patch-Zend_zend__hash.h
new file mode 100644
index 000000000000..37edf40daddd
--- /dev/null
+++ b/lang/php70/files/patch-Zend_zend__hash.h
@@ -0,0 +1,11 @@
+--- Zend/zend_hash.h.orig 2017-12-13 20:20:24 UTC
++++ Zend/zend_hash.h
+@@ -131,7 +131,7 @@ ZEND_API void ZEND_FASTCALL zend_hash_gr
+ ZEND_API void ZEND_FASTCALL zend_hash_graceful_reverse_destroy(HashTable *ht);
+ ZEND_API void ZEND_FASTCALL zend_hash_apply(HashTable *ht, apply_func_t apply_func);
+ ZEND_API void ZEND_FASTCALL zend_hash_apply_with_argument(HashTable *ht, apply_func_arg_t apply_func, void *);
+-ZEND_API void ZEND_FASTCALL zend_hash_apply_with_arguments(HashTable *ht, apply_func_args_t apply_func, int, ...);
++ZEND_API void zend_hash_apply_with_arguments(HashTable *ht, apply_func_args_t apply_func, int, ...);
+
+ /* This function should be used with special care (in other words,
+ * it should usually not be used). When used with the ZEND_HASH_APPLY_STOP
diff --git a/lang/php71/Makefile b/lang/php71/Makefile
index 9ab219ca7147..ee26bcb54442 100644
--- a/lang/php71/Makefile
+++ b/lang/php71/Makefile
@@ -3,7 +3,7 @@
PORTNAME= php71
PORTVERSION= 7.1.12
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES?= lang devel www
MASTER_SITES= PHP/distributions
DISTNAME= php-${PORTVERSION}
diff --git a/lang/php71/files/patch-Zend_zend__hash.c b/lang/php71/files/patch-Zend_zend__hash.c
new file mode 100644
index 000000000000..fd92c31802ae
--- /dev/null
+++ b/lang/php71/files/patch-Zend_zend__hash.c
@@ -0,0 +1,11 @@
+--- Zend/zend_hash.c.orig 2017-12-13 20:22:03 UTC
++++ Zend/zend_hash.c
+@@ -1544,7 +1544,7 @@ ZEND_API void ZEND_FASTCALL zend_hash_ap
+ }
+
+
+-ZEND_API void ZEND_FASTCALL zend_hash_apply_with_arguments(HashTable *ht, apply_func_args_t apply_func, int num_args, ...)
++ZEND_API void zend_hash_apply_with_arguments(HashTable *ht, apply_func_args_t apply_func, int num_args, ...)
+ {
+ uint32_t idx;
+ Bucket *p;
diff --git a/lang/php71/files/patch-Zend_zend__hash.h b/lang/php71/files/patch-Zend_zend__hash.h
new file mode 100644
index 000000000000..ba3f8fd157fd
--- /dev/null
+++ b/lang/php71/files/patch-Zend_zend__hash.h
@@ -0,0 +1,11 @@
+--- Zend/zend_hash.h.orig 2017-12-13 20:15:42 UTC
++++ Zend/zend_hash.h
+@@ -138,7 +138,7 @@ ZEND_API void ZEND_FASTCALL zend_hash_gr
+ ZEND_API void ZEND_FASTCALL zend_hash_graceful_reverse_destroy(HashTable *ht);
+ ZEND_API void ZEND_FASTCALL zend_hash_apply(HashTable *ht, apply_func_t apply_func);
+ ZEND_API void ZEND_FASTCALL zend_hash_apply_with_argument(HashTable *ht, apply_func_arg_t apply_func, void *);
+-ZEND_API void ZEND_FASTCALL zend_hash_apply_with_arguments(HashTable *ht, apply_func_args_t apply_func, int, ...);
++ZEND_API void zend_hash_apply_with_arguments(HashTable *ht, apply_func_args_t apply_func, int, ...);
+
+ /* This function should be used with special care (in other words,
+ * it should usually not be used). When used with the ZEND_HASH_APPLY_STOP
diff --git a/lang/php72/Makefile b/lang/php72/Makefile
index 19e4fbed004f..fc0cf633fd3f 100644
--- a/lang/php72/Makefile
+++ b/lang/php72/Makefile
@@ -2,7 +2,7 @@
PORTNAME= php72
DISTVERSION= 7.2.0
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= lang devel www
MASTER_SITES= PHP/distributions
DISTNAME= php-${DISTVERSION}
diff --git a/lang/php72/files/patch-Zend_zend__hash.c b/lang/php72/files/patch-Zend_zend__hash.c
new file mode 100644
index 000000000000..7e17e8e14ddf
--- /dev/null
+++ b/lang/php72/files/patch-Zend_zend__hash.c
@@ -0,0 +1,11 @@
+--- Zend/zend_hash.c.orig 2017-12-13 20:23:18 UTC
++++ Zend/zend_hash.c
+@@ -1543,7 +1543,7 @@ ZEND_API void ZEND_FASTCALL zend_hash_ap
+ }
+
+
+-ZEND_API void ZEND_FASTCALL zend_hash_apply_with_arguments(HashTable *ht, apply_func_args_t apply_func, int num_args, ...)
++ZEND_API void zend_hash_apply_with_arguments(HashTable *ht, apply_func_args_t apply_func, int num_args, ...)
+ {
+ uint32_t idx;
+ Bucket *p;
diff --git a/lang/php72/files/patch-Zend_zend__hash.h b/lang/php72/files/patch-Zend_zend__hash.h
new file mode 100644
index 000000000000..b8ba82611676
--- /dev/null
+++ b/lang/php72/files/patch-Zend_zend__hash.h
@@ -0,0 +1,11 @@
+--- Zend/zend_hash.h.orig 2017-12-13 20:16:12 UTC
++++ Zend/zend_hash.h
+@@ -145,7 +145,7 @@ ZEND_API void ZEND_FASTCALL zend_hash_gr
+ ZEND_API void ZEND_FASTCALL zend_hash_graceful_reverse_destroy(HashTable *ht);
+ ZEND_API void ZEND_FASTCALL zend_hash_apply(HashTable *ht, apply_func_t apply_func);
+ ZEND_API void ZEND_FASTCALL zend_hash_apply_with_argument(HashTable *ht, apply_func_arg_t apply_func, void *);
+-ZEND_API void ZEND_FASTCALL zend_hash_apply_with_arguments(HashTable *ht, apply_func_args_t apply_func, int, ...);
++ZEND_API void zend_hash_apply_with_arguments(HashTable *ht, apply_func_args_t apply_func, int, ...);
+
+ /* This function should be used with special care (in other words,
+ * it should usually not be used). When used with the ZEND_HASH_APPLY_STOP