aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2006-06-17 21:33:15 +0800
committergerald <gerald@FreeBSD.org>2006-06-17 21:33:15 +0800
commitd446b7301e34e9ecea38f97c83927ac5fa90dfa4 (patch)
tree56ecc29aeb04473145f6d8cbd8307ed931f70491 /lang
parent9d3b6a8a689c1fc9fc8f77379eff82a7317ed576 (diff)
downloadfreebsd-ports-gnome-d446b7301e34e9ecea38f97c83927ac5fa90dfa4.tar.gz
freebsd-ports-gnome-d446b7301e34e9ecea38f97c83927ac5fa90dfa4.tar.zst
freebsd-ports-gnome-d446b7301e34e9ecea38f97c83927ac5fa90dfa4.zip
Employ the new USE_LDCONFIG feature, which allows us to get rid of the
various, much more manual and error-prone hacks we needed so far. Reviewed by: flz (for lang/gcc40)
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc41/Makefile8
-rw-r--r--lang/gcc41/files/gcc.sh.in14
-rw-r--r--lang/gcc41/pkg-plist1
3 files changed, 1 insertions, 22 deletions
diff --git a/lang/gcc41/Makefile b/lang/gcc41/Makefile
index e751ef648b88..c8b08943e58a 100644
--- a/lang/gcc41/Makefile
+++ b/lang/gcc41/Makefile
@@ -71,11 +71,7 @@ CONFIGURE_ARGS+= --enable-java-awt=xlib,gtk
.endif
MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
ALL_TARGET= bootstrap-lean
-INSTALLS_SHLIB= yes
-LDCONFIG_DIRS= ${TARGLIB}
-SUB_LIST= TARGLIB="${TARGLIB}"
-SUB_FILES= gcc.sh
-RC_D_SH= etc/rc.d/gcc${SUFFIX}.sh
+USE_LDCONFIG= ${TARGLIB}
PLIST_SUB= GCC_VER=${PORTVERSION} GNU_HOST=${CONFIGURE_TARGET} \
SUFFIX=${SUFFIX}
MAN1= cpp${SUFFIX}.1 \
@@ -146,8 +142,6 @@ check: build
cd ${WRKSRC}; export RUNTESTFLAGS='--target_board ''unix{-pthread}'''; ${GMAKE} -sk check
post-install:
- -@${MKDIR} ${PREFIX}/etc/rc.d
- ${INSTALL_SCRIPT} ${WRKDIR}/gcc.sh ${PREFIX}/${RC_D_SH}
# man pages can only be generated if Perl >= 5.6 is installed;
# fake them otherwise.
for mp in ${_MANPAGES}; do \
diff --git a/lang/gcc41/files/gcc.sh.in b/lang/gcc41/files/gcc.sh.in
deleted file mode 100644
index 987e9531e371..000000000000
--- a/lang/gcc41/files/gcc.sh.in
+++ /dev/null
@@ -1,14 +0,0 @@
-#!/bin/sh
-
-case "$1" in
-start)
- ldconfig -m %%TARGLIB%%
- ;;
-stop)
- ;;
-*)
- echo "Usage: ${0##*/} { start | stop }" >&2
- exit 64
- ;;
-esac
-exit 0
diff --git a/lang/gcc41/pkg-plist b/lang/gcc41/pkg-plist
index 867fee686215..5fdc2d7941d0 100644
--- a/lang/gcc41/pkg-plist
+++ b/lang/gcc41/pkg-plist
@@ -9,7 +9,6 @@ bin/%%GNU_HOST%%-c++%%SUFFIX%%
bin/%%GNU_HOST%%-g++%%SUFFIX%%
bin/%%GNU_HOST%%-gcc-%%GCC_VER%%
bin/%%GNU_HOST%%-gcc%%SUFFIX%%
-etc/rc.d/gcc%%SUFFIX%%.sh
info/gcc%%SUFFIX%%/dir
%%FORTRAN%%bin/gfortran%%SUFFIX%%
%%FORTRAN%%bin/%%GNU_HOST%%-gfortran%%SUFFIX%%