aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2007-07-30 23:03:09 +0800
committermm <mm@FreeBSD.org>2007-07-30 23:03:09 +0800
commitd4c22d8042e64de83d51641a4e89411461adc16d (patch)
treef7436ea204f03f1bed0b6b945f7e50c2d80e80e7 /lang
parentb65617e8486df40df8ac6306e4f2bc47d5800969 (diff)
downloadfreebsd-ports-gnome-d4c22d8042e64de83d51641a4e89411461adc16d.tar.gz
freebsd-ports-gnome-d4c22d8042e64de83d51641a4e89411461adc16d.tar.zst
freebsd-ports-gnome-d4c22d8042e64de83d51641a4e89411461adc16d.zip
- Unbreak by removing check for unused X11/Intrinsic.h
- Reorganize post-patch for better readability Approved by: garga (mentor, implicit)
Diffstat (limited to 'lang')
-rw-r--r--lang/otcl/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/lang/otcl/Makefile b/lang/otcl/Makefile
index a4c93b71c186..b9f23f7a2c2d 100644
--- a/lang/otcl/Makefile
+++ b/lang/otcl/Makefile
@@ -37,12 +37,15 @@ CFLAGS+= -DHAVE_UNISTD_H
CONFIGURE_ARGS+= --with-tcl-ver=${TCL_VER} --with-tk-ver=${TK_VER}
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/X11R6|${X11BASE}|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|/usr/X11R6|${X11BASE}|g' ${WRKSRC}/conf/configure.in.x11
+ @${REINPLACE_CMD} -e 's|/usr/X11R6|${X11BASE}|g' \
+ -e's|X11/Intrinsic.h|X11/Xlib.h|g' \
+ ${WRKSRC}/configure ${WRKSRC}/conf/configure.in.x11
@${REINPLACE_CMD} -e 's|../lib/tcl$$TCL_HI_VERS|${TCL_LIBDIR}|g' \
- -e 's|../include|${TCL_INCLUDEDIR}/generic|g' ${WRKSRC}/conf/configure.in.tcl
+ -e 's|../include|${TCL_INCLUDEDIR}/generic|g' \
+ ${WRKSRC}/conf/configure.in.tcl
@${REINPLACE_CMD} -e 's|../lib/tk$$TK_HI_VERS|${TK_LIBDIR}|g' \
- -e 's|../include|${TK_INCLUDEDIR}/generic|g' ${WRKSRC}/conf/configure.in.tk
+ -e 's|../include|${TK_INCLUDEDIR}/generic|g' \
+ ${WRKSRC}/conf/configure.in.tk
post-install:
${LN} -sf libotcl.so ${PREFIX}/lib/libotcl.so.1