aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authortz <tz@FreeBSD.org>2017-06-09 17:44:33 +0800
committertz <tz@FreeBSD.org>2017-06-09 17:44:33 +0800
commite9880ccd763c9105f63a8da5896f30137bdd2cfa (patch)
tree36c495c00ee250b823c2e6ea150db846fe8bc1f4 /lang
parent42067aef2f8f27c07350f45c9a9c50a25d7428ac (diff)
downloadfreebsd-ports-gnome-e9880ccd763c9105f63a8da5896f30137bdd2cfa.tar.gz
freebsd-ports-gnome-e9880ccd763c9105f63a8da5896f30137bdd2cfa.tar.zst
freebsd-ports-gnome-e9880ccd763c9105f63a8da5896f30137bdd2cfa.zip
graphics/php71-gd: remove options T1LIB and VPX, add option WEBP
Support for T1LIB and VPX was removed in PHP 7.0 Support for WebP support was added in PHP 7.0 PR: 219837 Submitted by: Dani <i.dani@outlook.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/php71/Makefile.ext22
1 files changed, 8 insertions, 14 deletions
diff --git a/lang/php71/Makefile.ext b/lang/php71/Makefile.ext
index b4ffaee45333..39c9ab4c0c4d 100644
--- a/lang/php71/Makefile.ext
+++ b/lang/php71/Makefile.ext
@@ -100,14 +100,13 @@ CONFIGURE_ARGS+=--with-gd \
--with-png-dir=${LOCALBASE} \
--with-zlib-dir=/usr
-OPTIONS_DEFINE= T1LIB TRUETYPE JIS X11 VPX
-OPTIONS_DEFAULT=T1LIB TRUETYPE X11
+OPTIONS_DEFINE=TRUETYPE JIS WEBP X11
+OPTIONS_DEFAULT=TRUETYPE X11
-T1LIB_DESC= Include T1lib support
TRUETYPE_DESC= Enable TrueType string function
JIS_DESC= Enable JIS-mapped Japanese font support
+WEBP_DESC= Enable WebP image format support
X11_DESC= Enable XPM support
-VPX_DESC= Enable VP8 codec support
PHP_HEADER_DIRS=libgd
.endif
@@ -505,27 +504,22 @@ USES+= mysql
.include <bsd.port.pre.mk>
.if ${PHP_MODNAME} == "gd"
-. if ${PORT_OPTIONS:MT1LIB}
-LIB_DEPENDS+= libt1.so:devel/t1lib
-
-CONFIGURE_ARGS+=--with-t1lib=${LOCALBASE}
-. endif
. if ${PORT_OPTIONS:MTRUETYPE}
CONFIGURE_ARGS+=--enable-gd-native-ttf
. endif
. if ${PORT_OPTIONS:MJIS}
CONFIGURE_ARGS+=--enable-gd-jis-conv
. endif
+. if ${PORT_OPTIONS:MWEBP}
+LIB_DEPENDS+= libwebp.so:graphics/webp
+
+CONFIGURE_ARGS+=--with-webp-dir=${LOCALBASE}
+. endif
. if ${PORT_OPTIONS:MX11}
USE_XORG= xpm
CONFIGURE_ARGS+=--with-xpm-dir=${LOCALBASE}
. endif
-. if ${PORT_OPTIONS:MVPX}
-LIB_DEPENDS+= libvpx.so:multimedia/libvpx
-
-CONFIGURE_ARGS+=--with-vpx-dir=${LOCALBASE}
-. endif
.endif
.if ${PHP_MODNAME} == "imap"