aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2012-10-18 15:03:50 +0800
committervanilla <vanilla@FreeBSD.org>2012-10-18 15:03:50 +0800
commitf2a385e732a54d6bfbb1d3fea13af763fd8cf112 (patch)
treead76ad7a7548da50028bfeada4a395729d8fe19d /lang
parent9833d6412a6d2443a78885a831870ce96136c4b9 (diff)
downloadfreebsd-ports-gnome-f2a385e732a54d6bfbb1d3fea13af763fd8cf112.tar.gz
freebsd-ports-gnome-f2a385e732a54d6bfbb1d3fea13af763fd8cf112.tar.zst
freebsd-ports-gnome-f2a385e732a54d6bfbb1d3fea13af763fd8cf112.zip
Upgrade to 0.4.
PR: ports/172791 Submitted by: maintainer Feature safe: yes
Diffstat (limited to 'lang')
-rw-r--r--lang/rust/Makefile15
-rw-r--r--lang/rust/distinfo8
-rw-r--r--lang/rust/files/log2.patch48
-rw-r--r--lang/rust/files/patch-configure19
-rw-r--r--lang/rust/files/patch-src_libcore_cmath.rs10
-rw-r--r--lang/rust/files/patch-src_libcore_f32.rs22
-rw-r--r--lang/rust/files/tgammaf.patch32
-rw-r--r--lang/rust/pkg-plist16
8 files changed, 121 insertions, 49 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index 0ae844fe8ca1..f4c17a852b0a 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= rust
-PORTVERSION= 0.3
+PORTVERSION= 0.4
CATEGORIES= lang
MASTER_SITES= http://dl.rust-lang.org/dist/:src \
http://dl.rust-lang.org/stage0-snapshots/:boot
@@ -19,7 +19,7 @@ COMMENT= A language with a focus on memory safety and concurrency
RUST_SOURCE= ${DISTNAME}${EXTRACT_SUFX}
RUST_BOOT= rust-stage0-${RUST_BOOT_SIG}.tar.bz2
-RUST_BOOT_SIG= 2012-07-06-b5f5676-freebsd-x86_64-926e17746576397c10af9796d30af6a730329f71
+RUST_BOOT_SIG= 2012-10-09-cd6f24f-freebsd-x86_64-a2b5e9dddfa8f21cc8a068b77a47ba5425bfdcc6
RUST_TARGET= x86_64-unknown-freebsd
ONLY_FOR_ARCHS= amd64
@@ -38,6 +38,14 @@ OPTIONS_DEFAULT= CARGO
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 900044
+EXTRA_PATCHES+= ${FILESDIR}/log2.patch
+.endif
+
+.if ${OSVERSION} < 801000
+EXTRA_PATCHES+= ${FILESDIR}/tgammaf.patch
+.endif
+
.if ${OSVERSION} >= 900044
LIB_DEPENDS+= unwind:${PORTSDIR}/devel/libunwind
CC= clang
@@ -69,9 +77,6 @@ post-extract:
post-patch:
${REINPLACE_CMD} \
- -e '/probe_need CFG_CURL/d' \
- ${WRKSRC}/configure
- ${REINPLACE_CMD} \
-e 's|subprocess.call(\["curl"|subprocess.call(["fetch"|' \
${WRKSRC}/src/etc/snapshot.py
${REINPLACE_CMD} \
diff --git a/lang/rust/distinfo b/lang/rust/distinfo
index c54251c477ae..31a7f2d87b83 100644
--- a/lang/rust/distinfo
+++ b/lang/rust/distinfo
@@ -1,4 +1,4 @@
-SHA256 (rust-0.3.tar.gz) = b34c895b9596abb6942d1688e6a5189b08b92e2507234779779c1af91e9ae84e
-SIZE (rust-0.3.tar.gz) = 22310335
-SHA256 (rust-stage0-2012-07-06-b5f5676-freebsd-x86_64-926e17746576397c10af9796d30af6a730329f71.tar.bz2) = b991df3cd68568e549241eab5d8b5e9f9dfacb7edaaebca1dd0176c91d0047e2
-SIZE (rust-stage0-2012-07-06-b5f5676-freebsd-x86_64-926e17746576397c10af9796d30af6a730329f71.tar.bz2) = 10308861
+SHA256 (rust-0.4.tar.gz) = 150685f07e4d605cadf9fba25b05e9cc1b009364dd744131cf4230d64981d093
+SIZE (rust-0.4.tar.gz) = 24104527
+SHA256 (rust-stage0-2012-10-09-cd6f24f-freebsd-x86_64-a2b5e9dddfa8f21cc8a068b77a47ba5425bfdcc6.tar.bz2) = 6ef8e6af1af853ed391ff90063deeae3593954b271724d78104e6f31ebb8a470
+SIZE (rust-stage0-2012-10-09-cd6f24f-freebsd-x86_64-a2b5e9dddfa8f21cc8a068b77a47ba5425bfdcc6.tar.bz2) = 13084348
diff --git a/lang/rust/files/log2.patch b/lang/rust/files/log2.patch
new file mode 100644
index 000000000000..ed0b307f6a66
--- /dev/null
+++ b/lang/rust/files/log2.patch
@@ -0,0 +1,48 @@
+--- src/libcore/cmath.rs.orig 2012-10-16 21:22:12.704922039 +0800
++++ src/libcore/cmath.rs 2012-10-16 21:23:23.023337237 +0800
+@@ -56,7 +56,6 @@
+ // renamed: to be consitent with log as ln
+ #[link_name="log1p"] pure fn ln1p(n: c_double) -> c_double;
+ pure fn log10(n: c_double) -> c_double;
+- pure fn log2(n: c_double) -> c_double;
+ #[link_name="ilogb"] pure fn ilog_radix(n: c_double) -> c_int;
+ pure fn modf(n: c_double, iptr: &mut c_double) -> c_double;
+ pure fn pow(n: c_double, e: c_double) -> c_double;
+@@ -131,7 +130,6 @@
+ #[link_name="logf"] pure fn ln(n: c_float) -> c_float;
+ #[link_name="logbf"] pure fn log_radix(n: c_float) -> c_float;
+ #[link_name="log1pf"] pure fn ln1p(n: c_float) -> c_float;
+- #[link_name="log2f"] pure fn log2(n: c_float) -> c_float;
+ #[link_name="log10f"] pure fn log10(n: c_float) -> c_float;
+ #[link_name="ilogbf"] pure fn ilog_radix(n: c_float) -> c_int;
+ #[link_name="modff"] pure fn modf(n: c_float,
+--- src/libcore/f32.rs.orig 2012-10-16 21:22:27.909922315 +0800
++++ src/libcore/f32.rs 2012-10-16 21:24:32.932336957 +0800
+@@ -135,7 +135,11 @@
+ }
+
+ pub pure fn logarithm(n: f32, b: f32) -> f32 {
+- return log2(n) / log2(b);
++ return ln(n) / ln(b);
++}
++
++pub pure fn log2(n: f32) -> f32 {
++ return ln(n) / consts::ln_2;
+ }
+
+ impl f32: num::Num {
+--- src/libcore/f64.rs.orig 2012-10-16 21:22:34.895921647 +0800
++++ src/libcore/f64.rs 2012-10-16 21:25:30.466586496 +0800
+@@ -154,7 +154,11 @@
+ }
+
+ pub pure fn logarithm(n: f64, b: f64) -> f64 {
+- return log2(n) / log2(b);
++ return ln(n) / ln(b);
++}
++
++pub pure fn log2(n: f64) -> f64 {
++ return ln(n) / consts::ln_2;
+ }
+
+ impl f64: num::Num {
diff --git a/lang/rust/files/patch-configure b/lang/rust/files/patch-configure
new file mode 100644
index 000000000000..d106116a908d
--- /dev/null
+++ b/lang/rust/files/patch-configure
@@ -0,0 +1,19 @@
+--- configure.orig 2012-10-16 22:28:10.833921513 +0800
++++ configure 2012-10-16 22:30:18.122921502 +0800
+@@ -312,7 +312,6 @@
+ step_msg "looking for build programs"
+
+ probe_need CFG_PERL perl
+-probe_need CFG_CURL curl
+ probe_need CFG_PYTHON python2.7 python2.6 python2 python
+
+ python_version=$($CFG_PYTHON -V 2>&1)
+@@ -451,7 +450,7 @@
+ | cut -d ' ' -f 2)
+
+ case $CFG_CLANG_VERSION in
+- (3.0svn | 3.0 | 3.1 | 4.0 | 4.1)
++ (3.0svn | 3.0 | 3.1 | 3.2 | 4.0 | 4.1)
+ step_msg "found ok version of CLANG: $CFG_CLANG_VERSION"
+ CFG_C_COMPILER="clang"
+ ;;
diff --git a/lang/rust/files/patch-src_libcore_cmath.rs b/lang/rust/files/patch-src_libcore_cmath.rs
deleted file mode 100644
index 801bd79e0b00..000000000000
--- a/lang/rust/files/patch-src_libcore_cmath.rs
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/libcore/cmath.rs.orig 2012-04-01 10:40:10.385607179 +0800
-+++ src/libcore/cmath.rs 2012-04-01 10:40:34.370606102 +0800
-@@ -164,7 +164,6 @@
- #[link_name="sqrtf"] pure fn sqrt(n: c_float) -> c_float;
- #[link_name="tanf"] pure fn tan(n: c_float) -> c_float;
- #[link_name="tanhf"] pure fn tanh(n: c_float) -> c_float;
-- #[link_name="tgammaf"] pure fn tgamma(n: c_float) -> c_float;
- #[link_name="truncf"] pure fn trunc(n: c_float) -> c_float;
- }
-
diff --git a/lang/rust/files/patch-src_libcore_f32.rs b/lang/rust/files/patch-src_libcore_f32.rs
deleted file mode 100644
index e9d1f7799b67..000000000000
--- a/lang/rust/files/patch-src_libcore_f32.rs
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/libcore/f32.rs.orig 2012-07-16 17:14:25.444144084 +0800
-+++ src/libcore/f32.rs 2012-07-16 17:15:29.799514797 +0800
-@@ -5,6 +5,8 @@
- import cmath::c_float::*;
- import cmath::c_float_targ_consts::*;
-
-+import cmath::c_double;
-+
- export add, sub, mul, div, rem, lt, le, gt, eq, ne;
- export is_positive, is_negative, is_nonpositive, is_nonnegative;
- export is_zero, is_infinite, is_finite;
-@@ -179,6 +181,10 @@
- fn from_int(n: int) -> f32 { ret n as f32; }
- }
-
-+pure fn tgamma(n: f32) -> f32 {
-+ ret c_double::tgamma(n as f64) as f32;
-+}
-+
- //
- // Local Variables:
- // mode: rust
diff --git a/lang/rust/files/tgammaf.patch b/lang/rust/files/tgammaf.patch
new file mode 100644
index 000000000000..a548e804bcdd
--- /dev/null
+++ b/lang/rust/files/tgammaf.patch
@@ -0,0 +1,32 @@
+--- src/libcore/cmath.rs.orig 2012-10-16 21:27:43.459921547 +0800
++++ src/libcore/cmath.rs 2012-10-16 21:27:59.451920798 +0800
+@@ -145,7 +145,6 @@
+ #[link_name="sqrtf"] pure fn sqrt(n: c_float) -> c_float;
+ #[link_name="tanf"] pure fn tan(n: c_float) -> c_float;
+ #[link_name="tanhf"] pure fn tanh(n: c_float) -> c_float;
+- #[link_name="tgammaf"] pure fn tgamma(n: c_float) -> c_float;
+ #[link_name="truncf"] pure fn trunc(n: c_float) -> c_float;
+ }
+
+--- src/libcore/f32.rs.orig 2012-10-16 21:27:50.924920698 +0800
++++ src/libcore/f32.rs 2012-10-16 21:30:50.177658387 +0800
+@@ -7,6 +7,8 @@
+ pub use cmath::c_float::*;
+ pub use cmath::c_float_targ_consts::*;
+
++priv use cmath::c_double;
++
+ // These are not defined inside consts:: for consistency with
+ // the integer types
+
+@@ -130,6 +132,10 @@
+ pub const ln_10: f32 = 2.30258509299404568401799145468436421_f32;
+ }
+
++pub pure fn tgamma(n: f32) -> f32 {
++ return c_double::tgamma(n as f64) as f32;
++}
++
+ pub pure fn signbit(x: f32) -> int {
+ if is_negative(x) { return 1; } else { return 0; }
+ }
diff --git a/lang/rust/pkg-plist b/lang/rust/pkg-plist
index 8ac2dc3dd1ef..0e6a68283a7d 100644
--- a/lang/rust/pkg-plist
+++ b/lang/rust/pkg-plist
@@ -1,18 +1,18 @@
%%CARGO%%bin/cargo
bin/rustc
bin/rustdoc
-lib/libcore-d27e4777a53c3e50-0.3.so
-lib/librustc-73389320c1332876-0.3.so
+lib/libcore-c3ca5d77d81b46c1-0.4.so
+lib/librustc-c84825241471686d-0.4.so
lib/librustllvm.so
lib/librustrt.so
-lib/libstd-d399da1ab6f5bec0-0.3.so
-lib/libsyntax-b45cc7d0b085bc34-0.3.so
-lib/rustc/x86_64-unknown-freebsd/lib/libcore-d27e4777a53c3e50-0.3.so
+lib/libstd-4782a756585a81-0.4.so
+lib/libsyntax-84efebcb12c867a2-0.4.so
+lib/rustc/x86_64-unknown-freebsd/lib/libcore-c3ca5d77d81b46c1-0.4.so
lib/rustc/x86_64-unknown-freebsd/lib/libmorestack.a
-lib/rustc/x86_64-unknown-freebsd/lib/librustc-73389320c1332876-0.3.so
+lib/rustc/x86_64-unknown-freebsd/lib/librustc-c84825241471686d-0.4.so
lib/rustc/x86_64-unknown-freebsd/lib/librustrt.so
-lib/rustc/x86_64-unknown-freebsd/lib/libstd-d399da1ab6f5bec0-0.3.so
-lib/rustc/x86_64-unknown-freebsd/lib/libsyntax-b45cc7d0b085bc34-0.3.so
+lib/rustc/x86_64-unknown-freebsd/lib/libstd-4782a756585a81-0.4.so
+lib/rustc/x86_64-unknown-freebsd/lib/libsyntax-84efebcb12c867a2-0.4.so
@dirrm lib/rustc/x86_64-unknown-freebsd/lib
@dirrm lib/rustc/x86_64-unknown-freebsd
@dirrm lib/rustc
class='insertions'>+2 * Update to 1.14.7bapt2014-09-082-18/+44 * Cleanup plistbapt2014-09-031-3/+2 * Properly reset ownershipbapt2014-09-031-3/+2 * Because this is a slave port, it cannot load bsd.port.pre.mk before definingadamw2014-08-171-5/+5 * Remove indefinite articles and trailing periods from COMMENT, plusolgeni2014-08-081-1/+1 * Bump XORG_REVISION to reflect changed behavior on PowerPC.nwhitehorn2014-07-301-1/+1 * mmap() /dev/mem instead of /dev/console on PowerPC. Mostly this was alreadynwhitehorn2014-07-301-17/+52 * Rename all patches that contain '::' as a path separator, and useadamw2014-07-304-0/+0 * Remove NOPORTDOCS.adamw2014-07-051-2/+2 * Use MAKE_CMDbapt2014-06-251-94/+94 * Convert GMAKE to MAKE_CMDbapt2014-06-251-2/+2 * x11-drivers/xf86-video-ati:kwm2014-05-302-6/+27 * Revert accident commit in -r351411. This should stop the option dialogkwm2014-05-161-2/+0 * Restore PORTREVISION mistakenly removed in last commitpawel2014-05-011-0/+1 * Fix BadImplemented errors that happen with gdk 3.12.x and GNOME 3. [1]kwm2014-04-242-8/+43 * When linking a library libA with a library libB using libtool, if libB.latijl2014-04-231-4/+3 * The FreeBSD x11@ and graphics team proudly presentszeising2014-04-174-11/+10 * Support stagebapt2014-03-022-11/+8 * X11rdp is an X server for xrdp.swills2014-02-128-0/+720 * - Stage supportmiwi2014-02-031-3/+3 * Fix packaging on FreeBSD 11 when WITH_NEW_XORG is defined by bsd.port.mkbapt2014-01-261-5/+5 * Fix properties on pkg-plistbapt2014-01-221-1/+0 * Remove extra bsd.port.options.mk, it already defined in the master port.kwm2013-12-311-2/+0 * Remove extra bsd.port.options.mk, it already defined in the master port.kwm2013-12-312-5/+1 * Fix PLIST_SUB (add a space after @comment) for non-default option.bsam2013-12-301-1/+1 * - Support CC/CFLAGS properlypawel2013-12-212-15/+18 * Fix whitespace, no functional changes.zeising2013-12-161-1/+0 * Switch FreeBSD CURRENT to use the new xorg stack (WITH_NEW_XORG=) [0]zeising2013-12-168-47/+64 * Fix typo.kwm2013-10-251-1/+1 * Document xorg-server use after free CVE.kwm2013-10-243-4/+89 * Fix patches. Remove two unneeded ones, and add new patches to fix sparc64.zeising2013-09-304-15/+19 * Fix perl dependency.zeising2013-09-301-2/+2 * The FreeBSD graphics/x11 team proudly presentszeising2013-09-306-16/+528 * Add NO_STAGE all over the place in preparation for the staging support (cat: ...bapt2013-09-219-10/+11 * Plug two more use before initialized with the new x server.zeising2013-08-141-0/+23 * - Convert to new perl frameworkaz2013-08-041-1/+2 * Convert to USES=imakebapt2013-06-291-9/+3 * Enable AIGLX by default on xorg-server 1.12. (WITH_NEW_XORG)zeising2013-06-282-2/+3 * Readd the dix_events.c patch that was removed with the xorg update.zeising2013-06-272-2/+92 * Add a patch to fix upstream bug 18451 for 1.7.7.jkim2013-06-182-3/+233 * Don't install the README.compiled file, it got installed in a directorykwm2013-06-171-0/+11 * Fix patching on powerpc with new xorg.zeising2013-06-143-1/+19 * The FreeBSD x11 team proudly presentszeising2013-05-2519-271/+100 * Add a new xorg module, to use with USE_XORG: xorg-macros. This modulezeising2013-03-121-1/+2 * 2013-02-27 www/igal: No more upstream, no more public distfiles, consider usi...bapt2013-03-049-204/+0 * Fix the patch used to make xorg-server build with clang on i386.zeising2013-02-033-16/+1 * Fix build on i386 when building with clang.zeising2013-01-193-0/+30 * Add a patch to fix a couple of cases of use before initialized in the newzeising2012-12-142-2/+56 * 3dfx has been defunct for a long timeeadler2012-12-091-6/+4 * - Add missing "defined".avilla2012-11-151-1/+1 * Solve libGL.so and libglx.so conflict situation between libGL, xorg-server andkwm2012-08-314-14/+52 * Replace some spaces with tabs, and remove double defined variables in PLIST_SUB.kwm2012-08-291-7/+3 * Fix the build of xorg related ports when the base system is compiled withzeising2012-07-301-0/+4 * Add new OPTIONS_EXCLUSE_${ARCH} to be able to exclude an option on the given ...bapt2012-07-131-5/+2 * Convert to new options frameworkbapt2012-06-061-10/+11 * Revert "dix: use the event mask of the grab for TryClientEvents."naddy2012-04-252-1/+91 * - Please welcome Xorg 7.5.2miwi2012-04-2220-283/+226 * Repeated words are are hard to to find sometimes.eadler2012-01-081-1/+1 * - Remove WITH_FBSD10_FIX, is no longer neededmiwi2011-11-093-3/+0 * - Fix build on FreeBSD 10.0miwi2011-10-293-1/+3 * Fix CVE-2011-4028 and CVE-2011-4029.kwm2011-10-192-4/+22 * - Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)amdmi32011-09-241-2/+2 * Mark as broken on recent i386-9: fails to compile.linimon2011-08-291-1/+7 * Remove USE_GNOME=gnometarget from ports. It has been a empty keyword sincekwm2011-08-121-1/+0 * Fix the "exaGetPixmapFirstPixel called for invalid bpp" problem. This bugkwm2011-08-072-1/+27 * Unbreak this -- random automake fallout not shown up on amd64 -exp runsade2011-03-212-1/+7 * - Get Rid MD5 supportmiwi2011-03-194-5/+0 * - point x2x to its new homebapt2011-03-113-2/+3 * Revert "dix: use the event mask of the grab for TryClientEvents."naddy2011-02-282-0/+90 * - Please welcome Xorg 7.5.1miwi2011-02-2613-41/+15 * - There's no nv(4x) manpage in xorg-server distribution anymore.stas2011-01-251-1/+0 * - Fix build on powerpc64.stas2011-01-251-1/+1 * - DISTNAME= ${PORTNAME}-${PORTVERSION} is the default and not needed.pgollucci2010-12-301-1/+0 * Sync to new bsd.autotools.mkade2010-12-041-1/+1 * Punt autoconf267->autoconf268ade2010-10-161-1/+1 * Autotools update. Read ports/UPDATING 20100915 for details.ade2010-09-161-2/+2 * - Fix build on ppcmiwi2010-05-051-11/+0 * - Update to Xorg 7.5miwi2010-05-0113-46/+37 * Given that HAL doesn't work on sparc64 and always needs to be disabledmarius2010-02-081-2/+11