aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-01-11 18:08:38 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-01-11 18:08:38 +0800
commitf6763c3cd1541b5d51cd003610210be9e3f57b92 (patch)
treec9a458d29164af55be5bf3330f3f659428ac04ac /lang
parentffc02588e890cf8d01b2305cfb96dbb0eaf038a8 (diff)
downloadfreebsd-ports-gnome-f6763c3cd1541b5d51cd003610210be9e3f57b92.tar.gz
freebsd-ports-gnome-f6763c3cd1541b5d51cd003610210be9e3f57b92.tar.zst
freebsd-ports-gnome-f6763c3cd1541b5d51cd003610210be9e3f57b92.zip
- Remove always-true/false conditions after FreeBSD 9, 10.1, 10.2 EOL
Approved by: portmgr blanket
Diffstat (limited to 'lang')
-rw-r--r--lang/mono/Makefile9
-rw-r--r--lang/smlnj/Makefile17
-rw-r--r--lang/swift/Makefile4
3 files changed, 4 insertions, 26 deletions
diff --git a/lang/mono/Makefile b/lang/mono/Makefile
index ce4f98beb0a8..bc34caef281d 100644
--- a/lang/mono/Makefile
+++ b/lang/mono/Makefile
@@ -39,8 +39,6 @@ MAKE_ENV= MONO_SHARED_DIR="${MONO_SHARED_DIR}" \
ONLY_FOR_ARCHS= i386 amd64 powerpc
PORTSCOUT= limit:^\d+\.\d+\.[1-9]\d*
-.include <bsd.port.pre.mk>
-
post-patch:
@${REINPLACE_CMD} -e 's|^#!/bin/bash|#!/usr/bin/env bash|g' \
${WRKSRC}/scripts/mono-find-provides.in \
@@ -53,14 +51,9 @@ post-patch:
post-configure:
@${REINPLACE_CMD} -e 's|share\/man|man|g' \
${WRKSRC}/mcs/jay/Makefile
-# Fix build on FreeBSD 9.3 (and maybe other unsupported releases)
-.if ${OSVERSION} < 1000000
- @${REINPLACE_CMD} 's/^#define HAVE_LOCALCHARSET_H 1/#undef HAVE_LOCALCHARSET_H/' \
- ${WRKSRC}/eglib/config.h
-.endif
do-test:
@(cd ${WRKSRC}/mono/tests && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} \
${MAKE_FLAGS} Makefile ${MAKE_ARGS} check)
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/smlnj/Makefile b/lang/smlnj/Makefile
index ddf0b7ada9a8..9e90a2f5675a 100644
--- a/lang/smlnj/Makefile
+++ b/lang/smlnj/Makefile
@@ -18,6 +18,8 @@ LICENSE_TEXT= The text of the license can be obtained from the following URL:\
http://www.smlnj.org/license.html
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+ONLY_FOR_ARCHS= i386 amd64
+
NO_WRKSUBDIR= yes
SUB_FILES= pkg-install
@@ -41,21 +43,6 @@ POSITION64_DESC= use 64bit file${CALM} positions - implies RECOMPILE
ML_RECOMPILE_OPTIONS= RECOMPILE POSITION64
.endif
-.if (${ARCH} == "amd64") && (${OSVERSION} >= 1000029)
-ONLY_FOR_ARCHS= i386 amd64
-.elif (${ARCH} == "amd64")
-ONLY_FOR_ARCHS= i386 amd64
-# Compilation of the i386 runtime source on older amd64 systems requires
-# i386 system headers from the respective FreeBSD Version, taken from
-# stable/N/sys/i386/include, r196045 (N=8) and r225736 (N=9).
-EXTRA_DEFS+= -DINCLUDE_FREEBSD_I386_SIGNAL=\\\"freebsd-8-i386-signal.h\\\"
-EXTRA_DEFS+= -DINCLUDE_FREEBSD_I386_IEEEFP=\\\"freebsd-8-i386-ieeefp.h\\\"
-EXTRA_DEFS+= -DINCLUDE_FREEBSD_I386__TYPES=\\\"freebsd-9-i386-_types.h\\\"
-EXTRA_DEFS+= -DINCLUDE_FREEBSD_I386_ENDIAN=\\\"freebsd-9-i386-endian.h\\\"
-.else
-ONLY_FOR_ARCHS= i386
-.endif
-
.if (${ARCH} == "amd64")
CFLAGS+= -m32
AS?= as
diff --git a/lang/swift/Makefile b/lang/swift/Makefile
index 3c5a323e93ac..6e54985f5374 100644
--- a/lang/swift/Makefile
+++ b/lang/swift/Makefile
@@ -45,12 +45,10 @@ PORTDOCS= *
.include <bsd.port.pre.mk>
-.if ${OPSYS} == FreeBSD
-.if (${OSVERSION} < 1002000) || (${OSVERSION} < 1100079)
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1100079
BUILD_DEPENDS+= clang38:devel/llvm38
EXTRA_FLAGS= --host-cc=${LOCALBASE}/bin/clang38 --host-cxx=${LOCALBASE}/bin/clang++38
.endif
-.endif
post-extract:
@${MKDIR} ${WRKSRC}