aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-03-27 04:55:01 +0800
committermarino <marino@FreeBSD.org>2015-03-27 04:55:01 +0800
commitf713b44f75798d0b039fbac252d6d2242bda77e6 (patch)
treea2071b9c0748edb8786234d92b3c64891cc2fed7 /lang
parentcc8b9cb145895d1c6c7b22fe63af4d1088cce6ea (diff)
downloadfreebsd-ports-gnome-f713b44f75798d0b039fbac252d6d2242bda77e6.tar.gz
freebsd-ports-gnome-f713b44f75798d0b039fbac252d6d2242bda77e6.tar.zst
freebsd-ports-gnome-f713b44f75798d0b039fbac252d6d2242bda77e6.zip
lang/erlang* : Use OPTIONS_EXCLUDE_DragonFly to block SCTP option
DragonFly no longer has SCPT in base and when it did, it was ancient. Approved by: DragonFly blanket
Diffstat (limited to 'lang')
-rw-r--r--lang/erlang-runtime15/Makefile1
-rw-r--r--lang/erlang-runtime16/Makefile1
-rw-r--r--lang/erlang-runtime17/Makefile1
-rw-r--r--lang/erlang/Makefile1
4 files changed, 4 insertions, 0 deletions
diff --git a/lang/erlang-runtime15/Makefile b/lang/erlang-runtime15/Makefile
index 4a483902f5fc..7c3b5ea2145d 100644
--- a/lang/erlang-runtime15/Makefile
+++ b/lang/erlang-runtime15/Makefile
@@ -41,6 +41,7 @@ GS_DESC= Enable GS application (deprecated)
DTRACE_DESC= Enable DTrace support
OPTIONS_DEFAULT=KQUEUE OPENSSL SCTP SMP THREADS
+OPTIONS_EXCLUDE_DragonFly= SCTP
ERL_RELEASE= R${PORTVERSION:S/.//g:tu:S/1$/-1/}
diff --git a/lang/erlang-runtime16/Makefile b/lang/erlang-runtime16/Makefile
index a48ee238fcaf..6a334f13eb84 100644
--- a/lang/erlang-runtime16/Makefile
+++ b/lang/erlang-runtime16/Makefile
@@ -41,6 +41,7 @@ GS_DESC= Enable GS application (deprecated)
DTRACE_DESC= Enable DTrace support
OPTIONS_DEFAULT=KQUEUE OPENSSL SCTP SMP THREADS
+OPTIONS_EXCLUDE_DragonFly= SCTP
ERL_RELEASE= R${PORTVERSION:S/.//g:tu:S/1$/-1/}
diff --git a/lang/erlang-runtime17/Makefile b/lang/erlang-runtime17/Makefile
index 0adf47b813e6..e9294d94abc2 100644
--- a/lang/erlang-runtime17/Makefile
+++ b/lang/erlang-runtime17/Makefile
@@ -40,6 +40,7 @@ GS_DESC= Enable GS application (deprecated)
DTRACE_DESC= Enable DTrace support
OPTIONS_DEFAULT=KQUEUE OPENSSL SCTP SMP THREADS
+OPTIONS_EXCLUDE_DragonFly= SCTP
ERL_RELEASE= 17.4
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index 5a15167710d0..fb8a86ceda0a 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -45,6 +45,7 @@ GS_DESC= Enable GS application (deprecated)
DTRACE_DESC= Enable DTrace support
OPTIONS_DEFAULT=KQUEUE OPENSSL SCTP SMP THREADS
+OPTIONS_EXCLUDE_DragonFly= SCTP
ERL_RELEASE= 17.4