aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-10-20 17:34:03 +0800
committermarino <marino@FreeBSD.org>2014-10-20 17:34:03 +0800
commitf8ee277c1fc111bacf885dd55f96c9a604cc3d47 (patch)
treead654e472d3378e589b21dcb25a71b4f2d702f53 /lang
parent21658c7c54dcedadeedd4f1c45009b4a1e473f9b (diff)
downloadfreebsd-ports-gnome-f8ee277c1fc111bacf885dd55f96c9a604cc3d47.tar.gz
freebsd-ports-gnome-f8ee277c1fc111bacf885dd55f96c9a604cc3d47.tar.zst
freebsd-ports-gnome-f8ee277c1fc111bacf885dd55f96c9a604cc3d47.zip
Add USES=alias to several ports
Alias is a new USES tool that allows DragonFly to masquerade as FreeBSD by setting CFLAGS+= -D__FreeBSD__. For some ports, this fixes the build without the need for additional patches. Approved by: portmgr (bapt, blanket)
Diffstat (limited to 'lang')
-rw-r--r--lang/tclX/Makefile2
-rw-r--r--lang/v8/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/lang/tclX/Makefile b/lang/tclX/Makefile
index 723f35f292f4..6570a5ee7f06 100644
--- a/lang/tclX/Makefile
+++ b/lang/tclX/Makefile
@@ -17,7 +17,7 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
WRKSRC= ${WRKDIR}/${PORTNAME:tl}${PORTVERSION:R}
-USES= tcl tar:bzip2
+USES= alias tcl tar:bzip2
USE_LDCONFIG= ${PREFIX}/lib/tclx${PORTVERSION:R}
USE_AUTOTOOLS= autoconf
CONFIGURE_ARGS= --exec-prefix=${PREFIX} \
diff --git a/lang/v8/Makefile b/lang/v8/Makefile
index 66e011694481..ec268373ac38 100644
--- a/lang/v8/Makefile
+++ b/lang/v8/Makefile
@@ -21,7 +21,7 @@ ALL_TARGET= native
MAKE_ARGS= library=shared
MAKE_ENV= CC.host=${CC} CXX.host=${CXX} LINK.host=${CXX} LINK.target=${CXX}
USE_LDCONFIG= yes
-USES= compiler cpe execinfo gmake python:2 tar:xz
+USES= alias compiler cpe execinfo gmake python:2 tar:xz
CPE_VENDOR= google