aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorromain <romain@FreeBSD.org>2014-03-12 19:46:03 +0800
committerromain <romain@FreeBSD.org>2014-03-12 19:46:03 +0800
commitfc77e57f8001a9f5f9470797ac64bf320279e7f8 (patch)
tree4f1663c7dec534ec2b520ad044c81fc998dc2317 /lang
parentae841bc7b3106d5efa22024a8bfcdece4a649a8c (diff)
downloadfreebsd-ports-gnome-fc77e57f8001a9f5f9470797ac64bf320279e7f8.tar.gz
freebsd-ports-gnome-fc77e57f8001a9f5f9470797ac64bf320279e7f8.tar.zst
freebsd-ports-gnome-fc77e57f8001a9f5f9470797ac64bf320279e7f8.zip
Unbreak relative paths for xbuild
PR: ports/187130 Submitted by: mva
Diffstat (limited to 'lang')
-rw-r--r--lang/mono/Makefile1
-rw-r--r--lang/mono/files/patch-mcs_class_Microsoft.Build.Engine_Microsoft.Build.BuildEngine_DirectoryScanner.cs11
2 files changed, 12 insertions, 0 deletions
diff --git a/lang/mono/Makefile b/lang/mono/Makefile
index e0d637314905..3b3daa7d8b73 100644
--- a/lang/mono/Makefile
+++ b/lang/mono/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mono
PORTVERSION= 3.2.8
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= http://download.mono-project.com/sources/${PORTNAME}/
diff --git a/lang/mono/files/patch-mcs_class_Microsoft.Build.Engine_Microsoft.Build.BuildEngine_DirectoryScanner.cs b/lang/mono/files/patch-mcs_class_Microsoft.Build.Engine_Microsoft.Build.BuildEngine_DirectoryScanner.cs
new file mode 100644
index 000000000000..6c24d65eb6f9
--- /dev/null
+++ b/lang/mono/files/patch-mcs_class_Microsoft.Build.Engine_Microsoft.Build.BuildEngine_DirectoryScanner.cs
@@ -0,0 +1,11 @@
+--- mcs/class/Microsoft.Build.Engine/Microsoft.Build.BuildEngine/DirectoryScanner.cs.orig 2014-02-28 08:27:40.000000000 +0100
++++ mcs/class/Microsoft.Build.Engine/Microsoft.Build.BuildEngine/DirectoryScanner.cs 2014-02-28 08:28:16.000000000 +0100
+@@ -98,7 +98,7 @@
+ int offset = 0;
+ string full_path;
+ if (Path.IsPathRooted (name)) {
+- full_path = name;
++ full_path = Path.GetFullPath (name);
+ baseDirectory = new DirectoryInfo (Path.GetPathRoot (name));
+ if (IsRunningOnWindows)
+ // skip the "drive:"