aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2015-06-26 18:03:08 +0800
committerolgeni <olgeni@FreeBSD.org>2015-06-26 18:03:08 +0800
commit51e9027d9fdc8421cb14306476430f5c95419178 (patch)
treef33cb52572aeb38af0f4c4f0b44f86e23ae58755 /lang
parente616d612abd339d329d5ce35c8b7d847cd1f2e39 (diff)
downloadfreebsd-ports-gnome-51e9027d9fdc8421cb14306476430f5c95419178.tar.gz
freebsd-ports-gnome-51e9027d9fdc8421cb14306476430f5c95419178.tar.zst
freebsd-ports-gnome-51e9027d9fdc8421cb14306476430f5c95419178.zip
Sort option descriptions and remove unnecessary USES=autoreconf.
Diffstat (limited to 'lang')
-rw-r--r--lang/erlang-runtime15/Makefile6
-rw-r--r--lang/erlang-runtime16/Makefile6
-rw-r--r--lang/erlang-runtime17/Makefile8
-rw-r--r--lang/erlang-runtime18/Makefile6
4 files changed, 13 insertions, 13 deletions
diff --git a/lang/erlang-runtime15/Makefile b/lang/erlang-runtime15/Makefile
index 20be86e8fd6e..3562ac49e70d 100644
--- a/lang/erlang-runtime15/Makefile
+++ b/lang/erlang-runtime15/Makefile
@@ -29,21 +29,21 @@ MAKE_JOBS_UNSAFE=yes
OPTIONS_DEFINE= DOCS DTRACE GCC GS HIPE JAVA KQUEUE ODBC OPENSSL SCTP SMP THREADS WX
+DTRACE_DESC= Enable DTrace support
GCC_DESC= Use current GCC
+GS_DESC= Enable GS application (deprecated)
HIPE_DESC= Build native HiPE compiler
KQUEUE_DESC= Enable Kernel Poll (kqueue) support
SCTP_DESC= Enable SCTP support
SMP_DESC= Enable SMP support
WX_DESC= Enable WX application
-GS_DESC= Enable GS application (deprecated)
-DTRACE_DESC= Enable DTrace support
OPTIONS_DEFAULT=KQUEUE OPENSSL SCTP SMP THREADS
OPTIONS_EXCLUDE_DragonFly= SCTP
ERL_RELEASE= R${PORTVERSION:S/.//g:tu:S/1$/-1/}
-USES= autoreconf gmake perl5
+USES= gmake perl5
USE_PERL5= build
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/lang/erlang-runtime16/Makefile b/lang/erlang-runtime16/Makefile
index db4e88692544..7c919bd89ad7 100644
--- a/lang/erlang-runtime16/Makefile
+++ b/lang/erlang-runtime16/Makefile
@@ -29,21 +29,21 @@ MAKE_JOBS_UNSAFE=yes
OPTIONS_DEFINE= DOCS DTRACE GCC GS HIPE JAVA KQUEUE ODBC OPENSSL SCTP SMP THREADS WX
+DTRACE_DESC= Enable DTrace support
GCC_DESC= Use current GCC
+GS_DESC= Enable GS application (deprecated)
HIPE_DESC= Build native HiPE compiler
KQUEUE_DESC= Enable Kernel Poll (kqueue) support
SCTP_DESC= Enable SCTP support
SMP_DESC= Enable SMP support
WX_DESC= Enable WX application
-GS_DESC= Enable GS application (deprecated)
-DTRACE_DESC= Enable DTrace support
OPTIONS_DEFAULT=KQUEUE OPENSSL SCTP SMP THREADS
OPTIONS_EXCLUDE_DragonFly= SCTP
ERL_RELEASE= R${PORTVERSION:S/.//g:tu:S/1$/-1/}
-USES= autoreconf gmake perl5
+USES= gmake perl5
USE_PERL5= build
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/lang/erlang-runtime17/Makefile b/lang/erlang-runtime17/Makefile
index 4a73383710a6..0f60be2c4f3e 100644
--- a/lang/erlang-runtime17/Makefile
+++ b/lang/erlang-runtime17/Makefile
@@ -34,22 +34,22 @@ MAKE_JOBS_UNSAFE=yes
OPTIONS_DEFINE= DOCS DTRACE GCC GS HIPE JAVA KQUEUE ODBC OPENSSL SCTP SMP THREADS WX DIRTY
+DIRTY_DESC= Enable Dirty schedulers (experimental)
+DTRACE_DESC= Enable DTrace support
GCC_DESC= Use current GCC
+GS_DESC= Enable GS application (deprecated)
HIPE_DESC= Build native HiPE compiler
KQUEUE_DESC= Enable Kernel Poll (kqueue) support
SCTP_DESC= Enable SCTP support
SMP_DESC= Enable SMP support
WX_DESC= Enable WX application
-GS_DESC= Enable GS application (deprecated)
-DTRACE_DESC= Enable DTrace support
-DIRTY_DESC= Enable Dirty schedulers (experimental)
OPTIONS_DEFAULT=KQUEUE OPENSSL SCTP SMP THREADS
OPTIONS_EXCLUDE_DragonFly= SCTP
ERL_RELEASE= 17.5
-USES= autoreconf gmake perl5
+USES= gmake perl5
USE_PERL5= build
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/lang/erlang-runtime18/Makefile b/lang/erlang-runtime18/Makefile
index c06711e4897c..a068e5563ece 100644
--- a/lang/erlang-runtime18/Makefile
+++ b/lang/erlang-runtime18/Makefile
@@ -34,15 +34,15 @@ MAKE_JOBS_UNSAFE=yes
OPTIONS_DEFINE= DOCS DTRACE GCC GS HIPE JAVA KQUEUE ODBC OPENSSL SCTP SMP THREADS WX DIRTY
+DIRTY_DESC= Enable Dirty schedulers (experimental)
+DTRACE_DESC= Enable DTrace support
GCC_DESC= Use current GCC
+GS_DESC= Enable GS application (deprecated)
HIPE_DESC= Build native HiPE compiler
KQUEUE_DESC= Enable Kernel Poll (kqueue) support
SCTP_DESC= Enable SCTP support
SMP_DESC= Enable SMP support
WX_DESC= Enable WX application
-GS_DESC= Enable GS application (deprecated)
-DTRACE_DESC= Enable DTrace support
-DIRTY_DESC= Enable Dirty schedulers (experimental)
OPTIONS_DEFAULT=KQUEUE OPENSSL SCTP SMP THREADS
OPTIONS_EXCLUDE_DragonFly= SCTP