aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-06-17 21:29:44 +0800
committervanilla <vanilla@FreeBSD.org>2014-06-17 21:29:44 +0800
commit51cf7f8c32867582a0703b2097e28797dba74d20 (patch)
treeed22ab9a720fabbaed43a8f9aef9904d725d7a97 /lang
parent372d8813397eb52cd2a7bdd1217426e2c55e9364 (diff)
downloadfreebsd-ports-gnome-51cf7f8c32867582a0703b2097e28797dba74d20.tar.gz
freebsd-ports-gnome-51cf7f8c32867582a0703b2097e28797dba74d20.tar.zst
freebsd-ports-gnome-51cf7f8c32867582a0703b2097e28797dba74d20.zip
1: Stagify.
2: new syntax of LIB_DEPENDS Approved by: portmgr@
Diffstat (limited to 'lang')
-rw-r--r--lang/spidermonkey17/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/lang/spidermonkey17/Makefile b/lang/spidermonkey17/Makefile
index c2b9e7010da1..ac0738381abf 100644
--- a/lang/spidermonkey17/Makefile
+++ b/lang/spidermonkey17/Makefile
@@ -12,7 +12,7 @@ DISTNAME= js-${DISTVERSION}
MAINTAINER= citric@cubicone.tmetic.com
COMMENT= A standalone JavaScript interpreter from the Mozilla project
-LIB_DEPENDS= nspr4.1:${PORTSDIR}/devel/nspr
+LIB_DEPENDS= libnspr4.so:${PORTSDIR}/devel/nspr
CONFLICTS= njs-[0-9]*
@@ -43,7 +43,6 @@ EXTRACT_AFTER_ARGS= --exclude js/jsd
OPTIONS_DEFINE= UTF8
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MUTF8}
@@ -56,12 +55,12 @@ do-configure:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${OPSYS}`${UNAME} -r`_DBG.OBJ/js \
- ${PREFIX}/bin
+ ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/${OPSYS}`${UNAME} -r`_DBG.OBJ/libjs.so \
- ${PREFIX}/lib
- ${LN} -sf ${PREFIX}/lib/libjs.so ${PREFIX}/lib/libjs.so.1
+ ${STAGEDIR}${PREFIX}/lib
+ ${LN} -sf libjs.so ${STAGEDIR}${PREFIX}/lib/libjs.so.1
${CP} ${WRKSRC}/${OPSYS}`${UNAME} -r`_DBG.OBJ/jsautocfg.h ${WRKSRC}
- @${INSTALL_DATA} ${JSH:S,^,${WRKSRC}/,} ${PREFIX}/include/
+ @${INSTALL_DATA} ${JSH:S,^,${WRKSRC}/,} ${STAGEDIR}${PREFIX}/include/
.include <bsd.port.pre.mk>