aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2016-09-09 15:47:01 +0800
committergahr <gahr@FreeBSD.org>2016-09-09 15:47:01 +0800
commit5fc9f812186a51d4d3584e7ebc10e3216e5f4f4a (patch)
tree1e086d47f6d1602d1fdd317272ecc0488e86c589 /lang
parentfb75ee2597c40d50647b864b3985792e7d90e7a7 (diff)
downloadfreebsd-ports-gnome-5fc9f812186a51d4d3584e7ebc10e3216e5f4f4a.tar.gz
freebsd-ports-gnome-5fc9f812186a51d4d3584e7ebc10e3216e5f4f4a.tar.zst
freebsd-ports-gnome-5fc9f812186a51d4d3584e7ebc10e3216e5f4f4a.zip
lang/tcl8*: remove use of fpsetround
Pushed upstream: http://core.tcl.tk/tcl/info/20c19f9d5593455a PR: 212512 Submitted by: emaste
Diffstat (limited to 'lang')
-rw-r--r--lang/tcl84/files/patch-tclUnixInit.c17
-rw-r--r--lang/tcl85/files/patch-tclUnixInit.c17
-rw-r--r--lang/tcl86/files/patch-unix-tclUnixInit.c17
-rw-r--r--lang/tcl87/Makefile4
-rw-r--r--lang/tcl87/distinfo6
5 files changed, 56 insertions, 5 deletions
diff --git a/lang/tcl84/files/patch-tclUnixInit.c b/lang/tcl84/files/patch-tclUnixInit.c
new file mode 100644
index 000000000000..ea64d517f850
--- /dev/null
+++ b/lang/tcl84/files/patch-tclUnixInit.c
@@ -0,0 +1,17 @@
+--- tclUnixInit.c.orig 2012-11-19 16:27:16 UTC
++++ tclUnixInit.c
+@@ -268,14 +268,6 @@ TclpInitPlatform()
+ #endif /* SIGPIPE */
+
+ #if defined(__FreeBSD__) && defined(__GNUC__)
+- /*
+- * Adjust the rounding mode to be more conventional. Note that FreeBSD
+- * only provides the __fpsetreg() used by the following two for the GNU
+- * Compiler. When using, say, Intel's icc they break. (Partially based on
+- * patch in BSD ports system from root@celsius.bychok.com)
+- */
+-
+- fpsetround(FP_RN);
+ fpsetmask(0L);
+ #endif
+
diff --git a/lang/tcl85/files/patch-tclUnixInit.c b/lang/tcl85/files/patch-tclUnixInit.c
new file mode 100644
index 000000000000..a7774fb92b2e
--- /dev/null
+++ b/lang/tcl85/files/patch-tclUnixInit.c
@@ -0,0 +1,17 @@
+--- tclUnixInit.c.orig 2016-09-08 20:22:10.064101000 -0400
++++ tclUnixInit.c 2016-09-08 20:22:42.345592000 -0400
+@@ -391,14 +391,6 @@
+ #endif /* SIGPIPE */
+
+ #if defined(__FreeBSD__) && defined(__GNUC__)
+- /*
+- * Adjust the rounding mode to be more conventional. Note that FreeBSD
+- * only provides the __fpsetreg() used by the following two for the GNU
+- * Compiler. When using, say, Intel's icc they break. (Partially based on
+- * patch in BSD ports system from root@celsius.bychok.com)
+- */
+-
+- fpsetround(FP_RN);
+ (void) fpsetmask(0L);
+ #endif
+
diff --git a/lang/tcl86/files/patch-unix-tclUnixInit.c b/lang/tcl86/files/patch-unix-tclUnixInit.c
new file mode 100644
index 000000000000..b55fb818a0fb
--- /dev/null
+++ b/lang/tcl86/files/patch-unix-tclUnixInit.c
@@ -0,0 +1,17 @@
+--- unix/tclUnixInit.c.orig 2016-09-08 20:22:10.064101000 -0400
++++ unix/tclUnixInit.c 2016-09-08 20:22:42.345592000 -0400
+@@ -391,14 +391,6 @@
+ #endif /* SIGPIPE */
+
+ #if defined(__FreeBSD__) && defined(__GNUC__)
+- /*
+- * Adjust the rounding mode to be more conventional. Note that FreeBSD
+- * only provides the __fpsetreg() used by the following two for the GNU
+- * Compiler. When using, say, Intel's icc they break. (Partially based on
+- * patch in BSD ports system from root@celsius.bychok.com)
+- */
+-
+- fpsetround(FP_RN);
+ (void) fpsetmask(0L);
+ #endif
+
diff --git a/lang/tcl87/Makefile b/lang/tcl87/Makefile
index 55a31db5da15..6aff0c005eb8 100644
--- a/lang/tcl87/Makefile
+++ b/lang/tcl87/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= tcl
-DISTVERSION= 8.7.a0.20160908
+DISTVERSION= 8.7.a0.20160909
CATEGORIES= lang
MASTER_SITES= http://core.tcl.tk/tcl/tarball/
PKGNAMESUFFIX= ${PORTVERSION:R:R:S/.//}
@@ -23,7 +23,7 @@ TZDATA_DESC= Install Tcl timezone data
MODULES_DESC= Install Tcl common modules
OPTIONS_SUB= yes
-FOSSIL_CHECKIN= b98ee5637696606e
+FOSSIL_CHECKIN= 20c19f9d5593455a
PATCH_WRKSRC= ${WRKDIR}/Tcl_Source_Code
WRKSRC= ${PATCH_WRKSRC}/unix
diff --git a/lang/tcl87/distinfo b/lang/tcl87/distinfo
index 5e964801f968..a7a923bd181c 100644
--- a/lang/tcl87/distinfo
+++ b/lang/tcl87/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1473328563
-SHA256 (Tcl+Source+Code.tar.gz?uuid=b98ee5637696606e) = 220d9f6b20b11bb19807324bf8dba2e72ad383e96621b8ba1cb918c84cd5cc42
-SIZE (Tcl+Source+Code.tar.gz?uuid=b98ee5637696606e) = 8626143
+TIMESTAMP = 1473406670
+SHA256 (Tcl+Source+Code.tar.gz?uuid=20c19f9d5593455a) = 3b418db80941ae19b7084bb944df061fdaa5305f34661d0619f553bfecadee40
+SIZE (Tcl+Source+Code.tar.gz?uuid=20c19f9d5593455a) = 8625847