aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorshaun <shaun@FreeBSD.org>2006-10-06 09:47:56 +0800
committershaun <shaun@FreeBSD.org>2006-10-06 09:47:56 +0800
commit99d8b872bcc8e7de3077afbb16f77a8468e5a6dd (patch)
treea23460db2b0220c0ab7e2bf71fe58efa9de313e6 /lang
parent58818f3f146bedb17cafccd2946c588c5e188de2 (diff)
downloadfreebsd-ports-gnome-99d8b872bcc8e7de3077afbb16f77a8468e5a6dd.tar.gz
freebsd-ports-gnome-99d8b872bcc8e7de3077afbb16f77a8468e5a6dd.tar.zst
freebsd-ports-gnome-99d8b872bcc8e7de3077afbb16f77a8468e5a6dd.zip
- Allow expect to utilise 256 pty's as supported by FreeBSD. The
current code arbitrarily limits us to 64 at a time. - Bump PORTREVISION. Patch provided by "Cybil".
Diffstat (limited to 'lang')
-rw-r--r--lang/expect/Makefile1
-rw-r--r--lang/expect/files/patch-pty_termios.c20
2 files changed, 21 insertions, 0 deletions
diff --git a/lang/expect/Makefile b/lang/expect/Makefile
index 9c96f2621e9c..348586348ab2 100644
--- a/lang/expect/Makefile
+++ b/lang/expect/Makefile
@@ -6,6 +6,7 @@
PORTNAME= expect
PORTVERSION= 5.43.0
+PORTREVISION= 1
CATEGORIES= lang tcl84 tk84
MASTER_SITES= http://expect.nist.gov/src/
diff --git a/lang/expect/files/patch-pty_termios.c b/lang/expect/files/patch-pty_termios.c
new file mode 100644
index 000000000000..64a9cca5408d
--- /dev/null
+++ b/lang/expect/files/patch-pty_termios.c
@@ -0,0 +1,20 @@
+--- pty_termios.c.orig Fri May 7 17:46:03 2004
++++ pty_termios.c Fri Oct 6 01:17:48 2006
+@@ -166,7 +166,7 @@
+ static char *slave_bank;
+ static char *slave_num;
+ #else
+-static char banks[] = "pqrstuvwxyzPQRSTUVWXYZ";
++static char banks[] = "pqrsPQRS"; /* FreeBSD scheme */
+ static char master_name[] = "/dev/ptyXX";
+ static char slave_name [] = "/dev/ttyXX";
+ #endif /* HAVE_PTYM */
+@@ -489,7 +489,7 @@
+ *tty_bank = *bank;
+ *tty_num = '0';
+ if (stat(master_name, &stat_buf) < 0) break;
+- for (hex = "0123456789abcdef";*hex;hex++) {
++ for (hex = "0123456789abcdefghijklmnopqrstuv";*hex;hex++) {
+ *tty_num = *hex;
+ strcpy(slave_name,master_name);
+ *tty_type = 't';