aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-11-02 09:54:07 +0800
committerlinimon <linimon@FreeBSD.org>2018-11-02 09:54:07 +0800
commit9d81645166f1ae34b8c55563091cb4092d9cc866 (patch)
treebf09ff758166c53d6e5e34a626fc032d6be6ba8a /lang
parent751a5f73eabcea2655b58de9ae6a816da79b7528 (diff)
downloadfreebsd-ports-gnome-9d81645166f1ae34b8c55563091cb4092d9cc866.tar.gz
freebsd-ports-gnome-9d81645166f1ae34b8c55563091cb4092d9cc866.tar.zst
freebsd-ports-gnome-9d81645166f1ae34b8c55563091cb4092d9cc866.zip
USES=objc:compiler sets the compiler, but then USES=compiler:c++11-lang
overwrites it. Remove the latter to use the proper compiler. Also use libstdc++ on GCC architectures to fix build. While here, pet portlint. PR: 232386 Submitted by: Piotr Kubaj Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'lang')
-rw-r--r--lang/libobjc2/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/lang/libobjc2/Makefile b/lang/libobjc2/Makefile
index 7bff62910d1d..e116b80ef1b2 100644
--- a/lang/libobjc2/Makefile
+++ b/lang/libobjc2/Makefile
@@ -3,8 +3,8 @@
PORTNAME= libobjc2
PORTVERSION= 1.8.1
-PORTREVISION= 2
DISTVERSIONPREFIX= v
+PORTREVISION= 2
CATEGORIES= lang devel gnustep
MAINTAINER= theraven@FreeBSD.org
@@ -12,7 +12,7 @@ COMMENT= Replacement Objective-C runtime supporting modern Objective-C features
BROKEN_powerpc= Does not compile on powerpc: Unsupported relocation type 10
BROKEN_sparc64= Does not compile on sparc64: Cannot configure clang properly
-USES= cmake compiler:c++11-lang objc:compiler
+USES= cmake objc:compiler
USE_GITHUB= yes
GH_ACCOUNT= gnustep
@@ -29,6 +29,12 @@ CMAKE_ARGS+= -DTESTS=OFF
# This shouldn't be needed, but our llvm port installs llvm-config with a silly
# name...
CMAKE_ARGS+= -DLLVM_OPTS=OFF
+CXXFLAGS_powerpc64= -stdlib=libstdc++
+CXXFLAGS_powerpcspe= -stdlib=libstdc++
+CXXFLAGS_powerpc= -stdlib=libstdc++
+CXXFLAGS_sparc64= -stdlib=libstdc++
+CXXFLAGS_mips= -stdlib=libstdc++
+CXXFLAGS_mips64= -stdlib=libstdc++
post-install:
${LN} -sf libobjc.so.${SHLIB_MAJOR}.${SHLIB_MINOR} ${STAGEDIR}${PREFIX}/lib/libobjc.so.${SHLIB_MAJOR}