aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2013-07-22 07:25:52 +0800
committermm <mm@FreeBSD.org>2013-07-22 07:25:52 +0800
commitbbb9caa0177664a8057c308bb1d7fd48f54bb86d (patch)
tree3e8ae73f90e275c54747bc754420a3a1bc738660 /lang
parent5aab601b7f8530c317fac9dd533390f24e897744 (diff)
downloadfreebsd-ports-gnome-bbb9caa0177664a8057c308bb1d7fd48f54bb86d.tar.gz
freebsd-ports-gnome-bbb9caa0177664a8057c308bb1d7fd48f54bb86d.tar.zst
freebsd-ports-gnome-bbb9caa0177664a8057c308bb1d7fd48f54bb86d.zip
Add option to create a DEBUG build
Diffstat (limited to 'lang')
-rw-r--r--lang/hiphop-php/Makefile10
-rw-r--r--lang/hiphop-php/files/patch-hphp-util-assertions.h11
2 files changed, 21 insertions, 0 deletions
diff --git a/lang/hiphop-php/Makefile b/lang/hiphop-php/Makefile
index 5971ff1fcd87..07671f924841 100644
--- a/lang/hiphop-php/Makefile
+++ b/lang/hiphop-php/Makefile
@@ -3,6 +3,7 @@
PORTNAME= hiphop-php
PORTVERSION= 2.1
+PORTREVISION= 1
CATEGORIES= lang devel www
MASTER_SITES= https://github.com/facebook/hiphop-php/archive/:main \
http://unicode.org/Public/UNIDATA/:unidata \
@@ -45,6 +46,8 @@ LIB_DEPENDS= icudata:${PORTSDIR}/devel/icu \
unwind:${PORTSDIR}/devel/libunwind \
glog:${PORTSDIR}/devel/glog
+OPTIONS_DEFINE= DEBUG
+
ONLY_FOR_ARCHS= amd64
ONLY_FOR_ARCHS_REASON= This program is developed for amd64 only
@@ -97,6 +100,13 @@ DISTFILES+= ${DISTNAME}${EXTRACT_SUFX}:main \
8859-15.TXT:mappings \
8859-16.TXT:mappings
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDEBUG}
+CMAKE_BUILD_TYPE= Debug
+CONFIGURE_ARGS+= -DCMAKE_BUILD_TYPE=${CMAKE_BUILD_TYPE}
+.endif
+
.include <bsd.port.pre.mk>
_CFLAGS= ${CFLAGS} -DHAVE_POSIX_FALLOCATE=1
diff --git a/lang/hiphop-php/files/patch-hphp-util-assertions.h b/lang/hiphop-php/files/patch-hphp-util-assertions.h
new file mode 100644
index 000000000000..412e2a92d894
--- /dev/null
+++ b/lang/hiphop-php/files/patch-hphp-util-assertions.h
@@ -0,0 +1,11 @@
+--- hphp/util/assertions.h.orig 2013-07-22 00:36:45.262881238 +0200
++++ hphp/util/assertions.h 2013-07-22 00:37:05.484417990 +0200
+@@ -86,7 +86,7 @@
+ const char* file,
+ unsigned int line,
+ const char* func) {
+-#if !defined(NDEBUG) && !defined(__APPLE__)
++#if !defined(NDEBUG) && !defined(__APPLE__) && !defined(__FreeBSD__)
+ __assert_fail(e, file, line, func);
+ #else
+ extern void impl_assert_fail(const char*,