aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2016-08-25 19:13:11 +0800
committerolgeni <olgeni@FreeBSD.org>2016-08-25 19:13:11 +0800
commitcada6fe0b140e034dafb39546354434f8b976c71 (patch)
treedfd9eddd2a4ac3a3d5a6d6062acf53ee34d88582 /lang
parentb2ee6cb036a09a751dd6f1d2f568cf5cd88036ca (diff)
downloadfreebsd-ports-gnome-cada6fe0b140e034dafb39546354434f8b976c71.tar.gz
freebsd-ports-gnome-cada6fe0b140e034dafb39546354434f8b976c71.tar.zst
freebsd-ports-gnome-cada6fe0b140e034dafb39546354434f8b976c71.zip
Add support for native libraries to lang/erlang-runtime19, and fix
build on 11.x/HEAD.
Diffstat (limited to 'lang')
-rw-r--r--lang/erlang-runtime19/Makefile22
1 files changed, 20 insertions, 2 deletions
diff --git a/lang/erlang-runtime19/Makefile b/lang/erlang-runtime19/Makefile
index e64b8b06110c..7414eef37fb3 100644
--- a/lang/erlang-runtime19/Makefile
+++ b/lang/erlang-runtime19/Makefile
@@ -33,19 +33,22 @@ SUB_LIST= ERLANG_LIB=${ERLANG_LIB}
MAKE_JOBS_UNSAFE=yes
-OPTIONS_DEFINE= DOCS DTRACE GCC GS HIPE JAVA KQUEUE ODBC OPENSSL SCTP SMP THREADS WX DIRTY
+OPTIONS_DEFINE= DIRTY DOCS DTRACE GCC GS HIPE JAVA KQUEUE NATIVE ODBC OPENSSL SCTP SMP THREADS WX
DIRTY_DESC= Enable Dirty schedulers (experimental)
DTRACE_DESC= Enable DTrace support
GS_DESC= Enable GS application (deprecated)
HIPE_DESC= Build native HiPE compiler
KQUEUE_DESC= Enable Kernel Poll (kqueue) support
+NATIVE_DESC= Enable native libraries
SCTP_DESC= Enable SCTP support
SMP_DESC= Enable SMP support
WX_DESC= Enable WX application
+NATIVE_IMPLIES= HIPE
+
OPTIONS_DEFAULT=HIPE KQUEUE OPENSSL SCTP SMP THREADS
-OPTIONS_EXCLUDE_DragonFly= HIPE SCTP
+OPTIONS_EXCLUDE_DragonFly= HIPE NATIVE SCTP
ERL_RELEASE= 19.0
@@ -70,6 +73,10 @@ IGNORE= support for DTrace on amd64 requires GCC option
.endif
.endif
+.if ${OPSYS} == FreeBSD && ${OSVERSION} > 1100000
+CFLAGS+= -DMAP_NORESERVE=0
+.endif
+
.if ${PORT_OPTIONS:MGCC}
USE_GCC?= yes
.endif
@@ -103,6 +110,12 @@ CONFIGURE_ARGS+=--enable-hipe
CONFIGURE_ARGS+=--disable-hipe
.endif
+.if ${PORT_OPTIONS:MNATIVE}
+CONFIGURE_ARGS+=--enable-native-libs
+.else
+CONFIGURE_ARGS+=--disable-native-libs
+.endif
+
.if ${PORT_OPTIONS:MKQUEUE}
CONFIGURE_ARGS+=--enable-kernel-poll
.else
@@ -191,6 +204,11 @@ post-configure:
${RM} ${WRKSRC}/lib/odbc/SKIP
.endif
+.if ${PORT_OPTIONS:MNATIVE}
+pre-build:
+ @cd ${WRKSRC} && ${MAKE_CMD} clean
+.endif
+
post-install:
for SECTION in 1 3 4 6 7; do \
${TAR} --unlink -xzpf ${DISTDIR}/${DIST_SUBDIR}/${ERLANG_MAN} \