aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-03-08 22:28:16 +0800
committermiwi <miwi@FreeBSD.org>2007-03-08 22:28:16 +0800
commitf796f25df1dfab23c370b39e3fdb8acf3d17f980 (patch)
tree67285e5c28d0e4982aa5680ae2ba229e48b28eeb /lang
parent4e37d2f085197187364ff1e9139e006125b4b415 (diff)
downloadfreebsd-ports-gnome-f796f25df1dfab23c370b39e3fdb8acf3d17f980.tar.gz
freebsd-ports-gnome-f796f25df1dfab23c370b39e3fdb8acf3d17f980.tar.zst
freebsd-ports-gnome-f796f25df1dfab23c370b39e3fdb8acf3d17f980.zip
- Adds TCL85_MAN and TCLSH_WRAPPER to OPTIONS
- Removes pseudo-installation of tclsh in favour of new lang/tcl-tk-wrapper port - Replaces NO_TCL85_MAN with WITHOUT_TCL85_MAN to comply with structure of lang/tcl84 - Removes NOPORTDOCS because NO_INSTALL_MANPAGES and NOPORTDOCS aren't the same PR: 110083 Submitted by: Martin Matuska <martin@matuska.org> (maintainer)
Diffstat (limited to 'lang')
-rw-r--r--lang/tcl85/Makefile17
-rw-r--r--lang/tcl85/pkg-deinstall.tclsh22
-rw-r--r--lang/tcl85/pkg-install.tclsh35
-rw-r--r--lang/tcl86/Makefile17
-rw-r--r--lang/tcl86/pkg-deinstall.tclsh22
-rw-r--r--lang/tcl86/pkg-install.tclsh35
6 files changed, 16 insertions, 132 deletions
diff --git a/lang/tcl85/Makefile b/lang/tcl85/Makefile
index 090ed8ea7e72..578eaaf04ab6 100644
--- a/lang/tcl85/Makefile
+++ b/lang/tcl85/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tcl
PORTVERSION= 8.5.a.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= tcl
@@ -25,14 +25,13 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared --includedir=${PREFIX}/include/tcl${TCL_VER}
CONFIGURE_ENV= PORTSDIR=${PORTSDIR}
MAKE_ENV= SHORT_TCL_VER=85 LANG=C LC_ALL=C # LANG=C is required for some of UTF-using tests
-PKGINSTALL= ${PKGDIR}/pkg-install.tclsh
-PKGDEINSTALL= ${PKGDIR}/pkg-deinstall.tclsh
TCL_VER= 8.5
NOPRECIOUSMAKEVARS= Too many _MLINKS for README.html
PLIST_SUB= TCL_VER=${TCL_VER} SHORT_TCL_VER=85
EXTRACT_AFTER_ARGS=|${TAR} -xpf - --exclude compat/
-OPTIONS= NO_TCL85_MAN "Do not install tcl85 manpages" off
+OPTIONS= TCL85_MAN "Install tcl 8.5 manpages" on \
+ TCLSH_WRAPPER "Require tclsh wrapper from ports" off
.include <bsd.port.pre.mk>
@@ -50,11 +49,11 @@ CONFLICTS= tcl-threads-8.5*
LATEST_LINK= tcl85${THREADS_SUFFIX}
-.if defined(NOPORTDOCS)
-NO_INSTALL_MANPAGES= true
+.if defined(WITH_TCLSH_WRAPPER)
+RUN_DEPENDS+= tclsh:${PORTSDIR}/lang/tcl-tk-wrapper
.endif
-.if defined(NO_INSTALL_MANPAGES) || defined(WITH_NO_TCL85_MAN)
+.if defined(NO_INSTALL_MANPAGES) || defined(WITHOUT_TCL85_MAN)
PLIST_SUB+= INSTMAN='@comment '
@@ -703,7 +702,7 @@ post-configure:
${REINPLACE_CMD} \
-e 's,-DNO_MEMMOVE=1,,' -e 's,-DNO_STRING_H=1,,' \
-e 's,^COMPAT_OBJS.*,,' ${WRKSRC}/Makefile
-.if defined(NO_INSTALL_MANPAGES) || defined(WITH_NO_TCL85_MAN)
+.if defined(NO_INSTALL_MANPAGES) || defined(WITHOUT_TCL85_MAN)
${REINPLACE_CMD} -e 's|^MAN_INSTALL_DIR.*$$|MAN_INSTALL_DIR = ${WRKDIR}|' \
${WRKSRC}/Makefile
. for mp in ${MAN1} ${MAN3} ${MANN}
@@ -724,7 +723,7 @@ post-install:
.if exists(${PKGINSTALL})
${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL}
.endif
-.if !defined(NO_INSTALL_MANPAGES) && !defined(WITH_NO_TCL85_MAN)
+.if !defined(NO_INSTALL_MANPAGES) && !defined(WITHOUT_TCL85_MAN)
${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/../doc/man.macros ${DATADIR}
.endif
diff --git a/lang/tcl85/pkg-deinstall.tclsh b/lang/tcl85/pkg-deinstall.tclsh
deleted file mode 100644
index 78c3fcf12f33..000000000000
--- a/lang/tcl85/pkg-deinstall.tclsh
+++ /dev/null
@@ -1,22 +0,0 @@
-#! /bin/sh
-#
-# Remove the ${PREFIX}/bin/tclsh script that gets installed by INSTALL.tclsh
-# if we are the last tclsh installation to be pkg_delete'd.
-#
-# $FreeBSD$
-#
-
-#
-# Explicitly listing /usr/X11R6/bin here is debatable.
-#
-BINDIR="${PKG_PREFIX}/bin ${X11BASE}/bin"
-TCLSH=${PKG_PREFIX}/bin/tclsh
-
-tclshs=$(/bin/ls ${BINDIR} 2> /dev/null | \
- egrep '^(i?tclsh[0-9]+\.[0-9]+(\_r)?([a-z][a-z])?)|otclsh$')
-
-if [ "$tclshs" = "" -a -f ${TCLSH} ] && \
- (head -3 ${TCLSH} | grep awieYJFnsuILOnfsYEW) > /dev/null 2>&1
-then
- rm -f ${PKG_PREFIX}/bin/tclsh
-fi
diff --git a/lang/tcl85/pkg-install.tclsh b/lang/tcl85/pkg-install.tclsh
deleted file mode 100644
index 3b808e2b500f..000000000000
--- a/lang/tcl85/pkg-install.tclsh
+++ /dev/null
@@ -1,35 +0,0 @@
-#!/bin/sh
-
-# The user may have a tclsh they want to preserve
-ver=`grep -a awieYJFnsuILOnfsYEW ${PKG_PREFIX}/bin/tclsh 2> /dev/null \
- | sed -e 's/.*\*\*//'`
-if [ ! -e ${PKG_PREFIX}/bin/tclsh ] || [ "$ver" != "" -a "$ver" -lt 002 ]
-then
- [ -f ${PKG_PREFIX}/bin/tclsh ] && chmod u+w ${PKG_PREFIX}/bin/tclsh
-
- mkdir -p ${PKG_PREFIX}/bin
- cat > ${PKG_PREFIX}/bin/tclsh <<'EOF'
-#!/bin/sh
-# Installed by ports system. id: awieYJFnsuILOnfsYEW**002
-#
-# $FreeBSD$
-#
-
-(
-echo "In FreeBSD, tclsh is named with a version number. This is because"
-echo "different versions of tclsh are not compatible with each other and"
-echo "they can not all be called \"tclsh\"! You may need multiple versions"
-echo "installed because a given port may depend on a specific version."
-echo
-echo "On your system, tclsh is installed under at least the following names:"
-echo
-for name in $(/bin/ls $(echo $PATH | sed 's/:/ /g') 2> /dev/null | egrep '^(i?tclsh[0-9]+\.[0-9]+(\_r)?([a-z][a-z])?)|otclsh$')
-do
- echo $name
-done
-[ "$name" = "" ] && echo "No tclsh installations found, sorry."
-) 1>&2
-exit 1
-EOF
- chmod 555 ${PKG_PREFIX}/bin/tclsh
-fi
diff --git a/lang/tcl86/Makefile b/lang/tcl86/Makefile
index 090ed8ea7e72..578eaaf04ab6 100644
--- a/lang/tcl86/Makefile
+++ b/lang/tcl86/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tcl
PORTVERSION= 8.5.a.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= tcl
@@ -25,14 +25,13 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared --includedir=${PREFIX}/include/tcl${TCL_VER}
CONFIGURE_ENV= PORTSDIR=${PORTSDIR}
MAKE_ENV= SHORT_TCL_VER=85 LANG=C LC_ALL=C # LANG=C is required for some of UTF-using tests
-PKGINSTALL= ${PKGDIR}/pkg-install.tclsh
-PKGDEINSTALL= ${PKGDIR}/pkg-deinstall.tclsh
TCL_VER= 8.5
NOPRECIOUSMAKEVARS= Too many _MLINKS for README.html
PLIST_SUB= TCL_VER=${TCL_VER} SHORT_TCL_VER=85
EXTRACT_AFTER_ARGS=|${TAR} -xpf - --exclude compat/
-OPTIONS= NO_TCL85_MAN "Do not install tcl85 manpages" off
+OPTIONS= TCL85_MAN "Install tcl 8.5 manpages" on \
+ TCLSH_WRAPPER "Require tclsh wrapper from ports" off
.include <bsd.port.pre.mk>
@@ -50,11 +49,11 @@ CONFLICTS= tcl-threads-8.5*
LATEST_LINK= tcl85${THREADS_SUFFIX}
-.if defined(NOPORTDOCS)
-NO_INSTALL_MANPAGES= true
+.if defined(WITH_TCLSH_WRAPPER)
+RUN_DEPENDS+= tclsh:${PORTSDIR}/lang/tcl-tk-wrapper
.endif
-.if defined(NO_INSTALL_MANPAGES) || defined(WITH_NO_TCL85_MAN)
+.if defined(NO_INSTALL_MANPAGES) || defined(WITHOUT_TCL85_MAN)
PLIST_SUB+= INSTMAN='@comment '
@@ -703,7 +702,7 @@ post-configure:
${REINPLACE_CMD} \
-e 's,-DNO_MEMMOVE=1,,' -e 's,-DNO_STRING_H=1,,' \
-e 's,^COMPAT_OBJS.*,,' ${WRKSRC}/Makefile
-.if defined(NO_INSTALL_MANPAGES) || defined(WITH_NO_TCL85_MAN)
+.if defined(NO_INSTALL_MANPAGES) || defined(WITHOUT_TCL85_MAN)
${REINPLACE_CMD} -e 's|^MAN_INSTALL_DIR.*$$|MAN_INSTALL_DIR = ${WRKDIR}|' \
${WRKSRC}/Makefile
. for mp in ${MAN1} ${MAN3} ${MANN}
@@ -724,7 +723,7 @@ post-install:
.if exists(${PKGINSTALL})
${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL}
.endif
-.if !defined(NO_INSTALL_MANPAGES) && !defined(WITH_NO_TCL85_MAN)
+.if !defined(NO_INSTALL_MANPAGES) && !defined(WITHOUT_TCL85_MAN)
${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/../doc/man.macros ${DATADIR}
.endif
diff --git a/lang/tcl86/pkg-deinstall.tclsh b/lang/tcl86/pkg-deinstall.tclsh
deleted file mode 100644
index 78c3fcf12f33..000000000000
--- a/lang/tcl86/pkg-deinstall.tclsh
+++ /dev/null
@@ -1,22 +0,0 @@
-#! /bin/sh
-#
-# Remove the ${PREFIX}/bin/tclsh script that gets installed by INSTALL.tclsh
-# if we are the last tclsh installation to be pkg_delete'd.
-#
-# $FreeBSD$
-#
-
-#
-# Explicitly listing /usr/X11R6/bin here is debatable.
-#
-BINDIR="${PKG_PREFIX}/bin ${X11BASE}/bin"
-TCLSH=${PKG_PREFIX}/bin/tclsh
-
-tclshs=$(/bin/ls ${BINDIR} 2> /dev/null | \
- egrep '^(i?tclsh[0-9]+\.[0-9]+(\_r)?([a-z][a-z])?)|otclsh$')
-
-if [ "$tclshs" = "" -a -f ${TCLSH} ] && \
- (head -3 ${TCLSH} | grep awieYJFnsuILOnfsYEW) > /dev/null 2>&1
-then
- rm -f ${PKG_PREFIX}/bin/tclsh
-fi
diff --git a/lang/tcl86/pkg-install.tclsh b/lang/tcl86/pkg-install.tclsh
deleted file mode 100644
index 3b808e2b500f..000000000000
--- a/lang/tcl86/pkg-install.tclsh
+++ /dev/null
@@ -1,35 +0,0 @@
-#!/bin/sh
-
-# The user may have a tclsh they want to preserve
-ver=`grep -a awieYJFnsuILOnfsYEW ${PKG_PREFIX}/bin/tclsh 2> /dev/null \
- | sed -e 's/.*\*\*//'`
-if [ ! -e ${PKG_PREFIX}/bin/tclsh ] || [ "$ver" != "" -a "$ver" -lt 002 ]
-then
- [ -f ${PKG_PREFIX}/bin/tclsh ] && chmod u+w ${PKG_PREFIX}/bin/tclsh
-
- mkdir -p ${PKG_PREFIX}/bin
- cat > ${PKG_PREFIX}/bin/tclsh <<'EOF'
-#!/bin/sh
-# Installed by ports system. id: awieYJFnsuILOnfsYEW**002
-#
-# $FreeBSD$
-#
-
-(
-echo "In FreeBSD, tclsh is named with a version number. This is because"
-echo "different versions of tclsh are not compatible with each other and"
-echo "they can not all be called \"tclsh\"! You may need multiple versions"
-echo "installed because a given port may depend on a specific version."
-echo
-echo "On your system, tclsh is installed under at least the following names:"
-echo
-for name in $(/bin/ls $(echo $PATH | sed 's/:/ /g') 2> /dev/null | egrep '^(i?tclsh[0-9]+\.[0-9]+(\_r)?([a-z][a-z])?)|otclsh$')
-do
- echo $name
-done
-[ "$name" = "" ] && echo "No tclsh installations found, sorry."
-) 1>&2
-exit 1
-EOF
- chmod 555 ${PKG_PREFIX}/bin/tclsh
-fi