aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-09-20 18:07:37 +0800
committerjbeich <jbeich@FreeBSD.org>2018-09-20 18:07:37 +0800
commitfdc68411814d909375f3d0a34db512983fcc4d23 (patch)
tree2341ddb714a55e841e10f657845b3ec4769885f6 /lang
parent954be580b9d4594e7ee74972df648035bc3798a3 (diff)
downloadfreebsd-ports-gnome-fdc68411814d909375f3d0a34db512983fcc4d23.tar.gz
freebsd-ports-gnome-fdc68411814d909375f3d0a34db512983fcc4d23.tar.zst
freebsd-ports-gnome-fdc68411814d909375f3d0a34db512983fcc4d23.zip
lang/rust: unbreak if ssl != base
[ 13%] Building C object src/CMakeFiles/libssh2.dir/channel.c.o /usr/bin/cc -DLIBSSH2_CLEAR_MEMORY -DLIBSSH2_DH_GEX_NEW=1 -DLIBSSH2_HAVE_ZLIB=1 -DLIBSSH2_OPENSSL -I/usr/local/include -Isrc/vendor/libssh2-sys/libssh2/include -Ibuild/x86_64-unknown-freebsd/stage2-tools/x86_64-unknown-freebsd/release/build/libssh2-sys-149db94635ec1367/out/build/src -ffunction-sections -fdata-sections -fPIC -ffunction-sections -fdata-sections -fPIC -m64 -m64 -O3 -DNDEBUG -std=gnu90 -o CMakeFiles/libssh2.dir/channel.c.o -c src/vendor/libssh2-sys/libssh2/src/channel.c src/vendor/libssh2-sys/libssh2/src/channel.c:2262:44: error: use of undeclared identifier 'LIBSSH2_ERROR_CHANNEL_WINDOW_FULL' return _libssh2_error(session, LIBSSH2_ERROR_CHANNEL_WINDOW_FULL, ^ PR: 231411 Reported by: many Obtained from: upstream (libssh2) Approved by: portmgr blanket
Diffstat (limited to 'lang')
-rw-r--r--lang/rust/files/patch-src_vendor_libssh2-sys_libssh2_src_CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/lang/rust/files/patch-src_vendor_libssh2-sys_libssh2_src_CMakeLists.txt b/lang/rust/files/patch-src_vendor_libssh2-sys_libssh2_src_CMakeLists.txt
new file mode 100644
index 000000000000..6176f5652fb4
--- /dev/null
+++ b/lang/rust/files/patch-src_vendor_libssh2-sys_libssh2_src_CMakeLists.txt
@@ -0,0 +1,13 @@
+https://github.com/libssh2/libssh2/commit/54bef4c5dad868a9d45fdbfca9729b191c0abab5
+
+--- src/vendor/libssh2-sys/libssh2/src/CMakeLists.txt.orig 2018-09-11 04:49:50.000000000 +0000
++++ src/vendor/libssh2-sys/libssh2/src/CMakeLists.txt
+@@ -217,7 +217,7 @@ set_target_properties(libssh2 PROPERTIES PREFIX "")
+
+ target_compile_definitions(libssh2 PRIVATE ${PRIVATE_COMPILE_DEFINITIONS})
+ target_include_directories(libssh2
+- PRIVATE ${PRIVATE_INCLUDE_DIRECTORIES}
++ PRIVATE "${PROJECT_SOURCE_DIR}/include/" ${PRIVATE_INCLUDE_DIRECTORIES}
+ PUBLIC
+ $<BUILD_INTERFACE:${PROJECT_SOURCE_DIR}/include>
+ $<INSTALL_INTERFACE:$<INSTALL_PREFIX>/${CMAKE_INSTALL_INCLUDEDIR}>)