aboutsummaryrefslogtreecommitdiffstats
path: root/mail/abook
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2007-12-24 06:44:33 +0800
committerstas <stas@FreeBSD.org>2007-12-24 06:44:33 +0800
commit06949a62c322973728dc97828329795c2ae1ca99 (patch)
tree0782fe9d962486f515191fe2d5b331f4a5159dad /mail/abook
parent50bedfcb2023ed7f72ef219aaf8096c6e9dbe89f (diff)
downloadfreebsd-ports-gnome-06949a62c322973728dc97828329795c2ae1ca99.tar.gz
freebsd-ports-gnome-06949a62c322973728dc97828329795c2ae1ca99.tar.zst
freebsd-ports-gnome-06949a62c322973728dc97828329795c2ae1ca99.zip
- Add a patch to prevent segfault in the editor
- Bump portrevision. Obtained from: abook project
Diffstat (limited to 'mail/abook')
-rw-r--r--mail/abook/Makefile1
-rw-r--r--mail/abook/files/patch-ui.c18
2 files changed, 19 insertions, 0 deletions
diff --git a/mail/abook/Makefile b/mail/abook/Makefile
index aacf3d991354..d2f4cd9dcee0 100644
--- a/mail/abook/Makefile
+++ b/mail/abook/Makefile
@@ -7,6 +7,7 @@
PORTNAME= abook
PORTVERSION= 0.5.6
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/mail/abook/files/patch-ui.c b/mail/abook/files/patch-ui.c
new file mode 100644
index 000000000000..bacfd55a491d
--- /dev/null
+++ b/mail/abook/files/patch-ui.c
@@ -0,0 +1,18 @@
+--- ui.c 10 Apr 2006 08:15:46 -0000 1.57
++++ ui.c 6 Sep 2006 02:24:33 -0000 1.58
+@@ -569,9 +569,13 @@
+ } else {
+ char *s;
+ s = ui_readline("/", findstr, MAX_FIELD_LEN - 1, 0);
+- strncpy(findstr, s, MAX_FIELD_LEN);
+- free(s);
+ refresh_screen();
++ if(s == NULL) {
++ return; /* user cancelled (ctrl-G) */
++ } else {
++ strncpy(findstr, s, MAX_FIELD_LEN);
++ free(s);
++ }
+ }
+
+ if( (item = find_item(findstr, curitem + !!next, search_fields)) < 0 &&