aboutsummaryrefslogtreecommitdiffstats
path: root/mail/addresses-goodies
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2015-04-09 15:44:41 +0800
committerbapt <bapt@FreeBSD.org>2015-04-09 15:44:41 +0800
commitba50e6fa6dadb80fdb12b7fc2be35a67b6867ec7 (patch)
treeb7aed86ac84412d11603ce23b7893d46f0d7475b /mail/addresses-goodies
parent3fcb7028e93fb51c19b4379e9c99091b90563e30 (diff)
downloadfreebsd-ports-gnome-ba50e6fa6dadb80fdb12b7fc2be35a67b6867ec7.tar.gz
freebsd-ports-gnome-ba50e6fa6dadb80fdb12b7fc2be35a67b6867ec7.tar.zst
freebsd-ports-gnome-ba50e6fa6dadb80fdb12b7fc2be35a67b6867ec7.zip
Convert bsd.gnustep.mk to USES=gnustep
Simplify gnustep ports Hook into the regular ports framework: - LIB_DEPENDS for library dependencies - Use regular USE_LDCONFIG Reuse USES=objc (automatic) USE_GNUSTEP is now a macro to set the dependencies and build feature needed. Accepted arguments: back base build gui Merge deskutils/preferencepanes into deskutils/systempreferences
Diffstat (limited to 'mail/addresses-goodies')
-rw-r--r--mail/addresses-goodies/Makefile19
1 files changed, 7 insertions, 12 deletions
diff --git a/mail/addresses-goodies/Makefile b/mail/addresses-goodies/Makefile
index 99928d17a924..e3a5d9279162 100644
--- a/mail/addresses-goodies/Makefile
+++ b/mail/addresses-goodies/Makefile
@@ -4,8 +4,7 @@ PORTNAME= addresses
PORTVERSION= 0.4.8
PORTREVISION= 3
CATEGORIES= mail gnustep
-MASTER_SITES= ${MASTER_SITE_SAVANNAH}
-MASTER_SITE_SUBDIR= gap
+MASTER_SITES= SAVANNAH/gap
PKGNAMESUFFIX= -goodies${PKGNAMESUFFIX2}
DISTNAME= Addresses-${PORTVERSION}
@@ -14,20 +13,16 @@ COMMENT= Goodies for addressbook for GNUstep
LICENSE= LGPL21
-USE_GNUSTEP= yes
-USE_GNUSTEP_BACK= yes
-USE_GNUSTEP_BUILD= yes
-USE_GNUSTEP_INSTALL= yes
-USE_GNUSTEP_SYSTEM_LIBS+= Inspector:${GWORKSPACE_PORT}
-USE_GNUSTEP_LOCAL_LIBS+= Addresses:${ADDRESSES_PORT}
-USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
+USES= gnustep
+USE_GNUSTEP= back build
+
+LIB_DEPENDS= libInspector.so:${PORTSDIR}/deskutils/gworkspace \
+ libAddresses.so:${PORTSDIR}/mail/addresses
+USE_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
UNIQUENAME= ${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}
WRKSRC= ${WRKDIR}/Addresses-${PORTVERSION}/Goodies
-ADDRESSES_PORT?= mail/addresses
-GWORKSPACE_PORT?= deskutils/gworkspace
-
post-patch:
${REINPLACE_CMD} -e 's|LDAPAddressBook||' \
-e 's|VCFViewer||' \