aboutsummaryrefslogtreecommitdiffstats
path: root/mail/akpop3d
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-01-25 20:54:44 +0800
committerkrion <krion@FreeBSD.org>2004-01-25 20:54:44 +0800
commiteaf900ad13df382adbab3623a402e1ca344ba454 (patch)
tree0aee3ad2bcda3c58c5bc8839ca3ff49b8f37ceb6 /mail/akpop3d
parent328d34fb95b3528527655d2069c05044c59ed382 (diff)
downloadfreebsd-ports-gnome-eaf900ad13df382adbab3623a402e1ca344ba454.tar.gz
freebsd-ports-gnome-eaf900ad13df382adbab3623a402e1ca344ba454.tar.zst
freebsd-ports-gnome-eaf900ad13df382adbab3623a402e1ca344ba454.zip
- Add patch to authenticate users when using an external
authfile - Bump PORTREVISION PR: 61872 Submitted by: David P. Reese Jr. <daver@solidcore.com>
Diffstat (limited to 'mail/akpop3d')
-rw-r--r--mail/akpop3d/Makefile5
-rw-r--r--mail/akpop3d/files/patch-authenticate.c11
2 files changed, 14 insertions, 2 deletions
diff --git a/mail/akpop3d/Makefile b/mail/akpop3d/Makefile
index e08b6d969d88..e01ef3b9f3f8 100644
--- a/mail/akpop3d/Makefile
+++ b/mail/akpop3d/Makefile
@@ -7,6 +7,7 @@
PORTNAME= akpop3d
PORTVERSION= 0.7.4
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://www.synflood.at/akpop3d/
DISTNAME= ${PORTNAME}-${PORTVERSION}
@@ -28,7 +29,7 @@ LDFLAGS+= -L${OPENSSLBASE}/lib -lssl -lcrypto
.endif
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/akpop3d ${PREFIX}/bin/
- ${INSTALL_MAN} ${WRKSRC}/akpop3d.8 ${PREFIX}/man/man8/
+ ${INSTALL_PROGRAM} ${WRKSRC}/akpop3d ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/akpop3d.8 ${MANPREFIX}/man/man8
.include <bsd.port.mk>
diff --git a/mail/akpop3d/files/patch-authenticate.c b/mail/akpop3d/files/patch-authenticate.c
new file mode 100644
index 000000000000..41de987f83b7
--- /dev/null
+++ b/mail/akpop3d/files/patch-authenticate.c
@@ -0,0 +1,11 @@
+--- authenticate.c.orig Sun Jan 25 13:49:01 2004
++++ authenticate.c Sun Jan 25 13:49:33 2004
+@@ -195,7 +195,7 @@
+ syslog(LOG_ERR,"%s: %s: %s","failed to read auth file",authfile,strerror(errno));
+ return 0;
+ }
+- while ((0!=ferror(fptr)) && (0!=feof(fptr))) {
++ while ((!ferror(fptr)) && (!feof(fptr))) {
+ linebuf[0] = '\0';
+ if (fgets(linebuf, sizeof(linebuf), fptr) == NULL) {
+ fclose(fptr);