aboutsummaryrefslogtreecommitdiffstats
path: root/mail/alpine
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-06-07 03:31:40 +0800
committerbapt <bapt@FreeBSD.org>2013-06-07 03:31:40 +0800
commit2a8aee42f13a99b5456d25a41fe09d00b2f3948a (patch)
treec6401071332488ab96d504c8d322f4f196112147 /mail/alpine
parentfa8751630618cfdbe47b45670f929eab7591c2ed (diff)
downloadfreebsd-ports-gnome-2a8aee42f13a99b5456d25a41fe09d00b2f3948a.tar.gz
freebsd-ports-gnome-2a8aee42f13a99b5456d25a41fe09d00b2f3948a.tar.zst
freebsd-ports-gnome-2a8aee42f13a99b5456d25a41fe09d00b2f3948a.zip
Convert to new options framework
Diffstat (limited to 'mail/alpine')
-rw-r--r--mail/alpine/Makefile54
1 files changed, 27 insertions, 27 deletions
diff --git a/mail/alpine/Makefile b/mail/alpine/Makefile
index 6d389072e631..043ac6d43a2f 100644
--- a/mail/alpine/Makefile
+++ b/mail/alpine/Makefile
@@ -10,19 +10,19 @@ DIST_SUBDIR= alpine-${PORTVERSION}
MAINTAINER= c.petrik.sosa@gmail.com
COMMENT?= Mail and news client descended from Pine
-OPTIONS+= THREADS "Compile with thread support" on \
- MOUSE "Enable mouse support for xterm" on \
- NLS "National Language Support" off \
- ISPELL "Use ispell instead of aspell as default speller" off \
- NOSPELL "Use no default speller (overrides both)" off
+OPTIONS_DEFINE+= THREADS MOUSE NLS ISPELL NOSPELL
+OPTIONS_DEFAULT+= THREADS MOUSE
+MOUSE_DESC= Enable mouse support for xterm
+ISPELL_DESC= Use ispell instead of aspell as default speller
+NOSPELL_DESC= Use no default speller (overrides both)
.if !defined(PICO_ALPINE_SLAVE)
-OPTIONS+= PICO "Build and install pico, the default editor" on \
- IPV6 "Add support for IPv6" on \
- LDAP "Add support for LDAP" off \
- PASSFILE "Support for a stored password file (DANGEROUS)" off \
- CONS25 "Add a patch to support color for default console" off \
- QUOTA "Add a patch for disk quota checking on IMAP" off \
- MAILDIR "Add a patch for maildir support" off
+OPTIONS_DEFINE+= PICO IPV6 LDAP PASSFILE CONS25 QUOTA MAILDIR
+OPTIONS_DEFAULT+= PICO
+PICO_DESC= Build and install pico, the default editor
+PASSFILE_DESC= Support for a stored password file (DANGEROUS)
+CONS25_DESC= Add a patch to support color for default console
+QUOTA_DESC= Add a patch for disk quota checking on IMAP
+MAILDIR_DESC= Add a patch for maildir support
.endif
USE_BZIP2= yes
@@ -46,26 +46,26 @@ USE_OPENSSL= yes
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_THREADS)
+.if ${PORT_OPTIONS:MTHREADS}
CONFIGURE_ARGS+= --with-pthread
.else
CONFIGURE_ARGS+= --without-pthread
.endif
-.if !defined(WITHOUT_MOUSE)
+.if ${PORT_OPTIONS:MMOUSE}
CONFIGURE_ARGS+= --enable-mouse
.else
CONFIGURE_ARGS+= --disable-mouse
.endif
-.if defined(WITH_NLS)
+.if ${PORT_OPTIONS:MNLS}
CONFIGURE_ARGS+= --enable-nls
.else
CONFIGURE_ARGS+= --disable-nls
.endif
-.if !defined(WITH_NOSPELL)
-.if !defined(WITH_ISPELL)
+.if ! ${PORT_OPTIONS:MNOSPELL}
+.if ! ${PORT_OPTIONS:MISPELL}
CONFIGURE_ARGS+=--with-interactive-spellcheck=${LOCALBASE}/bin/aspell
BUILD_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
RUN_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
@@ -79,47 +79,47 @@ CONFIGURE_ARGS+=--without-simple-spellcheck --without-interactive-spellcheck
.endif
.if !defined(PICO_ALPINE_SLAVE)
-.if !defined(WITHOUT_PICO)
+.if ${PORT_OPTIONS:MPICO}
RUN_DEPENDS+= pico:${PORTSDIR}/editors/pico-alpine
.endif
-.if !defined(WITHOUT_IPV6)
+.if ${PORT_OPTIONS:MIPV6}
CONFIGURE_ARGS+= --with-ipv6
.else
CONFIGURE_ARGS+= --without-ipv6
.endif
-.if defined(WITH_LDAP)
+.if ${PORT_OPTIONS:MLDAP}
USE_OPENLDAP= yes
CONFIGURE_ARGS+= --with-ldap --with-ldap-dir=${LOCALBASE}
.else
CONFIGURE_ARGS+= --without-ldap
.endif
-.if defined(WITH_PASSFILE)
+.if ${PORT_OPTIONS:MPASSFILE}
ALPINE_PASSFILE?= .alpine.pwd
CONFIGURE_ARGS+= --with-passfile=.alpine.pwd
.endif
-.if defined(WITH_CONS25)
+.if ${PORT_OPTIONS:MCONS25}
EXTRA_PATCHES= ${FILESDIR}/cons25-alpine_keymenu.c
.endif
-.if defined(WITH_QUOTA) || defined(WITH_MAILDIR)
+.if ${PORT_OPTIONS:MQUOTA) || defined(WITH_MAILDIR}
PATCH_SITES= ${MASTER_SITE_LOCAL}
PATCH_SITE_SUBDIR= dougb/alpine-${PORTVERSION}/
PATCH_DIST_ARGS+= -E --quiet -d ${PATCH_WRKSRC} -p1
.endif
-.if defined(WITH_QUOTA)
+.if ${PORT_OPTIONS:MQUOTA}
PATCHFILES+= quota.patch.gz
.endif
-.if defined(WITH_MAILDIR)
+.if ${PORT_OPTIONS:MMAILDIR}
PATCHFILES+= maildir.patch.gz
.endif
-.if !defined(WITHOUT_SSL)
+.if ${PORT_OPTIONS:MSSL}
CONFIGURE_ARGS+= --with-ssl-dir=${OPENSSLDIR} \
--with-ssl-include-dir=${OPENSSLINC} \
--with-ssl-lib-dir=${OPENSSLLIB} \
@@ -162,7 +162,7 @@ post-patch:
done
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} ${DOCSDIR} \
${DOCSDIR}/tech-notes
${INSTALL_DATA} ${WRKSRC}/LICENSE ${DOCSDIR}