aboutsummaryrefslogtreecommitdiffstats
path: root/mail/anubis/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-08-01 02:52:14 +0800
committerijliao <ijliao@FreeBSD.org>2002-08-01 02:52:14 +0800
commit8ab9ee28ec1a6b68b8f687b5becebc35bbdbd2fb (patch)
tree33a1fcf432fe9156abe0d116dd0fe671ce940efd /mail/anubis/Makefile
parent231f8814a000d493f8d1a78300d070dfce8d102a (diff)
downloadfreebsd-ports-gnome-8ab9ee28ec1a6b68b8f687b5becebc35bbdbd2fb.tar.gz
freebsd-ports-gnome-8ab9ee28ec1a6b68b8f687b5becebc35bbdbd2fb.tar.zst
freebsd-ports-gnome-8ab9ee28ec1a6b68b8f687b5becebc35bbdbd2fb.zip
add anubis 3.3.0
An outgoing mail processor
Diffstat (limited to 'mail/anubis/Makefile')
-rw-r--r--mail/anubis/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/mail/anubis/Makefile b/mail/anubis/Makefile
new file mode 100644
index 000000000000..f17a0c60fe90
--- /dev/null
+++ b/mail/anubis/Makefile
@@ -0,0 +1,43 @@
+# ex:ts=8
+# Ports collection makefile for: anubis
+# Date created: Jul 31, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= anubis
+PORTVERSION= 3.3.0
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= gpgme:${PORTSDIR}/security/gpgme \
+ pcre:${PORTSDIR}/devel/pcre \
+ gnugetopt:${PORTSDIR}/devel/libgnugetopt
+
+USE_REINPLACE= yes
+USE_OPENSSL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+
+MAN1= anubis.1
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|/etc|${PREFIX}/etc|g" ${WRKSRC}/src/headers.h
+ @${SED} -e "s|%%PREFIX%%|${PREFIX}|g" ${FILESDIR}/anubis.sh > \
+ ${WRKSRC}/anubis.sh
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/anubis.sh ${PREFIX}/etc/rc.d
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/TUTORIAL ${DOCSDIR}
+ @${MKDIR} ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>