aboutsummaryrefslogtreecommitdiffstats
path: root/mail/anubis
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-06-03 21:52:59 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-06-03 21:52:59 +0800
commitab1b221875648a1700b90c267a3d8c19bcaa283b (patch)
treed900ea1153b18f348b49b4f0b58ce65be64f1e3a /mail/anubis
parentc00c108907b512ddeee979f485691ccae4e1ecb3 (diff)
downloadfreebsd-ports-gnome-ab1b221875648a1700b90c267a3d8c19bcaa283b.tar.gz
freebsd-ports-gnome-ab1b221875648a1700b90c267a3d8c19bcaa283b.tar.zst
freebsd-ports-gnome-ab1b221875648a1700b90c267a3d8c19bcaa283b.zip
- Stagify
- Use new LIB_DEPENDS syntax - Fix shebang Approved by: portmgr blanket
Diffstat (limited to 'mail/anubis')
-rw-r--r--mail/anubis/Makefile27
-rw-r--r--mail/anubis/pkg-plist1
2 files changed, 14 insertions, 14 deletions
diff --git a/mail/anubis/Makefile b/mail/anubis/Makefile
index 67e87eec7355..548a8df1eac4 100644
--- a/mail/anubis/Makefile
+++ b/mail/anubis/Makefile
@@ -23,13 +23,13 @@ GSASL_DESC= GSASL support (required for databases)
GDBM_DESC= GDBM backend
SOCKS_DESC= SOCKS proxy support
-USES= pkgconfig
+USES= pkgconfig shebangfix
+SHEBANG_FILES= contrib/msg2smtp.pl
USE_RC_SUBR= anubis
USE_AUTOTOOLS= aclocal autoheader autoconf automake
ACLOCAL_ARGS= -I m4 -I am
AUTOMAKE_ARGS= --force --add-missing
-MAN1= anubis.1
INFO= anubis
PORTEXAMPLES= 1anubisrc 2anubisrc
@@ -37,7 +37,6 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_JOBS_UNSAFE= yes
-NO_STAGE= yes
.include <bsd.port.options.mk>
# Default requirement for anubis rc script
@@ -52,7 +51,7 @@ PLIST_SUB+= NLS="@comment "
.endif
.if ${PORT_OPTIONS:MGUILE}
-LIB_DEPENDS+= guile:${PORTSDIR}/lang/guile
+LIB_DEPENDS+= libguile.so:${PORTSDIR}/lang/guile
PORTEXAMPLES+= anubis.scm anubisrc.guile
PLIST_SUB+= GUILE=""
.else
@@ -61,19 +60,19 @@ PLIST_SUB+= GUILE="@comment "
.endif
.if ${PORT_OPTIONS:MGPGME}
-LIB_DEPENDS+= gpgme:${PORTSDIR}/security/gpgme
+LIB_DEPENDS+= libgpgme.so:${PORTSDIR}/security/gpgme
.else
CONFIGURE_ARGS+=--without-gpgme
.endif
.if ${PORT_OPTIONS:MGNUTLS}
-LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
+LIB_DEPENDS+= libgnutls.so:${PORTSDIR}/security/gnutls
.else
CONFIGURE_ARGS+=--without-gnutls
.endif
.if ${PORT_OPTIONS:MGSASL} || ${PORT_OPTIONS:MGDBM} || ${PORT_OPTIONS:MMYSQL} || ${PORT_OPTIONS:MPGSQL}
-LIB_DEPENDS+= gsasl:${PORTSDIR}/security/gsasl
+LIB_DEPENDS+= libgsasl.so:${PORTSDIR}/security/gsasl
PLIST_SUB+= GSASL=""
.else
CONFIGURE_ARGS+=--without-gsasl
@@ -81,7 +80,7 @@ PLIST_SUB+= GSASL="@comment "
.endif
.if ${PORT_OPTIONS:MGDBM}
-LIB_DEPENDS+= gdbm:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS+= libgdbm.so:${PORTSDIR}/databases/gdbm
CONFIGURE_ARGS+=--with-gdbm
.endif
@@ -98,7 +97,7 @@ _REQUIRE+= postgresql
.endif
.if ${PORT_OPTIONS:MPCRE}
-LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre
CONFIGURE_ARGS+=--with-pcre
.endif
@@ -122,15 +121,15 @@ post-patch:
post-install:
.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/*rc ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/*rc ${STAGEDIR}${EXAMPLESDIR}
. if ${PORT_OPTIONS:MGUILE}
cd ${WRKSRC}/examples && \
- ${INSTALL_DATA} anubis.scm anubisrc.guile ${EXAMPLESDIR}
+ ${INSTALL_DATA} anubis.scm anubisrc.guile ${STAGEDIR}${EXAMPLESDIR}
. endif
. if ${PORT_OPTIONS:MPAM}
- @${MKDIR} ${EXAMPLESDIR}/pam
- ${INSTALL_DATA} ${WRKSRC}/examples/pam/anubis* ${EXAMPLESDIR}/pam
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/pam
+ ${INSTALL_DATA} ${WRKSRC}/examples/pam/anubis* ${STAGEDIR}${EXAMPLESDIR}/pam
. endif
.endif
diff --git a/mail/anubis/pkg-plist b/mail/anubis/pkg-plist
index 90aa6fbd1953..f6487e0d8ef4 100644
--- a/mail/anubis/pkg-plist
+++ b/mail/anubis/pkg-plist
@@ -2,6 +2,7 @@
%%GSASL%%bin/anubisusr
bin/msg2smtp.pl
sbin/anubis
+man/man1/anubis.1.gz
%%GSASL%%sbin/anubisadm
%%GUILE%%share/anubis/entire-msg.scm
%%GUILE%%share/anubis/remailer.scm