aboutsummaryrefslogtreecommitdiffstats
path: root/mail/archiveopteryx/Makefile
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2019-07-13 08:07:35 +0800
committerlinimon <linimon@FreeBSD.org>2019-07-13 08:07:35 +0800
commit0cb3a7544642e7f4e4f214184cf394b4aecfe7bd (patch)
treeabd62ebf5876447e6703d59978de852efd7daca3 /mail/archiveopteryx/Makefile
parent115e0d546ae741e28b493f352478b97a2062afd7 (diff)
downloadfreebsd-ports-gnome-0cb3a7544642e7f4e4f214184cf394b4aecfe7bd.tar.gz
freebsd-ports-gnome-0cb3a7544642e7f4e4f214184cf394b4aecfe7bd.tar.zst
freebsd-ports-gnome-0cb3a7544642e7f4e4f214184cf394b4aecfe7bd.zip
Prepare for powerpc-on-clang by deleting hard-coded tests for architecture
as a stand-in for "are we running on gcc". Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'mail/archiveopteryx/Makefile')
-rw-r--r--mail/archiveopteryx/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/mail/archiveopteryx/Makefile b/mail/archiveopteryx/Makefile
index 99874103da22..a8fd53d92285 100644
--- a/mail/archiveopteryx/Makefile
+++ b/mail/archiveopteryx/Makefile
@@ -14,7 +14,7 @@ LICENSE= MIT
BUILD_DEPENDS= jam:devel/jam
-USES= perl5 ssl tar:bzip2
+USES= compiler perl5 ssl tar:bzip2
USE_PERL5= build
WITH_PGSQL= client
@@ -38,7 +38,7 @@ OPTIONS_DEFINE= DOCS
# force Clang when on FreeBSD with clang in base
.if ${OPSYS} == FreeBSD
-.if ! ${ARCH:Mmips*} && ! ${ARCH:Mpowerpc*} && ! ${ARCH} == sparc64
+.if ${CHOSEN_COMPILER_TYPE} == clang
JAMARG+= "-sCLANG=1"
.endif
.endif