aboutsummaryrefslogtreecommitdiffstats
path: root/mail/archiveopteryx
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2017-01-10 23:12:44 +0800
committerfeld <feld@FreeBSD.org>2017-01-10 23:12:44 +0800
commit5e07ff179fed24c19c23d92bc33e3abe6cb14862 (patch)
tree9a67b0a6da156ba0a3c8922063cc80f8e1e4f704 /mail/archiveopteryx
parentab5c77636186555f96d0289254b5cffd3b088921 (diff)
downloadfreebsd-ports-gnome-5e07ff179fed24c19c23d92bc33e3abe6cb14862.tar.gz
freebsd-ports-gnome-5e07ff179fed24c19c23d92bc33e3abe6cb14862.tar.zst
freebsd-ports-gnome-5e07ff179fed24c19c23d92bc33e3abe6cb14862.zip
mail/archiveopteryx{-devel}: Fix build on HEAD
Diffstat (limited to 'mail/archiveopteryx')
-rw-r--r--mail/archiveopteryx/Makefile2
-rw-r--r--mail/archiveopteryx/files/patch-server_tlsthread.cpp11
2 files changed, 12 insertions, 1 deletions
diff --git a/mail/archiveopteryx/Makefile b/mail/archiveopteryx/Makefile
index fd9a8f660147..21915218554b 100644
--- a/mail/archiveopteryx/Makefile
+++ b/mail/archiveopteryx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= archiveopteryx
PORTVERSION= 3.2.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= mail
MASTER_SITES= http://archiveopteryx.org/download/
diff --git a/mail/archiveopteryx/files/patch-server_tlsthread.cpp b/mail/archiveopteryx/files/patch-server_tlsthread.cpp
new file mode 100644
index 000000000000..d43d193746fd
--- /dev/null
+++ b/mail/archiveopteryx/files/patch-server_tlsthread.cpp
@@ -0,0 +1,11 @@
+--- server/tlsthread.cpp.orig 2017-01-10 15:10:07 UTC
++++ server/tlsthread.cpp
+@@ -93,7 +93,7 @@ void TlsThread::setup()
+ SSL_library_init();
+
+ ctx = ::SSL_CTX_new( SSLv23_server_method() );
+- int options = SSL_OP_ALL
++ long options = SSL_OP_ALL
+ // also try to pick the same ciphers suites more often
+ | SSL_OP_CIPHER_SERVER_PREFERENCE
+ // and don't use SSLv2, even if the client wants to