aboutsummaryrefslogtreecommitdiffstats
path: root/mail/atmail
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-03-08 00:53:45 +0800
committermiwi <miwi@FreeBSD.org>2013-03-08 00:53:45 +0800
commit01586cc2cd8a893e9fb607884b766059ae2a287d (patch)
treee492c56fa7379da1ca224d6c3b1e9a31bdf1f7d9 /mail/atmail
parenta526e1d7b60fba52822780fd8712e159d1c7b55c (diff)
downloadfreebsd-ports-gnome-01586cc2cd8a893e9fb607884b766059ae2a287d.tar.gz
freebsd-ports-gnome-01586cc2cd8a893e9fb607884b766059ae2a287d.tar.zst
freebsd-ports-gnome-01586cc2cd8a893e9fb607884b766059ae2a287d.zip
- Convert to OptionsNG
- Trim header Reviewed by: bapt
Diffstat (limited to 'mail/atmail')
-rw-r--r--mail/atmail/Makefile22
1 files changed, 9 insertions, 13 deletions
diff --git a/mail/atmail/Makefile b/mail/atmail/Makefile
index 66fcd01639e8..0fd8a454069b 100644
--- a/mail/atmail/Makefile
+++ b/mail/atmail/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: atmail
-# Date created: 18 June 2008
-# Whom: Wen heping <wenheping@gmail.com>
-#
+# Created by: Wen heping <wenheping@gmail.com>
# $FreeBSD$
-#
PORTNAME= atmail
PORTVERSION= 1.0.4
@@ -20,20 +16,20 @@ WRKSRC= ${WRKDIR}/${DISTNAME}
NO_BUILD= yes
SUB_FILES= pkg-message
-OPTIONS= LDAP "Add support for a LDAP" Off \
- MBSTRING "Add support for UTF8 folder names" Off \
- ICONV "Add support encoding conversion" Off
+OPTIONS_DEFINE= LDAP MBSTRING
+MBSTRING_DESC= Support for UTF8 folder names
-.include <bsd.port.pre.mk>
-.if defined(WITH_LDAP)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MLDAP}
USE_PHP+= ldap
.endif
-.if defined(WITH_MBSTRING)
+.if ${PORT_OPTIONS:MMBSTRING}
USE_PHP+= mbstring
.endif
-.if defined(WITH_ICONV)
+.if ${PORT_OPTIONS:MICONV}
USE_PHP+= iconv
.endif
@@ -49,4 +45,4 @@ post-install:
>> ${TMPPLIST}
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>