aboutsummaryrefslogtreecommitdiffstats
path: root/mail/automx
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2013-01-13 00:27:50 +0800
committercrees <crees@FreeBSD.org>2013-01-13 00:27:50 +0800
commita74bd5264685d015c8059c9d205de17d2add5655 (patch)
tree34fd56277c222571ea7714bda34ddf95d27e8887 /mail/automx
parent84209f6d40cf0af82b976a40f3ea0c0d886e7697 (diff)
downloadfreebsd-ports-gnome-a74bd5264685d015c8059c9d205de17d2add5655.tar.gz
freebsd-ports-gnome-a74bd5264685d015c8059c9d205de17d2add5655.tar.zst
freebsd-ports-gnome-a74bd5264685d015c8059c9d205de17d2add5655.zip
automx makes setting up a mail account easy. All your users need to provide
is real name, mail address and password. Their mail client and automx will safely handle the rest. automx runs on your server and handles mail account profile requests from your mail clients. Put an end to endless phone calls trying to coach users to configure settings, whose dialogs they can't find. Stop wasting your time writing Tutorials nobody reads. automx unifies Microsofts and Mozillas mail account provisioning standards in one powerful Open Source tool. Choose from many backends, including LDAP and SQL, and let automx create standard and individualized profiles for multiple domains on the fly! WWW: http://www.automx.org/en/
Diffstat (limited to 'mail/automx')
-rw-r--r--mail/automx/Makefile62
-rw-r--r--mail/automx/distinfo2
-rw-r--r--mail/automx/pkg-descr15
-rw-r--r--mail/automx/pkg-plist9
4 files changed, 88 insertions, 0 deletions
diff --git a/mail/automx/Makefile b/mail/automx/Makefile
new file mode 100644
index 000000000000..3549baf830d5
--- /dev/null
+++ b/mail/automx/Makefile
@@ -0,0 +1,62 @@
+# $FreeBSD$
+
+PORTNAME= automx
+PORTVERSION= 0.9
+CATEGORIES= mail
+MASTER_SITES= http://www.automx.org/download/
+
+MAINTAINER= crees@FreeBSD.org
+COMMENT= Handles mail account profile requests from mail clients
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= ${LOCALBASE}/${APACHEMODDIR}/mod_wsgi.so:${PORTSDIR}/www/mod_wsgi \
+ ${PYTHON_PKGNAMEPREFIX}lxml>=0:${PORTSDIR}/devel/py-lxml \
+ bash:${PORTSDIR}/shells/bash \
+ wget:${PORTSDIR}/ftp/wget
+
+USE_APACHE_RUN= 22+
+USE_PYTHON= 2.6+
+NO_BUILD= yes
+PORTDATA= *
+PORTDOCS= *
+
+MAN1= ${PORTNAME}-test.1
+MAN5= ${PORTNAME}.conf.5 ${PORTNAME}_ldap.5 ${PORTNAME}_sql.5
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ ${REINPLACE_CMD} -e '1s,/bin/bash,${LOCALBASE}/bin/bash,' \
+ ${WRKSRC}/src/automx-test
+# Generate pkg-message from INSTALL file; include lines from Section 5 onwards
+ line=$$(${SED} -ne '/^5. Web Server/=' ${WRKSRC}/INSTALL) && \
+ ${SED} -ne "$$line,\$$p" ${WRKSRC}/INSTALL > ${PKGMESSAGE}
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ (cd ${WRKSRC}/src && ${COPYTREE_SHARE} ${PORTNAME} ${PYTHON_SITELIBDIR})
+ ${INSTALL_DATA} ${WRKSRC}/src/automx_wsgi.py ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/src/automx-test ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/src/automx.conf \
+ ${PREFIX}/etc/automx.conf.sample
+.for m in ${MAN1}
+ ${INSTALL_MAN} ${WRKSRC}/doc/man/man1/$m ${MAN5PREFIX}/man/man1
+.endfor
+.for m in ${MAN5}
+ ${INSTALL_MAN} ${WRKSRC}/doc/man/man5/$m ${MAN5PREFIX}/man/man5
+.endfor
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ (cd ${WRKSRC}/doc && ${COPYTREE_SHARE} "[^m]*" ${DOCSDIR})
+.endif
+
+post-install:
+ [ -f ${PREFIX}/etc/${PORTNAME}.conf ] || \
+ ${CP} -p ${PREFIX}/etc/${PORTNAME}.conf.sample \
+ ${PREFIX}/etc/${PORTNAME}.conf
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/mail/automx/distinfo b/mail/automx/distinfo
new file mode 100644
index 000000000000..8c81eeffa815
--- /dev/null
+++ b/mail/automx/distinfo
@@ -0,0 +1,2 @@
+SHA256 (automx-0.9.tar.gz) = 66dcd2f643c46f7046094beb3385e1129d70f28f438d83166e0b346f4c724e8c
+SIZE (automx-0.9.tar.gz) = 81770
diff --git a/mail/automx/pkg-descr b/mail/automx/pkg-descr
new file mode 100644
index 000000000000..e5cfad0510b8
--- /dev/null
+++ b/mail/automx/pkg-descr
@@ -0,0 +1,15 @@
+automx makes setting up a mail account easy. All your users need to provide
+is real name, mail address and password. Their mail client and automx will
+safely handle the rest.
+
+automx runs on your server and handles mail account profile requests from
+your mail clients. Put an end to endless phone calls trying to coach users to
+configure settings, whose dialogs they can't find. Stop wasting your time
+writing Tutorials nobody reads.
+
+automx unifies Microsofts and Mozillas mail account provisioning standards in
+one powerful Open Source tool. Choose from many backends, including LDAP and
+SQL, and let automx create standard and individualized profiles for multiple
+domains on the fly!
+
+WWW: http://www.automx.org/en/
diff --git a/mail/automx/pkg-plist b/mail/automx/pkg-plist
new file mode 100644
index 000000000000..d61e645b1a26
--- /dev/null
+++ b/mail/automx/pkg-plist
@@ -0,0 +1,9 @@
+bin/automx-test
+@unexec cmp -s %D/etc/automx.conf %D/etc/automx.conf.sample && rm -f %D/etc/automx.conf || true
+etc/automx.conf.sample
+@exec [ -f %B/automx.conf ] || cp -p %D/%F %B/automx.conf
+%%PYTHON_SITELIBDIR%%/automx/__init__.py
+%%PYTHON_SITELIBDIR%%/automx/config.py
+%%PYTHON_SITELIBDIR%%/automx/ordereddict.py
+%%PYTHON_SITELIBDIR%%/automx/view.py
+@dirrm %%PYTHON_SITELIBDIR%%/automx