aboutsummaryrefslogtreecommitdiffstats
path: root/mail/avenger/Makefile
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-05-10 07:19:58 +0800
committerjylefort <jylefort@FreeBSD.org>2005-05-10 07:19:58 +0800
commit7289e06ac15e198b5774fe53883461f3b238c366 (patch)
tree0af28e7c763e699461c7ffb26d2b6e0bbf2b532d /mail/avenger/Makefile
parent1f478761278cef298be0b1813993bca61316b1e2 (diff)
downloadfreebsd-ports-gnome-7289e06ac15e198b5774fe53883461f3b238c366.tar.gz
freebsd-ports-gnome-7289e06ac15e198b5774fe53883461f3b238c366.tar.zst
freebsd-ports-gnome-7289e06ac15e198b5774fe53883461f3b238c366.zip
Mail Avenger is a highly-configurable, MTA-independent SMTP server
daemon. It lets users run messages through filters like ClamAV and SpamAssassin during SMTP transactions, so the server can reject mail before assuming responsibility for its delivery. Other unique features include TCP SYN fingerprint and network route recording, verification of sender addresses through SMTP callbacks, SPF (sender policy framework) as a general policy language, qmail-style control over both SMTP-level behavior and local delivery of extension addresses, mail-bomb protection, integration with kernel firewalls, and more. WWW: http://www.mailavenger.org/ PR: ports/80800 Submitted by: David Mazieres <dm+bugs+avenger@mailavenger.org>
Diffstat (limited to 'mail/avenger/Makefile')
-rw-r--r--mail/avenger/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/mail/avenger/Makefile b/mail/avenger/Makefile
new file mode 100644
index 000000000000..a9b6e7d2ee0a
--- /dev/null
+++ b/mail/avenger/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: avenger
+# Date created: 8 May 2005
+# Whom: dm
+#
+# $FreeBSD$
+#
+
+PORTNAME= avenger
+PORTVERSION= 0.6.2
+CATEGORIES= mail
+MASTER_SITES= http://www.mailavenger.org/dist/
+
+MAINTAINER= dm+bug+avenger@mailavenger.org
+COMMENT= An anti-spam SMTP server
+
+LIB_DEPENDS= db-4.3:${PORTSDIR}/databases/db43
+
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+
+MAN1= aliascheck.1 avenger.1 dbutil.1 deliver.1 dotlock.1 \
+ edinplace.1 macutil.1 mailexec.1 match.1 smtpdcheck.1 synos.1
+MAN5= asmtpd.conf.5
+MAN8= asmtpd.8 avenger.local.8
+
+CONFIGURE_ARGS= --with-db=${LOCALBASE}
+
+post-patch:
+ @${FIND} ${WRKSRC} -type f -exec ${REINPLACE_CMD} -e \
+ 's|\(/etc/avenger\)|${PREFIX}\1|g' {} \;
+
+pre-install:
+ PKG_PREFIX=${PREFIX} ${SH} pkg-install ${PKGNAME} PRE-INSTALL
+
+post-install:
+ PKG_PREFIX=${PREFIX} ${SH} pkg-install ${PKGNAME} POST-INSTALL
+
+.include <bsd.port.mk>