aboutsummaryrefslogtreecommitdiffstats
path: root/mail/balsa2/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-12-20 20:25:42 +0800
committersobomax <sobomax@FreeBSD.org>2001-12-20 20:25:42 +0800
commita4d34d15a18c77ce64caaa6fdeb7206060ba04c4 (patch)
treedfc79a7750b6c74798ae61d3343787f94910e60c /mail/balsa2/Makefile
parent873d8345e60609c7433d244747d4fc1115681a06 (diff)
downloadfreebsd-ports-gnome-a4d34d15a18c77ce64caaa6fdeb7206060ba04c4.tar.gz
freebsd-ports-gnome-a4d34d15a18c77ce64caaa6fdeb7206060ba04c4.tar.zst
freebsd-ports-gnome-a4d34d15a18c77ce64caaa6fdeb7206060ba04c4.zip
Update to 1.3.0.
PR: 32927 Submitted by: John Merryweather Cooper <john_m_cooper@yahoo.com>
Diffstat (limited to 'mail/balsa2/Makefile')
-rw-r--r--mail/balsa2/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/mail/balsa2/Makefile b/mail/balsa2/Makefile
index 25502e03f8f5..a6cf9293fe21 100644
--- a/mail/balsa2/Makefile
+++ b/mail/balsa2/Makefile
@@ -6,18 +6,19 @@
#
PORTNAME= balsa
-PORTVERSION= 1.2.3
+PORTVERSION= 1.3.0
CATEGORIES= mail gnome
MASTER_SITES= http://www.theochem.kth.se/~pawsa/balsa/ \
ftp://ftp.newton.cx/pub/balsa/
MAINTAINER= gnome@FreeBSD.org
-LIB_DEPENDS= esmtp.5:${PORTSDIR}/mail/libesmtp \
- ldap.2:${PORTSDIR}/net/openldap2 \
+LIB_DEPENDS= ldap.2:${PORTSDIR}/net/openldap2 \
aspell.11:${PORTSDIR}/textproc/aspell \
pcre.0:${PORTSDIR}/devel/pcre
-RUN_DEPENDS= ${LOCALBASE}/bin/ispell:${PORTSDIR}/textproc/ispell
+BUILD_DEPENDS= ${LOCALBASE}/bin/libesmtp-config:${PORTSDIR}/mail/libesmtp
+RUN_DEPENDS= ${LOCALBASE}/bin/ispell:${PORTSDIR}/textproc/ispell \
+ ${LOCALBASE}/bin/libesmtp-config:${PORTSDIR}/mail/libesmtp
USE_X_PREFIX= yes
USE_GNOME= yes
@@ -29,12 +30,12 @@ CONFIGURE_ARGS= --enable-threads \
--enable-ldap \
--disable-more-warnings \
--with-ssl
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib -lgiconv"
MAN1= balsa.1
-pre-patch:
+post-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
s|-liconv|-lgiconv|g ; s|iconv_open|libiconv_open|g ; \