aboutsummaryrefslogtreecommitdiffstats
path: root/mail/balsa
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-11-28 07:14:10 +0800
committerpav <pav@FreeBSD.org>2004-11-28 07:14:10 +0800
commitf8f4f230181632749558d822ea4b6983a77e771d (patch)
treebeb218597f086e25ac41a441218a818584bbd618 /mail/balsa
parent35be0e83910d51092d74466e57f97dcfbe216fc7 (diff)
downloadfreebsd-ports-gnome-f8f4f230181632749558d822ea4b6983a77e771d.tar.gz
freebsd-ports-gnome-f8f4f230181632749558d822ea4b6983a77e771d.tar.zst
freebsd-ports-gnome-f8f4f230181632749558d822ea4b6983a77e771d.zip
- Fix build on 4.x
Reported by: pointyhat via kris
Diffstat (limited to 'mail/balsa')
-rw-r--r--mail/balsa/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/mail/balsa/Makefile b/mail/balsa/Makefile
index a0e2090f6267..575814bb1540 100644
--- a/mail/balsa/Makefile
+++ b/mail/balsa/Makefile
@@ -27,6 +27,7 @@ USE_PERL5= yes
USE_OPENSSL= yes
USE_GNOME= gnomeprefix intlhack gnomehack libgnomeui libgnomeprintui \
gtkhtml3
+USE_REINPLACE= yes
USE_LIBTOOL_VER=15
USE_LIBLTDL= yes
USE_ICONV= yes
@@ -54,4 +55,7 @@ USE_OPENLDAP= yes
CONFIGURE_ARGS+= --with-ldap
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|stdint.h|malloc.h|g' ${WRKSRC}/libbalsa/mailbox_imap.c
+
.include <bsd.port.post.mk>