aboutsummaryrefslogtreecommitdiffstats
path: root/mail/bayespam/Makefile
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2002-09-09 11:02:16 +0800
committerlioux <lioux@FreeBSD.org>2002-09-09 11:02:16 +0800
commit88142e806748431ac7f72e102314e4dc3600fa5e (patch)
treea32283176593004bf854899e6f330e44a4a90c29 /mail/bayespam/Makefile
parentfa1112d88cb48a459273deff203918e2e121244e (diff)
downloadfreebsd-ports-gnome-88142e806748431ac7f72e102314e4dc3600fa5e.tar.gz
freebsd-ports-gnome-88142e806748431ac7f72e102314e4dc3600fa5e.tar.zst
freebsd-ports-gnome-88142e806748431ac7f72e102314e4dc3600fa5e.zip
bayespam version 0.9.2: qmail spam filter written in Perl using
Bayesian classification
Diffstat (limited to 'mail/bayespam/Makefile')
-rw-r--r--mail/bayespam/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/mail/bayespam/Makefile b/mail/bayespam/Makefile
new file mode 100644
index 000000000000..d870c2b8dd39
--- /dev/null
+++ b/mail/bayespam/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: bayespam
+# Date created: Sun Sep 8 16:15:26 UTC 2002
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bayespam
+PORTVERSION= 0.9.2
+CATEGORIES= mail
+MASTER_SITES= http://www.garyarnold.com/projects/
+
+MAINTAINER= lioux@FreeBSD.org
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/MIME/Parser.pm:${PORTSDIR}/mail/p5-MIME-Tools
+
+USE_PERL5= yes
+USE_REINPLACE= yes
+NO_BUILD= yes
+
+FILES_DOCS= AUTHORS COPYING Changelog INSTALL README TODO \
+ qmail.sample
+FILES_SCRIPTS= bayes_process_email.pl bayes_spam_check.pl bayestest.pl
+
+post-patch:
+# fix location of Bayesian filter
+ @${REINPLACE_CMD} -e 's|/user/|${PREFIX}/|' ${WRKSRC}/README
+ @${REINPLACE_CMD} -e 's|/usr/bin/|${PREFIX}/bin/|' \
+ ${WRKSRC}/qmail.sample
+ @${REINPLACE_CMD} -E -e \
+ 's|/usr/bin/(bayes_spam_check.pl)|${PREFIX}/bin/\1|' \
+ ${WRKSRC}/bayestest.pl
+# fix location of PERL
+ @${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|' ${WRKSRC}/*.pl
+
+do-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${FILES_DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+ @${MKDIR} ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/Bayespam
+ @${INSTALL_DATA} ${WRKSRC}/Bayespam/Process.pm \
+ ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/Bayespam
+.for file in ${FILES_SCRIPTS}
+ @${INSTALL_SCRIPT} ${WRKSRC}/${file} ${PREFIX}/bin
+.endfor
+
+.include <bsd.port.mk>