aboutsummaryrefslogtreecommitdiffstats
path: root/mail/bincimap/files
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2003-06-12 16:05:25 +0800
committerleeym <leeym@FreeBSD.org>2003-06-12 16:05:25 +0800
commit6d069a5251f85effc720be1c68c16c29c006225f (patch)
tree282db986c3fad4da8126739a9e9bed09f9dbb16d /mail/bincimap/files
parent149aa4975a4de62de98c55a79422325e5354681f (diff)
downloadfreebsd-ports-gnome-6d069a5251f85effc720be1c68c16c29c006225f.tar.gz
freebsd-ports-gnome-6d069a5251f85effc720be1c68c16c29c006225f.tar.zst
freebsd-ports-gnome-6d069a5251f85effc720be1c68c16c29c006225f.zip
- Update to 1.1.8
- Update MASTER_SITES to include official mirrors - Introduce two compile-time knobs: - WITH_XINETD Use xinetd instead of the default daemontools/ucspi-tcp - WITHOUT_OPENSSL Disable OpenSSL support (enabled by default) - Install all sample configs into ${PREFIX}/etc/bincimap instead of ${EXAMPLESDIR} PR: 52904 Submitted by: Sergei Kolobov <sergei@kolobov.com>
Diffstat (limited to 'mail/bincimap/files')
-rw-r--r--mail/bincimap/files/patch-Makefile.in11
-rw-r--r--mail/bincimap/files/patch-src::util::convert.h39
2 files changed, 11 insertions, 39 deletions
diff --git a/mail/bincimap/files/patch-Makefile.in b/mail/bincimap/files/patch-Makefile.in
new file mode 100644
index 000000000000..e3e0c5500f51
--- /dev/null
+++ b/mail/bincimap/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Tue May 20 21:45:16 2003
++++ Makefile.in Wed May 21 03:03:40 2003
+@@ -96,7 +96,7 @@
+ install_sh = @install_sh@
+
+ #--------------------------------------------------------------------------
+-SUBDIRS = conf contrib doc man service src
++SUBDIRS = man src
+
+ #--------------------------------------------------------------------------
+ EXTRA_DIST = bincimap.spec config.h COPYING.OpenSSL config.h.in
diff --git a/mail/bincimap/files/patch-src::util::convert.h b/mail/bincimap/files/patch-src::util::convert.h
deleted file mode 100644
index 4168ff7e6701..000000000000
--- a/mail/bincimap/files/patch-src::util::convert.h
+++ /dev/null
@@ -1,39 +0,0 @@
-replace switch statement in inline function with if/then/else; fixes compiler
-failure on alpha: ``relocation truncated to fit: GPREL32 *UND*''
-
-diff -u -r1.4 convert.h
---- src/util/convert.h 8 Apr 2003 16:46:28 -0000 1.4
-+++ src/util/convert.h 9 Apr 2003 08:02:54 -0000
-@@ -269,6 +269,7 @@
- {
- std::string regex = "^";
- for (std::string::const_iterator i = s_in.begin(); i != s_in.end(); ++i) {
-+ /*
- switch (*i) {
- case '.':
- case '[': case ']':
-@@ -291,6 +292,24 @@
- default:
- regex += *i;
- break;
-+ }
-+ */
-+ if (*i == '.' || *i == '[' || *i == ']' || *i == '{' || *i == '}' ||
-+ *i == '(' || *i == ')' || *i == '^' || *i == '$' || *i == '?' ||
-+ *i == '+' || *i == '\\') {
-+ regex += "\\";
-+ regex += *i;
-+ }
-+ else if (*i == '*') {
-+ regex += ".*?";
-+ }
-+ else if (*i == '%') {
-+ regex += "[^\\";
-+ regex += delimiter;
-+ regex += "]*?";
-+ }
-+ else {
-+ regex += *i;
- }
- }
-