aboutsummaryrefslogtreecommitdiffstats
path: root/mail/bmf
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
commite61d6a701f43e8cec5a4ec8c9641daf5376441de (patch)
tree920c5861867d049fb1f1e03285110561450a4ac1 /mail/bmf
parent124c6dcab8f89a37ab971e5ad23a959bfaa97426 (diff)
downloadfreebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.gz
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.zst
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Diffstat (limited to 'mail/bmf')
-rw-r--r--mail/bmf/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/mail/bmf/Makefile b/mail/bmf/Makefile
index dd59e981babe..8b75092ec1b5 100644
--- a/mail/bmf/Makefile
+++ b/mail/bmf/Makefile
@@ -16,15 +16,15 @@ COMMENT= A fast Bayesian Mail Filter compatible with maildrop and procmail
.if defined(WITH_BDB41)
LIB_DEPENDS= db41.1:${PORTSDIR}/databases/db41
-CONFIGURE_ENV+= LDFLAGS=-L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV+= DB_LIBNAME=-ldb41
.elif defined(WITH_BDB4)
LIB_DEPENDS= db4.0:${PORTSDIR}/databases/db4
-CONFIGURE_ENV+= LDFLAGS=-L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV+= DB_LIBNAME=-ldb4
.elif defined(WITH_BDB3)
LIB_DEPENDS= db3.3:${PORTSDIR}/databases/db3
-CONFIGURE_ENV+= LDFLAGS=-L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV+= DB_LIBNAME=-ldb3
.endif