aboutsummaryrefslogtreecommitdiffstats
path: root/mail/bsmtp
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-02-09 02:58:53 +0800
committerijliao <ijliao@FreeBSD.org>2001-02-09 02:58:53 +0800
commite9870e060ff6f7b5a78a11879f3d7393a0d74255 (patch)
tree042f17fa63bb6d813288baa877b83cb11f732dc3 /mail/bsmtp
parentd29a77ae262a5483b41b393027395213023b8a66 (diff)
downloadfreebsd-ports-gnome-e9870e060ff6f7b5a78a11879f3d7393a0d74255.tar.gz
freebsd-ports-gnome-e9870e060ff6f7b5a78a11879f3d7393a0d74255.tar.zst
freebsd-ports-gnome-e9870e060ff6f7b5a78a11879f3d7393a0d74255.zip
update to 1.0.2
PR: 24936 Submitted by: MAINTAINER
Diffstat (limited to 'mail/bsmtp')
-rw-r--r--mail/bsmtp/Makefile11
-rw-r--r--mail/bsmtp/distinfo2
-rw-r--r--mail/bsmtp/files/config.sed3
-rw-r--r--mail/bsmtp/files/patch-Makefile_in28
-rw-r--r--mail/bsmtp/files/patch-bsmtp_c_in24
-rw-r--r--mail/bsmtp/pkg-plist1
6 files changed, 21 insertions, 48 deletions
diff --git a/mail/bsmtp/Makefile b/mail/bsmtp/Makefile
index c2cf44843568..5cca5ff4fd04 100644
--- a/mail/bsmtp/Makefile
+++ b/mail/bsmtp/Makefile
@@ -5,20 +5,21 @@
# $FreeBSD$
PORTNAME= bsmtp
-PORTVERSION= 1.01
+PORTVERSION= 1.02
CATEGORIES= mail
MASTER_SITES= http://www.stud.uni-karlsruhe.de/~uk1o/bsmtp/
MAINTAINER= naddy@mips.inka.de
+WRKSRC= ${WRKDIR}/${PORTNAME}
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --redo
pre-configure:
- @${SED} -e 's,%%CC%%,${CC},' \
- -e 's,%%CFLAGS%%,${CFLAGS},' \
- -e 's,%%PREFIX%%,${PREFIX},' \
- ${FILESDIR}/config.sed >${WRKSRC}/config.sed
+ @${SED} <${FILESDIR}/config.sed >${WRKSRC}/config.sed \
+ -e 's:%%CC%%:${CC}:' \
+ -e 's:%%CFLAGS%%:${CFLAGS}:' \
+ -e 's:%%PREFIX%%:${PREFIX}:'
post-install:
${MKDIR} ${PREFIX}/share/doc/bsmtp
diff --git a/mail/bsmtp/distinfo b/mail/bsmtp/distinfo
index 07ecf6ba3c6d..2d51b187203b 100644
--- a/mail/bsmtp/distinfo
+++ b/mail/bsmtp/distinfo
@@ -1 +1 @@
-MD5 (bsmtp-1.01.tar.gz) = 85aee02dfcb1c65646ebdb2fce7d8dbe
+MD5 (bsmtp-1.02.tar.gz) = 3084ca188e42414c42efe8d714166adb
diff --git a/mail/bsmtp/files/config.sed b/mail/bsmtp/files/config.sed
index d7044b29ed5f..88447bcc976c 100644
--- a/mail/bsmtp/files/config.sed
+++ b/mail/bsmtp/files/config.sed
@@ -1,3 +1,4 @@
+# $FreeBSD$
s,@CC@,%%CC%%,
s,@INSTALL@,/usr/bin/install,
s,@SH@,/bin/sh,
@@ -10,6 +11,8 @@ s,@CFLAGS@,%%CFLAGS%%,
s,@PRIVBINDIR@,%%PREFIX%%/libexec,
s,@PUBBINDIR@,%%PREFIX%%/bin,
s,@MAILERDIR@,%%PREFIX%%/share/sendmail,
+s,@BINUSR@,root,
+s,@BINGRP@,wheel,
s,@QUEUEDIR@,/var/spool/bsmtp,
s,@DAEMONUSER@,uucp,
s,@DAEMONGID@,66,
diff --git a/mail/bsmtp/files/patch-Makefile_in b/mail/bsmtp/files/patch-Makefile_in
deleted file mode 100644
index 2104c2c08735..000000000000
--- a/mail/bsmtp/files/patch-Makefile_in
+++ /dev/null
@@ -1,28 +0,0 @@
---- Makefile.in.orig Sun May 16 11:24:08 1999
-+++ Makefile.in Thu Oct 5 23:44:15 2000
-@@ -30,8 +30,8 @@
- #oldsendmail=@OLDSENDMAIL@ # not used anymore
- installmailer=@INSTALLMAILER@
- mailerversion=@MAILERVERSION@
--bingrp = bin
--binusr = bin
-+bingrp = wheel
-+binusr = root
- privbin = @PRIVBINDIR@
- pubbin = @PUBBINDIR@
- mailerdir = @MAILERDIR@
-@@ -88,6 +88,14 @@
- chown $(binusr) $(privbin) ; \
- chgrp $(bingrp) $(privbin) ; \
- chmod 755 $(privbin) ; \
-+ fi
-+ @if [ ! -d $(mailerdir) ]; then \
-+ echo Making $(mailerdir) ; \
-+ set -x ; \
-+ mkdir -p $(mailerdir) || mkdir $(mailerdir) || exit 0 ; \
-+ chown $(binusr) $(mailerdir) ; \
-+ chgrp $(bingrp) $(mailerdir) ; \
-+ chmod 755 $(mailerdir) ; \
- fi
- @if [ ! -d $(queuedir) ]; then \
- echo Making $(queuedir) ; \
diff --git a/mail/bsmtp/files/patch-bsmtp_c_in b/mail/bsmtp/files/patch-bsmtp_c_in
index d75120edb4b9..afbbd0214c10 100644
--- a/mail/bsmtp/files/patch-bsmtp_c_in
+++ b/mail/bsmtp/files/patch-bsmtp_c_in
@@ -1,14 +1,10 @@
---- bsmtp.c.in.orig Sun May 16 11:24:08 1999
-+++ bsmtp.c.in Thu Oct 5 21:41:25 2000
-@@ -167,7 +167,10 @@
- }
- #endif
- fseek (file, 0, SEEK_END);
-- fprintf (file, "MAIL FROM:<%s>\n", from);
-+ if (*from == '<')
-+ fprintf (file, "MAIL FROM:%s\n", from);
-+ else
-+ fprintf (file, "MAIL FROM:<%s>\n", from);
- while (argc) {
- fprintf (file, "RCPT TO:<%s>\n", argv[0]);
- argv++; argc--;
+--- bsmtp.c.in.orig Wed Feb 7 20:36:42 2001
++++ bsmtp.c.in Wed Feb 7 20:36:58 2001
+@@ -36,6 +36,7 @@
+ #include <grp.h>
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <unistd.h>
+
+ /* From .../sendmail/src/sysexits.h */
diff --git a/mail/bsmtp/pkg-plist b/mail/bsmtp/pkg-plist
index 2465b5c5596c..ec181b48113d 100644
--- a/mail/bsmtp/pkg-plist
+++ b/mail/bsmtp/pkg-plist
@@ -1,3 +1,4 @@
+@comment $FreeBSD$
bin/_bqueue
bin/bqueue
bin/bsmtp