aboutsummaryrefslogtreecommitdiffstats
path: root/mail/cclient
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2013-05-23 10:19:02 +0800
committerjgh <jgh@FreeBSD.org>2013-05-23 10:19:02 +0800
commit197e34167f91933cdb8448cc7a7d995b760151d1 (patch)
tree7387196f77943048eba0c2b0e857984f08f2b4fc /mail/cclient
parentda7602aef88e09c1333866d16a090d8fd9349d93 (diff)
downloadfreebsd-ports-gnome-197e34167f91933cdb8448cc7a7d995b760151d1.tar.gz
freebsd-ports-gnome-197e34167f91933cdb8448cc7a7d995b760151d1.tar.zst
freebsd-ports-gnome-197e34167f91933cdb8448cc7a7d995b760151d1.zip
- adoption of optionsNG
Approved by: portmgr (miwi)
Diffstat (limited to 'mail/cclient')
-rw-r--r--mail/cclient/Makefile30
1 files changed, 13 insertions, 17 deletions
diff --git a/mail/cclient/Makefile b/mail/cclient/Makefile
index c8e7030f69a9..c87df467cc22 100644
--- a/mail/cclient/Makefile
+++ b/mail/cclient/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: cclient
-# Date created: 2 July 2000
-# Whom: Kelly Yancey <kbyanc@FreeBSD.org>
-#
+# Created by: Kelly Yancey <kbyanc@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= cclient
PORTVERSION= 2007f
@@ -22,16 +18,16 @@ COMMENT= Mark Crispin's C-client mail access routines
LICENSE= AL2
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-OPTIONS= SSL "Compile with SSL support" on \
- SSL_AND_PLAINTEXT "Allow plain text passwords and SSL" off \
- IPV6 "Support IPv6" on \
- MBX_DEFAULT "Use MBX as default mailbox format" off
+OPTIONS_DEFINE= SSL SSL_AND_PLAINTEXT IPV6 MBX_DEFAULT
+OPTIONS_DEFAULT= SSL
+SSL_AND_PLAINTEXT_DESC= Allow plain text passwords and SSL
+MBX_DEFAULT_DESC= Use MBX as default mailbox format
MAKE_JOBS_UNSAFE= yes
.include <bsd.port.options.mk>
-.if ! defined(WITHOUT_SSL)
+.if ${PORT_OPTIONS:MSSL}
USE_OPENSSL= yes
.endif
@@ -39,10 +35,10 @@ USE_OPENSSL= yes
USE_LDCONFIG= yes
ALL_TARGET= bsf
-.if defined(WITHOUT_SSL)
+.if ! ${PORT_OPTIONS:MSSL}
MAKE_ARGS+= SSLTYPE=none SSLDIR=${OPENSSLBASE}
.else
-.if defined(WITH_SSL_AND_PLAINTEXT)
+.if ${PORT_OPTIONS:MSSL_AND_PLAINTEXT}
MAKE_ARGS+= SSLTYPE=unix SSLDIR=${OPENSSLDIR}
.else
MAKE_ARGS+= SSLTYPE=unix.nopwd SSLDIR=${OPENSSLDIR}
@@ -65,16 +61,16 @@ post-patch:
s:/etc/ssl/private:${PREFIX}/certs:g" ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e "s:/etc/c-client.cf:${PREFIX}/etc/c-client.cf:" \
${WRKSRC}/src/osdep/unix/env_unix.h
-.if ! defined(WITHOUT_SSL)
+.if ${PORT_OPTIONS:MSSL}
@${REINPLACE_CMD} -e " \
s:SSLINCLUDE=/usr/include/openssl SSLLIB=/usr/lib:SSLINCLUDE=${OPENSSLINC} SSLLIB=${OPENSSLLIB}: \
" ${WRKSRC}/Makefile
.endif
-.if !defined(WITHOUT_IPV6)
+.if ${PORT_OPTIONS:MIPV6}
@${REINPLACE_CMD} -e "s|^IP=4|IP=6|" ${WRKSRC}/Makefile \
${WRKSRC}/src/osdep/unix/Makefile
.endif
-.if defined(WITH_MBX_DEFAULT)
+.if ${PORT_OPTIONS:MMBX_DEFAULT}
@${REINPLACE_CMD} -e "s|^CREATEPROTO=unixproto|CREATEPROTO=mbxproto|" \
${WRKSRC}/src/osdep/unix/Makefile
.endif
@@ -91,7 +87,7 @@ PORTREV_H= ${WRKDIR}/portrevision.h
post-build:
@${ECHO_CMD} "#define CCLIENT_PORTVERSION \"${PORTVERSION}\"" >${PORTREV_H}
-.if !defined(WITHOUT_SSL)
+.if ${PORT_OPTIONS:MSSL}
@${ECHO_CMD} "#define CCLIENT_SSLENABLED \"yes\"" >>${PORTREV_H}
.else
@${ECHO_CMD} "#define CCLIENT_SSLENABLED \"no\"" >>${PORTREV_H}
@@ -113,7 +109,7 @@ do-install:
post-install:
${INSTALL_DATA} ${PORTREV_H} ${PREFIX}/include/c-client
-.if !defined(WITHOUT_SSL)
+.if ${PORT_OPTIONS:MSSL}
@${ECHO} "================================================================================"
@${ECHO} "Warning: You have chosen to include SSL support. Applications/ports that use"
@${ECHO} "the cclient library but do not support SSL may stop working or have problems"
d>2-0/+22 * Unbreak build on -CURRENT (missing include).fjoe2015-03-221-0/+10 * Fix build with clang 3.6.fjoe2015-03-223-5/+49 * Update USE_GITHUB so it does not require GH_COMMIT.bdrewery2015-03-201-1/+1 * misc/findutils: add CPE informationrobak2015-03-181-1/+3 * - Don't install patch files with headersamdmi32015-03-171-2/+3 * Clean up the rest of the perl@ Makefiles a bit.adamw2015-03-142-13/+10 * Update KDE SC to 4.14.3alonso2015-03-1259-93/+110 * Unbreak by using mono to set TZ in envantoine2015-03-121-1/+1 * - Add empty directories to plistamdmi32015-03-111-0/+5 * - Update to upstream version 0.7.8riggs2015-03-094-20/+30 * - Simplify MASTER_SITESamdmi32015-03-071-3/+5 * - Update to 20150221sunpoet2015-03-072-3/+3 * - Update to 20150303sunpoet2015-03-072-3/+3 * Update to 2015a:edwin2015-03-072-3/+3 * The FreeBSD Xfce team proudly presents Xfce 4.12.olivierd2015-03-065-32/+28 * - Update to 2.4.3sunpoet2015-03-063-4/+4 * - Update to 0.13sunpoet2015-03-062-4/+3 * misc/saaghar: update 1.0.94 -> 2.5.0robak2015-03-053-134/+246 * Update PyQt and its dependencies.rakuco2015-03-051-6/+0 * update to 3.58oliver2015-03-032-3/+3 * Remove Author from pkg-descr and white space fixesbapt2015-03-0311-21/+9 * New port: misc/vdmfecpi2015-02-284-0/+50 * Fix DESKTOP_ENTRIES:makc2015-02-281-1/+1 * Introduce new USE_QT4 component linguisttools for lrelease/lupdate toolsmakc2015-02-251-1/+2 * misc/fortune-mod-epictetus: update 0.1 -> 0.2robak2015-02-232-6/+12 * - Update to 2.3.10. [1]rakuco2015-02-233-10/+8 * Allow the CC expansion to deal with a full path to a compiler. Thissbruno2015-02-221-1/+1 * - Remove deprecated USE_KDE4=kdehiermakc2015-02-201-1/+1 * - Update to 20150203sunpoet2015-02-192-3/+3 * - Update to 20150217sunpoet2015-02-192-3/+3 * Unbreak on headantoine2015-02-156-31/+54 * Update to 0.14.kwm2015-02-064-89/+342 * Cleanup plistbapt2015-02-051-18/+0 * Cleanup plistbapt2015-02-0518-483/+0 * Cleanup plistbapt2015-02-0513-24/+0 * Upgrade to 0.4.vanilla2015-02-032-4/+3 * Update poppler to 0.30.0 [1].kwm2015-02-031-1/+1 * - Update to 3.4.1.0lme2015-02-032-5/+5 * Update to r46230 of the FreeBSD docset.blackend2015-02-013-4/+4 * Update to 1.3.3.fjoe2015-01-283-5/+5 * Update to 1.4.15.fjoe2015-01-282-4/+3 * Unbreak on -CURRENT (ignore unused command line arguments for clang).fjoe2015-01-282-0/+36 * - Update to 20150124sunpoet2015-01-272-3/+3 * Fix RUN_DEPENDSantoine2015-01-251-3/+2 * Upgrade to 1.3.4.vanilla2015-01-242-3/+3 * misc/otter & biology/ariadne: Not jobs safemarino2015-01-221-0/+2 * - Use INSTALL_TARGET=install-strip instead of STRIP_CMDsunpoet2015-01-201-3/+1 * Update mbuffer to 2014-12-27mm2015-01-202-3/+3 * - Update to 20150117sunpoet2015-01-182-3/+3 * - Remove vestiges of alpha supportak2015-01-161-1/+1 * Update graphics/giflib to 5.0.5antoine2015-01-151-1/+1 * - Update to 1.7.4tabthorpe2015-01-133-6/+4 * - Add in GNOME_USES=gconf2tabthorpe2015-01-131-1/+1 * - Switch to webkit-gtk3tabthorpe2015-01-132-3/+7 * Fix packagingantoine2015-01-111-6/+0 * - upgrade to 20140910.002leeym2015-01-113-4/+11 * - Update to 2.10.1tabthorpe2015-01-103-15/+3 * - Switch to using gtkhtml4tabthorpe2015-01-101-2/+2 * - Update to 1.7.3tabthorpe2015-01-103-51/+53 * - Update to 20150107sunpoet2015-01-102-3/+3 * - Update to 20150105sunpoet2015-01-102-3/+3 * Update iso-codes to 3.57.kwm2015-01-092-3/+3 * Move MASTER_SITES from CRITICAL to LOCAL/ehauptehaupt2015-01-067-7/+7 * - Add DEBUG optiondanilo2015-01-061-0/+3 * - Update to 0.04sunpoet2015-01-062-4/+4 * Remove nagios-base-logos, all these files are now in nagios distribution.demon2015-01-055-157/+0 * Assign maintainership of FPC ports to new FPC ports teammarino2015-01-051-1/+1 * - Update to 2.003sunpoet2015-01-053-8/+7 * - Update to version 0.93.0 [1]pawel2015-01-042-5/+4 * - Gnome is default icons theme [1], not switched to Adwaita because Thunar andolivierd2015-01-041-0/+7 * security/libgcrypt: 1.6.1 -> 1.6.2, bump dependspi2015-01-031-1/+1 * - Update BUILD_DEPENDS: ExtUtils::MakeMaker 6.42+ is already in all supported...sunpoet2015-01-021-1/+3 * - Add p5-Software-License-CCpack 1.11sunpoet2015-01-025-0/+82 * - Update to 20150101sunpoet2015-01-022-3/+3 * Update cinnamon to 2.4, this should fix [1] and [2].kwm2014-12-316-12/+205 * - Distfile was rerolled, the only difference is in the gzip compression,antoine2014-12-282-14/+1 * Upgrade to version 1.98.olgeni2014-12-274-18/+4 * - Add missing run dependency on perlantoine2014-12-262-12/+80 * Bump portrevision after png updatebapt2014-12-262-2/+2 * Change libpng15.so to libpng.so in LIB_DEPENDS to prepare the upgradeantoine2014-12-262-2/+2 * Remove non default option on imlibbapt2014-12-251-3/+1 * Fix stagingbapt2014-12-252-6/+6 * Remove now useless gnomehier, pkg handles automatically the directories wherebapt2014-12-255-189/+0 * - Update to 20141222sunpoet2014-12-242-3/+3 * Change my non-FreeBSD MAINTAINER mail to bofh@bofh2014-12-249-9/+9 * Update to 0.8.5olivierd2014-12-243-3/+4 * Get rid of gnomehierbapt2014-12-212-2/+4 * Cleanup plistbapt2014-12-2115-17/+0 * - Cleanup PLISTsunpoet2014-12-211-1/+0 * - Cleanup PLISTsunpoet2014-12-211-1/+0 * - Cleanup PLISTsunpoet2014-12-211-4/+0 * - Update to 0.005sunpoet2014-12-212-4/+3 * Fix packaging as userbapt2014-12-171-1/+1 * Fix packaging as a userbapt2014-12-171-0/+1 * - Update comms/spandsp to version 0.0.6 [1]pawel2014-12-161-2/+2 * USES+= gettext-tools on 5 portsmarino2014-12-131-1/+1 * misc/mc: really re-add small patch that was deleted in r369133pi2014-12-092-10/+10 * Update "BSD" license in misc categoryfeld2014-12-094-4/+6 * Cleanup plistbapt2014-12-0995-1037/+3 * misc/mc: re-add small patch that was deleted in r369133pi2014-12-092-1/+10 * Replace USES=libtool:oldver with USES=libtool or USES=libtool:keepla intijl2014-12-094-4/+4 * - Update to 2.09jadawin2014-12-092-4/+3 * - Cleanup PLISTsunpoet2014-12-081-1/+0 * Update to r46070 of the FreeBSD docset.blackend2014-12-0811-19/+7 * Add LICENSEfeld2014-12-071-0/+2 * - Update to 20141123sunpoet2014-12-062-3/+3 * - Add PORTSCOUTsunpoet2014-12-041-0/+2 * - Update to 1.1.6sunpoet2014-12-043-3/+4 * - Fix typoamdmi32014-12-041-1/+1 * Update GNOME to 3.14.2.kwm2014-12-036-6/+134 * Bump PORTREVISION as the previous commit affected package creationehaupt2014-11-301-0/+1 * - Convert to USES=tar:tgzehaupt2014-11-301-1/+5 * Split devel/gettext in devel/gettext-runtime and devel/gettext-tools. Thetijl2014-11-305-7/+7 * - Add required run-depend. Without it, only empty window is renderedamdmi32014-11-281-0/+3 * Change the way Perl modules are installed, update the default Perl to 5.18.mat2014-11-26126-321/+71 * Bump PORTREVISION after graphics/poppler update to 0.26.3makc2014-11-252-1/+2 * - Update to 2014.10sunpoet2014-11-252-3/+3 * - Update to 1.2.2sunpoet2014-11-252-3/+3 * - Update to 0.14sunpoet2014-11-253-8/+3 * - Add PORTSCOUTsunpoet2014-11-252-6/+2 * - Update LICENSEsunpoet2014-11-251-1/+2 * - Update to 20141115sunpoet2014-11-252-3/+3 * - Update to 1.62danilo2014-11-232-4/+4 * Switch to USES=pgsqlcrees2014-11-231-2/+2 * - Update to 0.92.3danilo2014-11-232-4/+4 * - Fix MASTER_SITESsunpoet2014-11-221-1/+1 * - Reset maintainer to ports@nemysis2014-11-221-1/+1 * misc/amanda-client: Fix build with perl 5.20marino2014-11-201-0/+5 * Allow package building to allow users to get rapide update of the timezones bybapt2014-11-191-6/+0 * The FreeBSD GNOME team proudly presents GNOME 3.14 and Cinnamon 2.2.kwm2014-11-1925-4506/+18127 * Reset miwi's maintainership per his demandbapt2014-11-184-4/+4 * - Fix shebangsamdmi32014-11-171-1/+6 * Release 2014j - 2014-11-10 17:37:11 -0800edwin2014-11-162-3/+3 * Eliminate pkg-install and pkg-deinstall scripts, symlinks can be packaged fineantoine2014-11-154-1336/+561 * - fix build on FreeBSD-10dinoex2014-11-145-17/+61 * Cleanup plistantoine2014-11-111-5/+0 * Fix runtime errorantoine2014-11-101-0/+2 * misc/pastebinit: Upgrade version 1.3.1 => 1.4.1marino2014-11-092-7/+5 * misc/amanda-(server,client): Upgrade version 3.3.2 => 3.3.6marino2014-11-095-55/+25 * - Update to 0.92.2ak2014-11-062-4/+4 * - Chase GNU Emacs updatesashish2014-11-051-1/+1 * - Update to 0.8.4olivierd2014-11-048-200/+12 * misc/freeguide: update 0.11 -> 0.11.1robak2014-10-313-23/+22 * Drop maintainership of all remaining ports where I am listed.anders2014-10-301-1/+1 * - Fix spelling of LICENSEamdmi32014-10-282-2/+2 * - Update to 0.92.1ak2014-10-252-4/+4 * Remove @dirrm and @dirrmtry entries from the Qt ports.rakuco2014-10-243-818/+0 * Allow staging as a regular userantoine2014-10-242-32/+7 * Add Pacific/Bougainville to pkg-plist, add comment on how to check it.edwin2014-10-232-15/+18 * Update to 2014i:edwin2014-10-232-3/+3 * - Convert ports of misc/ to new USES=pythonmva2014-10-21