aboutsummaryrefslogtreecommitdiffstats
path: root/mail/claws-mail
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2005-06-05 00:11:16 +0800
committernetchild <netchild@FreeBSD.org>2005-06-05 00:11:16 +0800
commitf6769c00c5f586ed9b7b222c182d07f58b0d3ada (patch)
tree52ead2e445f9b7040698b28be961a52244fa900f /mail/claws-mail
parent7a328bc2d5bec314d17595f68b4d71d8c2ca9f6c (diff)
downloadfreebsd-ports-gnome-f6769c00c5f586ed9b7b222c182d07f58b0d3ada.tar.gz
freebsd-ports-gnome-f6769c00c5f586ed9b7b222c182d07f58b0d3ada.tar.zst
freebsd-ports-gnome-f6769c00c5f586ed9b7b222c182d07f58b0d3ada.zip
Add patch from the sylpheed-claws CVS which is supposed to fix the build
issues on 4.x. Additionally add a bugfix (from CVS too). Submitted by: Chris Johnson <cjohnson@lextranet.com>
Diffstat (limited to 'mail/claws-mail')
-rw-r--r--mail/claws-mail/Makefile2
-rw-r--r--mail/claws-mail/files/patch-src-procmsg.c57
-rw-r--r--mail/claws-mail/files/patch-src-send_message.c20
3 files changed, 78 insertions, 1 deletions
diff --git a/mail/claws-mail/Makefile b/mail/claws-mail/Makefile
index 5bacabfaed38..b83586ad1057 100644
--- a/mail/claws-mail/Makefile
+++ b/mail/claws-mail/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sylpheed-claws
PORTVERSION= 1.9.11
-#PORTREVISION= 1
+PORTREVISION= 1
CATEGORIES= mail news ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sylpheed-claws
diff --git a/mail/claws-mail/files/patch-src-procmsg.c b/mail/claws-mail/files/patch-src-procmsg.c
new file mode 100644
index 000000000000..6a05e44f63bb
--- /dev/null
+++ b/mail/claws-mail/files/patch-src-procmsg.c
@@ -0,0 +1,57 @@
+Index: src/procmsg.c
+===================================================================
+RCS file: /cvsroot/sylpheed-claws/sylpheed-claws/src/procmsg.c,v
+retrieving revision 1.150.2.23
+retrieving revision 1.150.2.24
+diff -u -r1.150.2.23 -r1.150.2.24
+--- src/procmsg.c 30 Apr 2005 16:47:39 -0000 1.150.2.23
++++ src/procmsg.c 19 May 2005 19:53:29 -0000 1.150.2.24
+@@ -662,13 +662,6 @@
+ FILE *fp;
+ int hnum;
+ gchar buf[BUFFSIZE];
+-
+- g_return_val_if_fail(file != NULL, NULL);
+-
+- if ((fp = fopen(file, "rb")) == NULL) {
+- FILE_OP_ERROR(file, "fopen");
+- return NULL;
+- }
+ static HeaderEntry qentry[] = {{"S:", NULL, FALSE},
+ {"SSV:", NULL, FALSE},
+ {"R:", NULL, FALSE},
+@@ -682,6 +675,13 @@
+ {"X-Sylpheed-Encrypt:", NULL, FALSE},
+ {"X-Sylpheed-Encrypt-Data:", NULL, FALSE},
+ {NULL, NULL, FALSE}};
++
++ g_return_val_if_fail(file != NULL, NULL);
++
++ if ((fp = fopen(file, "rb")) == NULL) {
++ FILE_OP_ERROR(file, "fopen");
++ return NULL;
++ }
+
+ while ((hnum = procheader_get_one_field(buf, sizeof(buf), fp, qentry))
+ != -1) {
+
+
+Index: src/procmsg.c
+===================================================================
+RCS file: /cvsroot/sylpheed-claws/sylpheed-claws/src/procmsg.c,v
+retrieving revision 1.150.2.24
+retrieving revision 1.150.2.25
+diff -u -r1.150.2.24 -r1.150.2.25
+--- src/procmsg.c 19 May 2005 19:53:29 -0000 1.150.2.24
++++ src/procmsg.c 20 May 2005 16:24:11 -0000 1.150.2.25
+@@ -722,9 +722,9 @@
+ cur = orig;
+ while (cur) {
+ gchar *file;
++ PrefsAccount *ac = procmsg_get_account_from_file(file);
+ msg = (MsgInfo *)cur->data;
+ file = folder_item_fetch_msg(queue, msg->msgnum);
+- PrefsAccount *ac = procmsg_get_account_from_file(file);
+ g_free(file);
+
+ if (last_account == NULL || (ac != NULL && ac == last_account)) {
diff --git a/mail/claws-mail/files/patch-src-send_message.c b/mail/claws-mail/files/patch-src-send_message.c
new file mode 100644
index 000000000000..53bf482e4197
--- /dev/null
+++ b/mail/claws-mail/files/patch-src-send_message.c
@@ -0,0 +1,20 @@
+Index: src/send_message.c
+===================================================================
+RCS file: /cvsroot/sylpheed-claws/sylpheed-claws/src/send_message.c,v
+retrieving revision 1.17.2.9
+retrieving revision 1.17.2.10
+diff -u -r1.17.2.9 -r1.17.2.10
+--- src/send_message.c 30 Apr 2005 16:47:40 -0000 1.17.2.9
++++ src/send_message.c 20 May 2005 16:24:12 -0000 1.17.2.10
+@@ -333,7 +333,8 @@
+ * easier.
+ */
+ if (!keep_session || ret != 0) {
+- smtp_quit(session);
++ if (session_is_connected(session))
++ smtp_quit(session);
+ while (session_is_connected(session))
+ gtk_main_iteration();
+ session_destroy(session);
+
+