aboutsummaryrefslogtreecommitdiffstats
path: root/mail/cmail/Makefile
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2001-03-27 21:06:15 +0800
committerkevlo <kevlo@FreeBSD.org>2001-03-27 21:06:15 +0800
commitfd4bd64947a5feb0a21a228a9c12cb075f98259f (patch)
treee747718fe5b4cc7853aa4173ca6f93be10469ab5 /mail/cmail/Makefile
parent5fe6f15ad2cb969c4a44e77b27cdda2da2209eec (diff)
downloadfreebsd-ports-gnome-fd4bd64947a5feb0a21a228a9c12cb075f98259f.tar.gz
freebsd-ports-gnome-fd4bd64947a5feb0a21a228a9c12cb075f98259f.tar.zst
freebsd-ports-gnome-fd4bd64947a5feb0a21a228a9c12cb075f98259f.zip
Upgrade to version 3.1
A few notes I changed in Makefile: - Remove USE_PERL5 - Add MAN1 PR: 26133 Submitted by: MAINTAINER
Diffstat (limited to 'mail/cmail/Makefile')
-rw-r--r--mail/cmail/Makefile22
1 files changed, 10 insertions, 12 deletions
diff --git a/mail/cmail/Makefile b/mail/cmail/Makefile
index 466a59fc44a7..491694965cac 100644
--- a/mail/cmail/Makefile
+++ b/mail/cmail/Makefile
@@ -1,27 +1,25 @@
# New ports collection makefile for: cmail
# Date created: 31 Dec 1998
-# Whom: Chip Marshall <chip@eboai.org>
+# Whom: Chip Marshall <chip@chocobo.cx>
#
# $FreeBSD$
#
PORTNAME= cmail
-PORTVERSION= 2.10
+PORTVERSION= 3.1
CATEGORIES= mail
MASTER_SITES= ftp://ftp.eboai.org/pub/users/chip/
-EXTRACT_SUFX= .tgz
+EXTRACT_SUFX= .tar.bz2
-MAINTAINER= chip@eboai.org
+MAINTAINER= chip@chocobo.cx
-NO_BUILD= yes
+USE_BZIP2= yes
-USE_PERL5= yes
+PERL_CONFIGURE= yes
-pre-configure:
- @${SED} -e '1,1s:/usr/local/bin/perl:${PERL5}:' \
- ${WRKSRC}/cmail.pl > ${WRKSRC}/cmail
-do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/cmail ${PREFIX}/bin/cmail
- ${INSTALL_MAN} ${WRKSRC}/cmail.rc ${PREFIX}/share/examples/cmail.rc
+MAN1= cmail.1
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/cmailrc.sample ${PREFIX}/share/examples/cmailrc.sample
.include <bsd.port.mk>