aboutsummaryrefslogtreecommitdiffstats
path: root/mail/courier-imap/Makefile
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2005-01-08 18:25:05 +0800
committeroliver <oliver@FreeBSD.org>2005-01-08 18:25:05 +0800
commit7d8aa874997ea562bda35e5fa87c579846d5f214 (patch)
treeb30ac5610ec4f256655d05af79abd9c96ce3a6b9 /mail/courier-imap/Makefile
parenta442977f4e66fe6157500149dff5e2aff5c9d46e (diff)
downloadfreebsd-ports-gnome-7d8aa874997ea562bda35e5fa87c579846d5f214.tar.gz
freebsd-ports-gnome-7d8aa874997ea562bda35e5fa87c579846d5f214.tar.zst
freebsd-ports-gnome-7d8aa874997ea562bda35e5fa87c579846d5f214.zip
upadate to courier-authlib 0.52, courier-imap 4.0.1 and sqwebmail 5.0.0
Special thanks for testing and sugestions to: Brian Candler <B.Candler@pobox.com>
Diffstat (limited to 'mail/courier-imap/Makefile')
-rw-r--r--mail/courier-imap/Makefile150
1 files changed, 27 insertions, 123 deletions
diff --git a/mail/courier-imap/Makefile b/mail/courier-imap/Makefile
index a83ebf01dadc..7404fe9f5f7f 100644
--- a/mail/courier-imap/Makefile
+++ b/mail/courier-imap/Makefile
@@ -6,14 +6,18 @@
#
PORTNAME= courier-imap
-PORTVERSION= 3.0.8
+PORTVERSION= 4.0.1
PORTREVISION= 0
PORTEPOCH= 1
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= courier
+BUILD_DEPENDS= ${LOCALBASE}/bin/courierauthconfig:${PORTSDIR}/mail/courier-authlib
+RUN_DEPENDS= ${LOCALBASE}/bin/courierauthconfig:${PORTSDIR}/mail/courier-authlib
+
.if defined(WITH_DRAC)
+BROKEN= DRAC support doesn't work with 4.0.0 right now
PATCH_SITES= http://www.smalltown.ne.jp/~usata/pub/patch/
PATCHFILES= courier-imap-3.0.6-drac.patch
PATCH_DIST_STRIP= -p1
@@ -38,13 +42,6 @@ CONFIGURE_ENV= CFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
# options available:
#
# WITHOUT_OPENSSL: Don't build in TLS support
-# WITHOUT_PAM: Don't build in PAM support
-# WITHOUT_AUTHDAEMON Don't build the authdaemon
-# WITH_CRAM: Build in CRAM-MD5 authentication support
-# WITH_VPOPMAIL: Build in vpopmail support
-# WITH_MYSQL: Build in mysql support
-# WITH_POSTGRESQL: Build in postgresql support
-# WITH_LDAP: Build in ldap support with openldap
# WITH_FAM: Build in fam support for IDLE command
# WITH_DRAC: Build in DRAC support
# WITH_TRASHQUOTA: Include deleted mails in the quota
@@ -56,23 +53,13 @@ RCDIR?= ${PREFIX}/etc/rc.d
USERDB?= ${PREFIX}/etc/userdb
LIBEXECDIR?= ${PREFIX}/libexec/${PORTNAME}
-VPOPMAILDIR?= ${LOCALBASE}/vpopmail
-
PLIST_SUB= CONFDIR=${CONFDIR:S,^${PREFIX}/,,} \
RCDIR=${RCDIR:S,^${PREFIX}/,,} \
USERDB=${USERDB:S,^${PREFIX}/,,} \
LIBEXECDIR=${LIBEXECDIR:S,^${PREFIX}/,,}
-.if !defined(WITHOUT_OPENSSL)
-USE_OPENSSL= YES
-PLIST_SUB+= OPENSSLFLAG=
-.else
-PLIST_SUB+= OPENSSLFLAG="@comment "
-.endif
-
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --without-authshadow \
- --sysconfdir=${CONFDIR} \
+CONFIGURE_ARGS= --sysconfdir=${CONFDIR} \
--with-userdb=${USERDB} \
--datadir=${DATADIR} \
--libexecdir=${LIBEXECDIR} \
@@ -92,72 +79,17 @@ CONFIGURE_ARGS+= --with-db=gdbm
CONFIGURE_ARGS+= --with-db=db
.endif
-.if !defined(WITH_VPOPMAIL)
-CONFIGURE_ARGS+=--without-authvchkpw
-PLIST_SUB+= VPOPMAILFLAG="@comment "
+.if !defined(WITHOUT_OPENSSL)
+USE_OPENSSL= YES
+PLIST_SUB+= OPENSSLFLAG=
.else
-CONFIGURE_ARGS+=--with-authvchkpw
-BUILD_DEPENDS+= ${VPOPMAILDIR}/lib/libvpopmail.a:${PORTSDIR}/mail/vpopmail
-PLIST_SUB+= VPOPMAILFLAG=""
+PLIST_SUB+= OPENSSLFLAG="@comment "
.endif
.if defined(WITH_TRASHQUOTA)
CONFIGURE_ARGS+=--with-trashquota
.endif
-.if defined(WITH_LDAP)
-USE_OPENLDAP= yes
-CONFIGURE_ARGS+=--with-authldap
-PLIST_SUB+= LDAPFLAG=""
-.else
-CONFIGURE_ARGS+=--without-authldap
-PLIST_SUB+= LDAPFLAG="@comment "
-.endif
-
-.if !defined(WITH_MYSQL)
-CONFIGURE_ARGS+=--without-authmysql
-PLIST_SUB+= MYSQLFLAG="@comment "
-.else
-USE_MYSQL= YES
-PLIST_SUB+= MYSQLFLAG=""
-CONFIGURE_ARGS+=--with-authmysql \
- --with-mysql-libs=${LOCALBASE}/lib/mysql \
- --with-mysql-includes=${LOCALBASE}/include/mysql
-.endif
-
-.if !defined(WITH_POSTGRESQL)
-CONFIGURE_ARGS+=--without-authpgsql
-PLIST_SUB+= PGSQLFLAG="@comment "
-.else
-POSTGRESQL_PORT?= databases/postgresql7
-LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
-PLIST_SUB+= PGSQLFLAG=""
-.endif
-
-.if !defined(WITHOUT_AUTHDAEMON)
-CONFIGURE_ARGS+=--with-authdaemon
-PLIST_SUB+= AUTHDFLAG=""
-.else
-CONFIGURE_ARGS+=--without-authdaemon
-PLIST_SUB+= AUTHDFLAG="@comment "
-.endif
-
-.if !defined(WITHOUT_PAM)
-CONFIGURE_ARGS+=--with-authpam
-PLIST_SUB+= PAMFLAG="" PWDFLAG="@comment "
-.else
-CONFIGURE_ARGS+=--without-authpam
-PLIST_SUB+= PAMFLAG="@comment " PWDFLAG=""
-.endif
-
-.if !defined(WITH_CRAM)
-CONFIGURE_ARGS+=--without-authcram
-.else
-CONFIGURE_ARGS+=--with-authcram
-.endif
-
-.include <bsd.port.pre.mk>
-
RC_SCRIPTS_SUB=PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
.if defined(WITH_FAM) || exists(${LOCALBASE}/lib/libfam.so)
@@ -172,39 +104,27 @@ EXTRA_PATCHES= ${FILESDIR}/extra-patch-drac
BUILD_DEPENDS+= ${LOCALBASE}/lib/libdrac.a:${PORTSDIR}/mail/drac
.endif
-MAN1= courierlogger.1 couriertcpd.1 maildiracl.1 maildirkw.1 \
+MAN1= couriertcpd.1 maildiracl.1 maildirkw.1 \
maildirmake.1
-MAN7= authlib.7
-MAN8= makeuserdb.8 userdb.8 userdbpw.8 \
- deliverquota.8 imapd.8 mkimapdcert.8 mkpop3dcert.8
-
-MLINKS= authlib.7 authpwd.7 \
- authlib.7 authuserdb.7 \
- authlib.7 authshadow.7 \
- authlib.7 authpam.7 \
- authlib.7 authvchkpw.7 \
- authlib.7 authcram.7 \
- authlib.7 authldap.7 \
- authlib.7 authmysql.7 \
- authlib.7 authdaemon.7 \
- authlib.7 authdaemond.7 \
- makeuserdb.8 pw2userdb.8 \
- makeuserdb.8 vchkpw2userdb.8
-
-EXTRA_DOCS= README INSTALL AUTHORS imap/ChangeLog
+
+MAN8= deliverquota.8 imapd.8 mkimapdcert.8 mkpop3dcert.8
+
+EXTRA_DOCS= AUTHORS INSTALL NEWS imap/ChangeLog imap/README \
+ imap/README.proxy maildir/README.imapkeywords.html \
+ maildir/README.maildirfilter.html \
+ maildir/README.maildirquota.txt \
+ maildir/README.sharedfolders.txt tcpd/README.couriertls \
+
post-patch:
@${REINPLACE_CMD} -e 's|^case x$$lockmethod in|${TEST} \&\& &|g' \
${WRKSRC}/liblock/configure
- @${REINPLACE_CMD} -e 's|$$VPOPMAILLIBS|& -lcrypt|g ; \
- s|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/authlib/configure
- @${REINPLACE_CMD} -e 's|^@INSTALLAUTHMODULES@$$|& @AUTHMODULES@|' \
- ${WRKSRC}/authlib/installlist.in
@${REINPLACE_CMD} -e 's|%%INSTALL_MAN%%|${INSTALL_MAN}|' \
- ${WRKSRC}/Makefile.in ${WRKSRC}/authlib/Makefile.in
+ ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|@LIBS@|@LIBS@ -rpath=:${LOCALBASE}/lib/courier-authlib|' \
+ ${WRKSRC}/imap/Makefile.in
post-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/authlib/authtest ${PREFIX}/bin/
.for i in imapd pop3d
${INSTALL_DATA} ${WRKSRC}/imap/${i}.cnf ${CONFDIR}/${i}.cnf.dist
.endfor
@@ -219,30 +139,14 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/${a} ${DOCSDIR}
.endfor
.endif
+
+ cd ${WRKSRC} && ( ${GMAKE} install-configure ; cd - )
+
@${ECHO_MSG} ""
@${ECHO_MSG} "You will have to run ${DATADIR}/mkimapdcert to create"
@${ECHO_MSG} "a self-signed certificate if you want to use imapd-ssl."
@${ECHO_MSG} "And you will have to copy and edit the *.dist files to *"
@${ECHO_MSG} "in ${CONFDIR}."
@${ECHO_MSG} ""
- @${ECHO_MSG} "In case you use authpam, you should put the following lines"
-.if ${OSVERSION} >= 500000
- @${ECHO_MSG} "in your /etc/pam.d/imap"
- @${ECHO_MSG} "auth required pam_unix.so try_first_pass"
- @${ECHO_MSG} "account required pam_unix.so try_first_pass"
- @${ECHO_MSG} "session required pam_permit.so"
-.else
- @${ECHO_MSG} "in your /etc/pam.conf"
- @${ECHO_MSG} "imap auth required pam_unix.so try_first_pass"
- @${ECHO_MSG} "imap account required pam_unix.so try_first_pass"
- @${ECHO_MSG} "imap session required pam_permit.so"
-.endif
- @${ECHO_MSG} ""
- @${ECHO_MSG} "In case you are upgrading an existing Installation, you need to run"
- @${ECHO_MSG} "'make install-configure' to update your old configuration files."
- @${ECHO_MSG} ""
-
-install-configure:
- cd ${WRKSRC} && ${GMAKE} install-configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>