aboutsummaryrefslogtreecommitdiffstats
path: root/mail/courier-imap
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2003-07-10 00:46:53 +0800
committeroliver <oliver@FreeBSD.org>2003-07-10 00:46:53 +0800
commit41c02abcb3ce53034629ac88ca2b490d383256b8 (patch)
tree2c53f8c2f8aad78a0bdf6d2d6a29cedbd5b81ccf /mail/courier-imap
parent5dadd94098f4e5fa9247914d34d56a73b77c8ce2 (diff)
downloadfreebsd-ports-gnome-41c02abcb3ce53034629ac88ca2b490d383256b8.tar.gz
freebsd-ports-gnome-41c02abcb3ce53034629ac88ca2b490d383256b8.tar.zst
freebsd-ports-gnome-41c02abcb3ce53034629ac88ca2b490d383256b8.zip
fix building on an nfs-share
force using fcntl locking method and disabling the locking test during configure
Diffstat (limited to 'mail/courier-imap')
-rw-r--r--mail/courier-imap/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/mail/courier-imap/Makefile b/mail/courier-imap/Makefile
index fcf9dd829438..be5c52453a40 100644
--- a/mail/courier-imap/Makefile
+++ b/mail/courier-imap/Makefile
@@ -64,7 +64,8 @@ CONFIGURE_ARGS= --without-authshadow \
--libexecdir=${LIBEXECDIR} \
--enable-workarounds-for-imap-client-bugs \
--enable-unicode \
- --disable-root-check
+ --disable-root-check \
+ --with-locking-method=fcntl
.if !defined(WITH_VPOPMAIL)
CONFIGURE_ARGS+= --without-authvchkpw
@@ -157,9 +158,12 @@ EXTRA_DOCS= README INSTALL AUTHORS imap/ChangeLog
.include <bsd.port.pre.mk>
post-patch:
- @${REINPLACE_CMD} -Ee \
- '/^ imapd.cnf pop3d.cnf/s/(imapd.cnf|pop3d.cnf)//g' \
+ @${REINPLACE_CMD} -e 's/^ imapd.cnf pop3d.cnf //' \
${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|^case x$$lockmethod in|${TEST} \&\& &|g' \
+ ${WRKSRC}/liblock/configure
+ @${REINPLACE_CMD} -e 's|$$VPOPMAILLIBS|& -lcrypt|g' \
+ ${WRKSRC}/authlib/configure
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/authlib/authtest ${PREFIX}/bin/