aboutsummaryrefslogtreecommitdiffstats
path: root/mail/crm114
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-02-24 22:17:04 +0800
committerkrion <krion@FreeBSD.org>2004-02-24 22:17:04 +0800
commit92aa6d41cf5cf17f52c2d56f7a67e2286ee8af86 (patch)
treeedfa663d73c9a6c44321b084733250269ad7b5f0 /mail/crm114
parent11fcb0e3a253aa85f57197485829889343d1e21f (diff)
downloadfreebsd-ports-gnome-92aa6d41cf5cf17f52c2d56f7a67e2286ee8af86.tar.gz
freebsd-ports-gnome-92aa6d41cf5cf17f52c2d56f7a67e2286ee8af86.tar.zst
freebsd-ports-gnome-92aa6d41cf5cf17f52c2d56f7a67e2286ee8af86.zip
Add crm114 20040212,
CRM114 is a system to examine incoming e-mail, system log streams, data files or other data streams, and to sort, filter, or alter the incoming files or data streams according to the user's wildest desires. Criteria for categorization of data can be by satisfaction of regexes, by sparse binary polynomial matching with a Bayesian Chain Rule evaluator, or by other means. Accuracy of the SBPH/BCR classifier has been seen in excess of 99 per cent, for 1/4 megabyte of learning text. In other words, CRM114 learns, and it learns fast. WWW: http://crm114.sourceforge.net PR: ports/63304 Submitted by: Meno Abels <meno.abels@adviser.com>
Diffstat (limited to 'mail/crm114')
-rw-r--r--mail/crm114/Makefile39
-rw-r--r--mail/crm114/distinfo2
-rw-r--r--mail/crm114/files/patch-Makefile53
-rw-r--r--mail/crm114/pkg-descr10
-rw-r--r--mail/crm114/pkg-plist11
5 files changed, 115 insertions, 0 deletions
diff --git a/mail/crm114/Makefile b/mail/crm114/Makefile
new file mode 100644
index 000000000000..c60e69706550
--- /dev/null
+++ b/mail/crm114/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: crm114
+# Date created: 23 February 2004
+# Whom: Meno Abels <meno.abels@adviser.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= crm114
+PORTVERSION= 20040212
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= crm114
+DISTNAME= ${PORTNAME}-${PORTVERSION}-BlameJetlag.src
+
+MAINTAINER= Meno.Abels@Adviser.com
+COMMENT= An Markov based SpamFilter
+
+LIB_DEPENDS= tre.4:${PORTSDIR}/textproc/libtre
+
+USE_GETTEXT= yes
+USE_ICONV= yes
+
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" prefix="${PREFIX}" \
+ LDFLAGS="${LDFLAGS}" LIBS="${LIBS}" \
+ INSTALL_PROGRAM="${INSTALL_PROGRAM}"
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib -liconv -lintl
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in CRM114_Mailfilter_HOWTO.txt FAQ.txt INTRO.txt QUICKREF.txt README
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/crm114/distinfo b/mail/crm114/distinfo
new file mode 100644
index 000000000000..c4760f0e7451
--- /dev/null
+++ b/mail/crm114/distinfo
@@ -0,0 +1,2 @@
+MD5 (crm114-20040212-BlameJetlag.src.tar.gz) = 1124fb9c18161bf4306a162e6b9fd974
+SIZE (crm114-20040212-BlameJetlag.src.tar.gz) = 760719
diff --git a/mail/crm114/files/patch-Makefile b/mail/crm114/files/patch-Makefile
new file mode 100644
index 000000000000..3fea26040ca9
--- /dev/null
+++ b/mail/crm114/files/patch-Makefile
@@ -0,0 +1,53 @@
+--- Makefile.orig Thu Feb 12 03:42:43 2004
++++ Makefile Tue Feb 24 14:58:58 2004
+@@ -4,7 +4,7 @@
+ # If you want to install the executables somewhere else, change
+ # BINDIR here. Default is /usr/bin
+ #
+-prefix=/usr
++#prefix=/usr/local
+ BINDIR=${prefix}/bin
+
+ # VER_SUFFIX defines a version suffix for our installed executables,
+@@ -65,15 +65,7 @@
+ $(CC) $(LDFLAGS) crm114.o crmregex_gnu.o crm_mathexec.o -lm -o crm114_gnu $(LIBS)
+
+ crm114_tre: crm114.o crmregex_tre.o crm_mathexec.o
+- #
+- # Note: if you haven't installed TRElib, the next step
+- # will get an error.
+- # For TRElib, look in the TRE sub-directory of this kit.
+- # You will also need to add /usr/local/lib to /etc/ld.so.conf,
+- # and then run ldconfig (as root) to set the library up and make
+- # the library known to the static and runtime linkers.
+- #
+- $(CC) $(LDFLAGS) crm114.o crmregex_tre.o crm_mathexec.o -static -lm -ltre -o crm114_tre $(LIBS)
++ $(CC) $(LDFLAGS) crm114.o crmregex_tre.o crm_mathexec.o -lm -ltre -o crm114_tre $(LIBS)
+
+ crm114.o: crm114.c crm114.h crm114_structs.h crm114_config.h crm114_sysincludes.h
+ $(CC) $(CFLAGS) -DVERSION='"$(VERSION)"' -c crm114.c -o crm114.o
+@@ -89,14 +81,14 @@
+
+ cssutil: cssutil.c crm114.h crm114_structs.h crm114_config.h crm114_sysincludes.h
+ $(CC) $(CFLAGS) -c cssutil.c -o cssutil.o
+- $(CC) $(CFLAGS) cssutil.o -static -lm -ltre -o cssutil
++ $(CC) $(LDFLAGS) $(CFLAGS) cssutil.o -lm -ltre -o cssutil $(LIBS)
+
+ cssdiff: cssdiff.c crm114.h crm114_structs.h crm114_config.h crm114_sysincludes.h
+ $(CC) $(CFLAGS) -c cssdiff.c -o cssdiff.o
+- $(CC) $(CFLAGS) -static -ltre cssdiff.o -o cssdiff
++ $(CC) $(LDFLAGS) $(CFLAGS) -ltre cssdiff.o -o cssdiff $(LIBS)
+
+ cssmerge: cssmerge.c crm114.h crm114_structs.h crm114_config.h crm114_sysincludes.h
+- $(CC) $(CFLAGS) -static -ltre cssmerge.c -o cssmerge
++ $(CC) $(LDFLAGS) $(CFLAGS) -ltre cssmerge.c -o cssmerge $(LIBS)
+
+ clean:
+ -rm -f crm114
+@@ -254,4 +246,4 @@
+ distribution: install src_gzip i386_gzip css_gzip
+ md5sum crm114-$(VERSION).*.tar.gz
+
+-FORCE:
+\ No newline at end of file
++FORCE:
diff --git a/mail/crm114/pkg-descr b/mail/crm114/pkg-descr
new file mode 100644
index 000000000000..bbf238d68b84
--- /dev/null
+++ b/mail/crm114/pkg-descr
@@ -0,0 +1,10 @@
+CRM114 is a system to examine incoming e-mail, system log streams,
+data files or other data streams, and to sort, filter, or alter the
+incoming files or data streams according to the user's wildest
+desires. Criteria for categorization of data can be by satisfaction
+of regexes, by sparse binary polynomial matching with a Bayesian
+Chain Rule evaluator, or by other means. Accuracy of the SBPH/BCR
+classifier has been seen in excess of 99 per cent, for 1/4 megabyte
+of learning text. In other words, CRM114 learns, and it learns fast.
+
+WWW: http://crm114.sourceforge.net
diff --git a/mail/crm114/pkg-plist b/mail/crm114/pkg-plist
new file mode 100644
index 000000000000..0b46939bd4d5
--- /dev/null
+++ b/mail/crm114/pkg-plist
@@ -0,0 +1,11 @@
+@comment $FreeBSD$
+bin/crm
+bin/cssdiff
+bin/cssmerge
+bin/cssutil
+%%PORTDOCS%%%%DOCSDIR%%/CRM114_Mailfilter_HOWTO.txt
+%%PORTDOCS%%%%DOCSDIR%%/FAQ.txt
+%%PORTDOCS%%%%DOCSDIR%%/INTRO.txt
+%%PORTDOCS%%%%DOCSDIR%%/QUICKREF.txt
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%