aboutsummaryrefslogtreecommitdiffstats
path: root/mail/cyrus-imapd24
diff options
context:
space:
mode:
authorume <ume@FreeBSD.org>2007-08-09 22:54:16 +0800
committerume <ume@FreeBSD.org>2007-08-09 22:54:16 +0800
commit6fcf0e00d68c1e338667a8cb18ef593fdfc89345 (patch)
tree609d81925dc8a3b8e299de8272bd5f2532d6919a /mail/cyrus-imapd24
parent6c50ef40fe72b66225e49296df6a77fe9f75b782 (diff)
downloadfreebsd-ports-gnome-6fcf0e00d68c1e338667a8cb18ef593fdfc89345.tar.gz
freebsd-ports-gnome-6fcf0e00d68c1e338667a8cb18ef593fdfc89345.tar.zst
freebsd-ports-gnome-6fcf0e00d68c1e338667a8cb18ef593fdfc89345.zip
Add an option to not use Berkeley DB.
PR: ports/101383 Submitted by: Sean Farley <sean-freebsd__at__farley.org>
Diffstat (limited to 'mail/cyrus-imapd24')
-rw-r--r--mail/cyrus-imapd24/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/mail/cyrus-imapd24/Makefile b/mail/cyrus-imapd24/Makefile
index e7b0aa20d77f..8d6758d305cd 100644
--- a/mail/cyrus-imapd24/Makefile
+++ b/mail/cyrus-imapd24/Makefile
@@ -27,22 +27,19 @@ LATEST_LINK= ${PORTNAME}23
USE_RC_SUBR= imapd.sh
USE_OPENSSL= yes
USE_PERL5= yes
-USE_BDB= yes
-INVALID_BDB_VER=2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--with-cyrus-prefix=${PREFIX}/cyrus \
--with-cyrus-user=${CYRUS_USER} \
--with-cyrus-group=${CYRUS_GROUP} \
--with-sasl=${LOCALBASE} \
- --with-bdb-incdir=${BDB_INCLUDE_DIR} \
- --with-bdb-libdir=${LOCALBASE}/lib \
--with-bdb=${BDB_LIB_NAME} \
--with-com_err \
--with-openssl=${OPENSSLBASE} \
--with-perl=${PERL5}
-OPTIONS= DRAC "Enable DRAC support" off \
+OPTIONS= BDB "Use Berkeley DB" on \
+ DRAC "Enable DRAC support" off \
IDLED "Enable IMAP idled support" off \
LDAP_PTLOADER "Enable LDAP ptloader" off \
LISTEXT "Enable IMAP List extensions" off \
@@ -55,6 +52,15 @@ OPTIONS= DRAC "Enable DRAC support" off \
.include <bsd.port.pre.mk>
+.if defined(WITHOUT_BDB)
+BDB_LIB_NAME= no
+.else
+USE_BDB= yes
+INVALID_BDB_VER=2
+CONFIGURE_ARGS+=--with-bdb-incdir=${BDB_INCLUDE_DIR} \
+ --with-bdb-libdir=${LOCALBASE}/lib
+.endif
+
.if defined(WITH_NNTP)
CONFIGURE_ARGS+=--enable-nntp
PLIST_SUB+= NNTP=""