aboutsummaryrefslogtreecommitdiffstats
path: root/mail/dbmail21/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-12-02 00:31:24 +0800
committerpav <pav@FreeBSD.org>2006-12-02 00:31:24 +0800
commitb8a4338654afc3ebe0ef37af156301961ad32c09 (patch)
tree392db80f5fc485468e3e9241798a8d65ebfec393 /mail/dbmail21/Makefile
parent5cc1262f99e5313fdbaa583f33229cf683e3a972 (diff)
downloadfreebsd-ports-gnome-b8a4338654afc3ebe0ef37af156301961ad32c09.tar.gz
freebsd-ports-gnome-b8a4338654afc3ebe0ef37af156301961ad32c09.tar.zst
freebsd-ports-gnome-b8a4338654afc3ebe0ef37af156301961ad32c09.zip
- Fix duplicate LATEST_LINK, as reported by kris
- Remove non-existent USE_PTHREAD, replace -pthread with PTHREAD_LIBS
Diffstat (limited to 'mail/dbmail21/Makefile')
-rw-r--r--mail/dbmail21/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/mail/dbmail21/Makefile b/mail/dbmail21/Makefile
index 7757983ee16e..31d1f49e380c 100644
--- a/mail/dbmail21/Makefile
+++ b/mail/dbmail21/Makefile
@@ -33,10 +33,9 @@ USE_RC_SUBR= dbmail-pop3d.sh dbmail-lmtpd.sh dbmail-imapd.sh
LIB_DEPENDS+= gmime-2.0.4:${PORTSDIR}/mail/gmime2
USE_GNOME= glib20
USE_OPENSSL= YES
-USE_PTHREADS= YES
CFLAGS+= -fPIC -I${LOCALBASE}/include -L${LOCALBASE}/lib
-LDFLAGS+= -pthread
+LDFLAGS+= ${PTHREAD_LIBS}
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}" LOCALBASE=${LOCALBASE}
PORTDOCS= AUTHORS BUGS COPYING INSTALL NEWS README \
@@ -52,6 +51,7 @@ MAN8= dbmail-export.8 dbmail-imapd.8 dbmail-lmtpd.8 \
MANCOMPRESSED= no
MSG_FILE= ${PKGDIR}/pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
+LATEST_LINK= dbmail21
PLIST_SUB+= PORTNAME=${PORTNAME}
.if defined(NOPORTDOCS)