aboutsummaryrefslogtreecommitdiffstats
path: root/mail/dovecot
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-05-30 05:57:54 +0800
committerpav <pav@FreeBSD.org>2004-05-30 05:57:54 +0800
commit19568e85cee7b537c3e1b073fbce5e3ea3e525d6 (patch)
treec378103782472acdfe653b52e798669d05d4fd07 /mail/dovecot
parenta8b4dbb7eabe626d38b4f28daa4c557c28ee5caf (diff)
downloadfreebsd-ports-gnome-19568e85cee7b537c3e1b073fbce5e3ea3e525d6.tar.gz
freebsd-ports-gnome-19568e85cee7b537c3e1b073fbce5e3ea3e525d6.tar.zst
freebsd-ports-gnome-19568e85cee7b537c3e1b073fbce5e3ea3e525d6.zip
- Update to 0.99.10.5
- Fix OPTIONS handling PR: ports/67351 Submitted by: Robin Breathe <robin@isometry.net> (maintainer)
Diffstat (limited to 'mail/dovecot')
-rw-r--r--mail/dovecot/Makefile20
-rw-r--r--mail/dovecot/distinfo4
-rw-r--r--mail/dovecot/files/patch-dovecot-example.conf38
3 files changed, 19 insertions, 43 deletions
diff --git a/mail/dovecot/Makefile b/mail/dovecot/Makefile
index f6f18e1663ce..27289f294ca9 100644
--- a/mail/dovecot/Makefile
+++ b/mail/dovecot/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= dovecot
-PORTVERSION= 0.99.10.4
-PORTREVISION= 2
+PORTVERSION= 0.99.10.5
CATEGORIES= mail ipv6
MASTER_SITES= http://www.dovecot.org/
@@ -17,6 +16,8 @@ COMMENT= Secure and compact IMAP and POP3 servers
USE_ICONV= yes
USE_REINPLACE= yes
+USE_RC_SUBR= yes
+
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --without-shadow --enable-ipv6 \
@@ -33,10 +34,14 @@ DOCS= auth.txt configuration.txt design.txt \
nfs.txt dovecot-ldap.conf dovecot-pgsql.conf \
dovecot-openssl.cnf securecoding.txt
+OPTIONS= SASL2 "SASL2 support" off \
+ VPOPMAIL "VPopMail support" off \
+ LDAP "OpenLDAP support" off \
+ PGSQL "PostgreSQL support" off
+
.include <bsd.port.pre.mk>
## SASL2 support
-OPTIONS+= SASL2 "SASL2 support" off
#
# SASL provides authentication support to
# session-based protocols. This is can be
@@ -48,7 +53,6 @@ CONFIGURE_ARGS+= --with-cyrus-sasl2
.endif
## VPopMail Support
-OPTIONS+= VPOPMAIL "VPopMail support" off
#
# vpopmail provides easy authentication and
# multi-domain features. It was originally
@@ -61,7 +65,6 @@ CONFIGURE_ARGS+= --with-vpopmail
.endif
## OpenLDAP Support
-OPTIONS+= LDAP "OpenLDAP support" off
#
# LDAP is the light-weight directory access
# protocol and can be used by Dovecot for its
@@ -73,7 +76,6 @@ CONFIGURE_ARGS+= --with-ldap
.endif
## PostgreSQL Support
-OPTIONS+= PGSQL "PostgreSQL support" off
#
# PostgreSQL is a powerful SQL database that
# can be used to store user tables.
@@ -83,12 +85,6 @@ LIB_DEPENDS+= pq.3:${PORTSDIR}/databases/postgresql7
CONFIGURE_ARGS+= --with-pgsql
.endif
-.if ${OSVERSION} >= 500038
-RC_SUBR?= /etc/rc.subr
-.else
-USE_RC_SUBR= yes
-.endif
-
pre-build:
@${REINPLACE_CMD} -e 's,%%SSLDIR%%,/var/dovecot/ssl,' \
${WRKSRC}/doc/mkcert.sh \
diff --git a/mail/dovecot/distinfo b/mail/dovecot/distinfo
index 1dd163f140bc..4bac4bf3a57e 100644
--- a/mail/dovecot/distinfo
+++ b/mail/dovecot/distinfo
@@ -1,2 +1,2 @@
-MD5 (dovecot-0.99.10.4.tar.gz) = 81eda7985e99d28acd6d286aa0e13e07
-SIZE (dovecot-0.99.10.4.tar.gz) = 859856
+MD5 (dovecot-0.99.10.5.tar.gz) = acda02c8bdcff5e194a8b9227ccb74b5
+SIZE (dovecot-0.99.10.5.tar.gz) = 863825
diff --git a/mail/dovecot/files/patch-dovecot-example.conf b/mail/dovecot/files/patch-dovecot-example.conf
index e4720be067da..95b0d407fd9f 100644
--- a/mail/dovecot/files/patch-dovecot-example.conf
+++ b/mail/dovecot/files/patch-dovecot-example.conf
@@ -1,11 +1,11 @@
---- dovecot-example.conf.orig Sun Nov 9 00:21:22 2003
-+++ dovecot-example.conf Sun Nov 16 16:14:35 2003
+--- dovecot-example.conf.orig Sat May 29 16:56:16 2004
++++ dovecot-example.conf Sat May 29 17:08:35 2004
@@ -7,11 +7,11 @@
# --with-ssldir=/etc/ssl
# Base directory where to store runtime data.
-#base_dir = /var/run/dovecot/
-+base_dir = /var/dovecot/
++base_dir = /var/dovecot
# Protocols we want to be serving:
# imap imaps pop3 pop3s
@@ -27,13 +27,13 @@
# certificate, just make sure to update the domains in dovecot-openssl.cnf
-#ssl_cert_file = /etc/ssl/certs/dovecot.pem
-#ssl_key_file = /etc/ssl/private/dovecot.pem
-+ssl_cert_file = %%SSLDIR%%/certs/imapd.pem
-+ssl_key_file = %%SSLDIR%%/private/imapd.pem
++ssl_cert_file = %%SSLDIR%%/certs/dovecot.pem
++ssl_key_file = %%SSLDIR%%/private/dovecot.pem
# SSL parameter file. Master process generates this file for login processes.
# It contains Diffie Hellman and RSA parameters.
-#ssl_parameters_file = /var/run/dovecot/ssl-parameters.dat
-+ssl_parameters_file = %%SSLDIR%%/parameters.dat
++ssl_parameters_file = %%SSLDIR%%/ssl-parameters.dat
# How often to regenerate the SSL parameters file. Generation is quite CPU
# intensive operation. The value is in hours, 0 disables regeneration
@@ -66,15 +66,6 @@
# Set max. process size in megabytes. If you don't use
# login_process_per_connection you might need to grow this.
-@@ -100,7 +100,7 @@
-
- # Number of login processes to create. If login_process_per_user is
- # yes, this is the number of extra processes waiting for users to log in.
--#login_processes_count = 3
-+#login_processes_count = 1
-
- # Maximum number of extra login processes to create. The extra process count
- # usually stays at login_processes_count, but when multiple users start logging
@@ -126,7 +126,7 @@
login = pop3
@@ -182,7 +173,7 @@
# Executable location
-#pop3_executable = /usr/libexec/dovecot/pop3
-+pop3_executable = %%PREFIX%%/libexec/dovecot/pop3
++#pop3_executable = %%PREFIX%%/libexec/dovecot/pop3
# Set max. process size in megabytes. Most of the memory goes to mmap()ing
# files, so it shouldn't harm much even if this limit is set pretty high.
@@ -195,18 +186,7 @@
##
## Authentication processes
-@@ -380,8 +380,8 @@
- # vpopmail: vpopmail library
- # ldap <config path>: LDAP, see doc/dovecot-ldap.conf
- # pgsql <config path>: a PostgreSQL database, see doc/dovecot-pgsql.conf
--#auth_userdb = passwd
--auth_userdb = pgsql /usr/local/etc/dovecot-pgsql.conf
-+#auth_userdb = pgsql %%PREFIX%%/etc/dovecot-pgsql.conf
-+auth_userdb = passwd
-
- # Where password database is kept:
- # passwd: /etc/passwd or similiar, using getpwnam()
-@@ -391,9 +391,9 @@
+@@ -390,9 +390,9 @@
# vpopmail: vpopmail authentication
# ldap <config path>: LDAP, see doc/dovecot-ldap.conf
# pgsql <config path>: a PostgreSQL database, see doc/dovecot-pgsql.conf
@@ -218,7 +198,7 @@
# Set max. process size in megabytes.
#auth_process_size = 256
-@@ -422,7 +422,7 @@
+@@ -421,7 +421,7 @@
# More verbose logging. Useful for figuring out why authentication isn't
# working.