aboutsummaryrefslogtreecommitdiffstats
path: root/mail/dspam
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2014-05-15 01:47:41 +0800
committergarga <garga@FreeBSD.org>2014-05-15 01:47:41 +0800
commit7cb98d4f5f6a7716e79c9fa2a2531c0f8c070d2a (patch)
tree60af86012db1e458813c44b44ca941637de1a41d /mail/dspam
parentb61eecc9512ae5214b6049fd67f7e280bbce26d8 (diff)
downloadfreebsd-ports-gnome-7cb98d4f5f6a7716e79c9fa2a2531c0f8c070d2a.tar.gz
freebsd-ports-gnome-7cb98d4f5f6a7716e79c9fa2a2531c0f8c070d2a.tar.zst
freebsd-ports-gnome-7cb98d4f5f6a7716e79c9fa2a2531c0f8c070d2a.zip
. Move USE_AUTOTOOLS=libtool to USES=libtool
. Drop .la files . Use shebangfix for necessary files . Use @sample, @owner, @group and @mode to modernize plist . Try to remove LOG_DIR on pkg-plist Approved by: portmgr (blanket)
Diffstat (limited to 'mail/dspam')
-rw-r--r--mail/dspam/Makefile22
-rw-r--r--mail/dspam/pkg-plist23
2 files changed, 25 insertions, 20 deletions
diff --git a/mail/dspam/Makefile b/mail/dspam/Makefile
index 59f3461177e7..8f1c4829a9b1 100644
--- a/mail/dspam/Makefile
+++ b/mail/dspam/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dspam
PORTVERSION= 3.9.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= mail
MASTER_SITES= SF \
http://T32.TecNik93.com/FreeBSD/ports/${PORTNAME}/sources/
@@ -74,8 +74,7 @@ OPTIONS_DEFAULT= SYSLOG DEBUG DAEMON CLAMAV CLAMAV_LOCAL \
HASH MYSQL MYSQL_COMPRESS PGSQL SQLITE3
MAKE_JOBS_UNSAFE= yes
-USES= perl5
-USE_AUTOTOOLS= libtool
+USES= perl5 libtool shebangfix
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
@@ -83,6 +82,16 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS+= ${PTHREAD_CFLAGS}
+SHEBANG_FILES= src/tools/dspam_logrotate \
+ src/tools/dspam_notify.pl \
+ src/tools/dspam_train.in \
+ webui/cgi-bin/templates/de/strings.pl \
+ webui/cgi-bin/templates/strings.pl \
+ webui/cgi-bin/templates/fr/strings.pl \
+ webui/cgi-bin/templates/es-es/strings.pl \
+ webui/cgi-bin/templates/pt-br/strings.pl \
+ webui/cgi-bin/*.cgi
+
.ifdef(GDBS)
CFLAGS+= -g -DDEBUG
STRIP=
@@ -490,10 +499,6 @@ pre-configure:
.endif
post-install:
- ${CP} ${WRKSRC}/src/dspam.conf ${WRKSRC}/src/dspam.conf.sample
- cd ${WRKSRC}/src/ && \
- ${INSTALL_DATA} dspam.conf.sample ${STAGEDIR}${PREFIX}/etc
-
########
# stupid hack until I figure out where/how to patch
@${MKDIR} ${STAGEDIR}${PREFIX}/libdata/pkgconfig
@@ -525,9 +530,6 @@ post-install:
.endif # NOPORTEXAMPLES
.if ${PORT_OPTIONS:MWEBUI}
-. for I in admin.cgi admingraph.cgi configure.pl dspam.cgi graph.cgi templates/strings.pl
- ${REINPLACE_CMD} -e "s,/usr/bin/perl,${PERL},g" ${WRKSRC}/webui/cgi-bin/${I}
-. endfor
${MV} ${WRKSRC}/webui/cgi-bin/configure.pl ${WRKSRC}/webui/cgi-bin/configure.pl.sample
cd ${WRKSRC}/webui/cgi-bin && ${MKDIR} ${STAGEDIR}${WWWDIR} && \
${INSTALL_SCRIPT} configure.pl.sample ${STAGEDIR}${WWWDIR}/ && \
diff --git a/mail/dspam/pkg-plist b/mail/dspam/pkg-plist
index 2db63a81db8a..bb125584e8e8 100644
--- a/mail/dspam/pkg-plist
+++ b/mail/dspam/pkg-plist
@@ -14,11 +14,13 @@ bin/dspam_merge
%%PGSQL%%bin/dspam_pg2int8
bin/dspam_stats
bin/dspam_train
-@unexec if cmp -s %D/etc/dspam.conf %D/etc/dspam.conf.sample; then rm -f %D/etc/dspam.conf; fi
-etc/dspam.conf.sample
-@exec chown %%DSPAM_OWNER%%:%%DSPAM_GROUP%% %D/%F
-@exec chmod 640 %D/%F
-@exec cp -np %D/%F %B/dspam.conf
+@owner %%DSPAM_OWNER%%
+@group %%DSPAM_GROUP%%
+@mode 640
+@sample etc/dspam.conf.sample
+@mode
+@group
+@owner
include/dspam/buffer.h
include/dspam/config.h
include/dspam/config_shared.h
@@ -35,9 +37,9 @@ include/dspam/read_config.h
include/dspam/storage_driver.h
include/dspam/tokenizer.h
lib/libdspam.a
-lib/libdspam.la
lib/libdspam.so
lib/libdspam.so.7
+lib/libdspam.so.7.0.0
man/man1/dspam.1.gz
man/man1/dspam_clean.1.gz
man/man1/dspam_dump.1.gz
@@ -54,21 +56,21 @@ man/man3/dspam_getsource.3.gz
man/man3/dspam_destroy.3.gz
man/man3/dspam_detach.3.gz
%%DYNAMIC%%%%HASH%%lib/dspam/libhash_drv.a
-%%DYNAMIC%%%%HASH%%lib/dspam/libhash_drv.la
%%DYNAMIC%%%%HASH%%lib/dspam/libhash_drv.so
%%DYNAMIC%%%%HASH%%lib/dspam/libhash_drv.so.7
+%%DYNAMIC%%%%HASH%%lib/dspam/libhash_drv.so.7.0.0
%%DYNAMIC%%%%MYSQL%%lib/dspam/libmysql_drv.a
-%%DYNAMIC%%%%MYSQL%%lib/dspam/libmysql_drv.la
%%DYNAMIC%%%%MYSQL%%lib/dspam/libmysql_drv.so
%%DYNAMIC%%%%MYSQL%%lib/dspam/libmysql_drv.so.7
+%%DYNAMIC%%%%MYSQL%%lib/dspam/libmysql_drv.so.7.0.0
%%DYNAMIC%%%%PGSQL%%lib/dspam/libpgsql_drv.a
-%%DYNAMIC%%%%PGSQL%%lib/dspam/libpgsql_drv.la
%%DYNAMIC%%%%PGSQL%%lib/dspam/libpgsql_drv.so
%%DYNAMIC%%%%PGSQL%%lib/dspam/libpgsql_drv.so.7
+%%DYNAMIC%%%%PGSQL%%lib/dspam/libpgsql_drv.so.7.0.0
%%DYNAMIC%%%%SQLITE%%lib/dspam/libsqlite3_drv.a
-%%DYNAMIC%%%%SQLITE%%lib/dspam/libsqlite3_drv.la
%%DYNAMIC%%%%SQLITE%%lib/dspam/libsqlite3_drv.so
%%DYNAMIC%%%%SQLITE%%lib/dspam/libsqlite3_drv.so.7
+%%DYNAMIC%%%%SQLITE%%lib/dspam/libsqlite3_drv.so.7.0.0
@dirrm lib/dspam
libdata/pkgconfig/dspam.pc
%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
@@ -226,5 +228,6 @@ firstrun.txt.sample
firstspam.txt.sample
quarantinefull.txt.sample
@cwd /
+@dirrmtry %%LOG_DIR%%
@dirrm %%DSPAM_HOME%%
@exec chown %%DSPAM_HOME_OWNER%%:%%DSPAM_HOME_GROUP%% %%DSPAM_HOME%%