aboutsummaryrefslogtreecommitdiffstats
path: root/mail/dspampd/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-10-22 06:01:40 +0800
committerpav <pav@FreeBSD.org>2005-10-22 06:01:40 +0800
commitfea66081670611d4b737d2ff32a17bd11645ea0e (patch)
tree4b95cf75f61b0d727986f90de8806779c2d90acc /mail/dspampd/Makefile
parentfc2390479bbc1448502eb1be7a2ada12297dfe5e (diff)
downloadfreebsd-ports-gnome-fea66081670611d4b737d2ff32a17bd11645ea0e.tar.gz
freebsd-ports-gnome-fea66081670611d4b737d2ff32a17bd11645ea0e.tar.zst
freebsd-ports-gnome-fea66081670611d4b737d2ff32a17bd11645ea0e.zip
- Toggle default options to avoid conflicting dependencies
PR: ports/87691 Submitted by: Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com> (maintainer)
Diffstat (limited to 'mail/dspampd/Makefile')
-rw-r--r--mail/dspampd/Makefile26
1 files changed, 14 insertions, 12 deletions
diff --git a/mail/dspampd/Makefile b/mail/dspampd/Makefile
index fd437626ba78..6e21f33f5084 100644
--- a/mail/dspampd/Makefile
+++ b/mail/dspampd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= dspampd
PORTVERSION= 2.00.r2
+PORTREVISION= 1
CATEGORIES= mail perl5
MASTER_SITES= http://caspian.dotconf.net/menu/Software/DspamPD/ \
http://people.tecnik93.com/~itetcu/FreeBSD/ports/dspampd/sources/
@@ -20,15 +21,14 @@ WRKSRC= ${WRKDIR}/dspampd-v2.00-rc2
USE_PERL5_RUN= YES
USE_RC_SUBR= YES
-OPTIONS= DSPAM "Use stable dspam as anti-spam module" off
-OPTIONS+= DSPAM_DEVEL "Use devel dspam as antispam module" on
+OPTIONS= DSPAM "Use stable dspam as anti-spam module" on
+OPTIONS+= DSPAM_DEVEL "Use devel dspam as antispam module" off
OPTIONS+= DSPAM_VIRT_USERS "Non-system users in dspam" off
-OPTIONS+= CLAMAV "Use clamav as antivir module" off
-OPTIONS+= CLAMAV_DEVEL "Use clamav as antivir module" on
+OPTIONS+= CLAMAV "Use clamav as antivir module" on
+OPTIONS+= CLAMAV_DEVEL "Use clamav as antivir module" off
#OPTIONS+= TIME_HIRES "" on
NO_BUILD= YES
-#NO_INSTALL= YES
USE_REINPLACE= YES
CONF_DIR= ${PREFIX}/etc/dspampd
@@ -56,13 +56,6 @@ SED_CONF_SCRIPT+= -e "s,%%CONF_DIR%%,${CONF_DIR},g"
.include <bsd.port.pre.mk>
-# defaults for package building
-.ifndef(WITH_DEVEL) && !defined(WITH_DSPAM_DEVEL) && \
- !defined(WITH_CLAMAV) && !defined(WITH_CLAMAV_DEVEL)
-WITH_DSPAM_DEVEL= on
-WITH_CLAMAV_DEVEL= on
-.endif
-
.ifdef(WITH_DSPAM)
RUN_DEPENDS+= dspam:${PORTSDIR}/mail/dspam
.endif
@@ -93,6 +86,15 @@ SED_CONF_SCRIPT+= -e "s,%%CLAMAV%%,clamd,"
SED_CONF_SCRIPT+= -e "/%%CLAMAV%%/D"
.endif
+pre-everything::
+ @${ECHO_CMD} "##########################################################"
+ @${ECHO_CMD} " Please use mail/dsapm-devel, it's better."
+ @${ECHO_CMD} "There are reports of an infinite cycle with newer perl"
+ @${ECHO_CMD} "versions; please send a mail with your working/non-working"
+ @${ECHO_CMD} "perl version so that this port can be marked accordingly;"
+ @${ECHO_CMD} "or send a patch ;)"
+ @${ECHO_CMD} "##########################################################"
+
pre-extract:
@${ECHO_CMD}
@${ECHO_CMD} "Define, if you need:"