aboutsummaryrefslogtreecommitdiffstats
path: root/mail/elmo/Makefile
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2004-08-07 15:40:19 +0800
committeradamw <adamw@FreeBSD.org>2004-08-07 15:40:19 +0800
commit6fa1840da40f42b03300250a457272687aa42984 (patch)
tree72144827a3915652745efe5ca2e8d715e10736fe /mail/elmo/Makefile
parentaf5bc4fece56f19e7605ada5ad037aa2786e8d5c (diff)
downloadfreebsd-ports-gnome-6fa1840da40f42b03300250a457272687aa42984.tar.gz
freebsd-ports-gnome-6fa1840da40f42b03300250a457272687aa42984.tar.zst
freebsd-ports-gnome-6fa1840da40f42b03300250a457272687aa42984.zip
Update to 1.2.0. Lots of tweaks. Much has changed since the
previous version. This port hasn't been updated since it was committed, and the maintainer hasn't responded to any messages I've sent about it, so I'm removing him as maintainer. I'll hold maintainership of this port for a little bit in case the former maintainer wants it back.
Diffstat (limited to 'mail/elmo/Makefile')
-rw-r--r--mail/elmo/Makefile73
1 files changed, 28 insertions, 45 deletions
diff --git a/mail/elmo/Makefile b/mail/elmo/Makefile
index 1c67460e313c..abf4a8d9d00f 100644
--- a/mail/elmo/Makefile
+++ b/mail/elmo/Makefile
@@ -6,55 +6,38 @@
#
PORTNAME= elmo
-PORTVERSION= 0.8.3
-PORTREVISION= 3
+PORTVERSION= 1.2.0
CATEGORIES= mail
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S/$/:sf/} \
- ${MASTER_SITE_SAVANNAH:S/$/:sav/}
-MASTER_SITE_SUBDIR= ${PORTNAME}/:sf \
- ${PORTNAME}/unstable.pkg/${PORTVERSION}/:sav
-DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:sf,sav
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= trevor@FreeBSD.org
+MAINTAINER= adamw@FreeBSD.org
COMMENT= Receive, filter, read, compose and send mail at the text console
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CFLAGS="${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}"
-INFO= elmo
-MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}" \
- PTHREAD_CFLAGS="${PTHREAD_CFLAGS}"
-MAN1= elmo.1 elmoconf.pl.1
-PLIST= ${WRKDIR}/pkg-plist
USE_GETTEXT= yes
USE_ICONV= yes
-USE_PERL5= yes
-
-pre-extract:
- @${CAT} ${PKGMESSAGE}
- @${ECHO_CMD} sleeping ten seconds--press control-C to cancel build
- @${ECHO_CMD} 
- @sleep 10
-
-pre-install:
- ${RM} -f ${PLIST}
-.for ii in elmo elmoconf.pl
- ${ECHO_CMD} bin/${ii} >> ${PLIST}
-.endfor
-.for ii in de pl
- ${ECHO_CMD} share/locale/${ii}/LC_MESSAGES/elmo.mo >> ${PLIST}
-.endfor
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/elmo ${PREFIX}/bin/
- ${INSTALL_SCRIPT} ${WRKSRC}/src/elmoconf.pl ${PREFIX}/bin/
-.for ii in ${MAN1}
- ${INSTALL_MAN} ${WRKSRC}/doc/${ii} ${MANPREFIX}/man/man1
-.endfor
-.for ii in de pl
- ${INSTALL_DATA} ${WRKSRC}/po/${ii}.gmo \
- ${PREFIX}/share/locale/${ii}/LC_MESSAGES/elmo.mo
-.endfor
- ${INSTALL_DATA} ${WRKSRC}/doc/elmo.info ${PREFIX}/info/
- - install-info --info-dir=${PREFIX}/info ${PREFIX}/info/elmo.info
-
-.include <bsd.port.mk>
+USE_OPENSSL= yes
+USE_PERL5_RUN= yes
+USE_REINPLACE= yes
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+MAN1= elmo.1 elmoconf.pl.1
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/lib/libgpgme.so) || defined(WITH_GPGME)
+LIB_DEPENDS+= gpgme:${PORTSDIR}/security/gpgme
+.else
+pre-everything::
+ @${ECHO_CMD}
+ @${ECHO_CMD} "Define WITH_GPGME=yes to build with gpgme support."
+ @${ECHO_CMD}
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|/usr/bin/env perl|${PERL}|" \
+ ${WRKSRC}/src/elmoconf.pl
+
+.include <bsd.port.post.mk>