aboutsummaryrefslogtreecommitdiffstats
path: root/mail/enigmail-thunderbird
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2008-04-22 15:42:39 +0800
committerale <ale@FreeBSD.org>2008-04-22 15:42:39 +0800
commit5135d52d4dd052ea398bdc84d3a28d1b312c662f (patch)
treecdb6f336abec16e92beb402242d370a488d15e58 /mail/enigmail-thunderbird
parent874a5f6e0dc633927f4760fb9ebbaa46f9632e9d (diff)
downloadfreebsd-ports-gnome-5135d52d4dd052ea398bdc84d3a28d1b312c662f.tar.gz
freebsd-ports-gnome-5135d52d4dd052ea398bdc84d3a28d1b312c662f.tar.zst
freebsd-ports-gnome-5135d52d4dd052ea398bdc84d3a28d1b312c662f.zip
Use gcc 3.4 to build enigmail for thunderbird on amd64 (and FreeBSD >= 7).
This should fix the enigmail crash. PR: ports/117285 Submitted by: delphij
Diffstat (limited to 'mail/enigmail-thunderbird')
-rw-r--r--mail/enigmail-thunderbird/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/mail/enigmail-thunderbird/Makefile b/mail/enigmail-thunderbird/Makefile
index d30b496630b4..f168401e6586 100644
--- a/mail/enigmail-thunderbird/Makefile
+++ b/mail/enigmail-thunderbird/Makefile
@@ -44,6 +44,12 @@ XPI_FILE= ${DISTNAME}-${GECKO}-freebsd-${ARCH}.xpi
PLIST_FILES= %%DATADIR%%/${XPI_FILE}
PLIST_DIRS= %%DATADIR%%
+.include <bsd.port.pre.mk>
+
+.if ${GECKO} == "thunderbird" && ${ARCH} == "amd64" && ${OSVERSION} >= 700000
+USE_GCC= 3.4
+.endif
+
do-extract:
@${RM} -rf ${WRKDIR}
@${MKDIR} ${WRKDIR}
@@ -68,4 +74,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>