aboutsummaryrefslogtreecommitdiffstats
path: root/mail/esmtp
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-06-29 21:33:41 +0800
committerkrion <krion@FreeBSD.org>2004-06-29 21:33:41 +0800
commita80ec59f64f04b37ee18c960d7135ea324fc865d (patch)
tree13011131b47ad2fe4d6f2894350ebf34091b435c /mail/esmtp
parent06983d1bec730544cd2c1c16391cc3957746c282 (diff)
downloadfreebsd-ports-gnome-a80ec59f64f04b37ee18c960d7135ea324fc865d.tar.gz
freebsd-ports-gnome-a80ec59f64f04b37ee18c960d7135ea324fc865d.tar.zst
freebsd-ports-gnome-a80ec59f64f04b37ee18c960d7135ea324fc865d.zip
Add patch which disables annoying log warnings when only auth
is used. Submitted by: Bohdan Horst <nexus@irc.pl>
Diffstat (limited to 'mail/esmtp')
-rw-r--r--mail/esmtp/Makefile2
-rw-r--r--mail/esmtp/files/patch-smtp.c33
2 files changed, 34 insertions, 1 deletions
diff --git a/mail/esmtp/Makefile b/mail/esmtp/Makefile
index bece41f42ae3..9f6027633e69 100644
--- a/mail/esmtp/Makefile
+++ b/mail/esmtp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= esmtp
PORTVERSION= 0.5.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/mail/esmtp/files/patch-smtp.c b/mail/esmtp/files/patch-smtp.c
new file mode 100644
index 000000000000..6c6334512041
--- /dev/null
+++ b/mail/esmtp/files/patch-smtp.c
@@ -0,0 +1,33 @@
+
+$FreeBSD$
+
+--- smtp.c.orig Fri Nov 7 12:47:16 2003
++++ smtp.c Tue Jun 29 15:27:29 2004
+@@ -426,9 +426,14 @@
+ goto failure;
+
+ /* Do what's needed at application level to use authentication. */
+- authctx = auth_create_context ();
+- auth_set_mechanism_flags (authctx, AUTH_PLUGIN_PLAIN, 0);
+- auth_set_interact_cb (authctx, authinteract, identity);
++ if(identity->user || identity->pass)
++ {
++ authctx = auth_create_context ();
++ auth_set_mechanism_flags (authctx, AUTH_PLUGIN_PLAIN, 0);
++ auth_set_interact_cb (authctx, authinteract, identity);
++ }
++ else
++ authctx = NULL;
+
+ /* Use our callback for X.509 certificate passwords. If STARTTLS is not in
+ * use or disabled in configure, the following is harmless.
+@@ -560,7 +565,8 @@
+ fputc('\n', log_fp);
+
+ smtp_destroy_session (session);
+- auth_destroy_context (authctx);
++ if(authctx)
++ auth_destroy_context (authctx);
+ auth_client_exit ();
+
+ return;